Laptops General - Read Only

2 Bronze

Dell N5110 bios issue when using caddy+SSD instead of ODD

My notebook is still under warranty. Bought an OCZ SSD and using a caddy I've replaced the ODD and mounted the SSD.
I will need full disk encryption on both disks, without sacrificing SSD speeds. Also I will need to boot the SSD directly on power up. Using A11 bios (latest), but I find it buggy because of the following issues:

- The SSD cannot be booted directly. Bios doesn't support choosing which HDD's to boot first, and always boots the internal HDD. Software bootloader on the internal HDD pointing to the second drive(SSD) doesn't work too. It seems the BIOS doesn't initialize the SATA ODD slot at boot for some reason.
- The BIOS doesn't support ATA password for the SSD when plugged instead of ODD. It always sets password for the internal HDD. Also, if I enable ATA password with hdparm, it doesn't unlock the drive.
- pressing F12 and choosing "Hard-drive" does boot the SSD because it skips the internal HDD if it doesn't find any bootloader there and then it boots the SSD normally. But still it's annoying I have to press F12 at every reboot and also I can't use ATA password for the SSD.

My goal is to make the laptop boot the SSD, with or without F12, and have it recognize an ATA password for drive unlocking.

An solution is swaping the HDD with the SSD internally. But that isn't covered by the warranty. Can it be done under warranty somehow, free or paid?

Please help me, thanks.

Replies (12)
10 Diamond

The hard drive in this model isn't considered customer-replaceable (and it's anything but easy to replace - you have to strip the system down to bare metal to get to the drive).

2 Bronze

Well, I managed to make the bios recognize ATA password on the SSD. If i use hdparm tool to activate the password, the bios does ask for SSD disk password. But the password I set in hdparm is not working in the BIOS because of the character mapping system.

Info here: thaeial.blogspot.ro/.../locking-and-unlocking-hdd-with-dell.html

I tried using the character mapping explained here: www.ee.bgu.ac.il/.../ScanCodes.htm

But didn't worked out.

Any help how to activate password into hdparm and make it work with the DELL bios?

2 Bronze

What happens for example if my laptop will brick and I want to use the internal HDD in another system?

How does the password I knew from the Dell BIOS works in another BIOS?

2 Bronze

I had a similar problem when I installed my Samsung 840 Pro + cadddy in my ODD. I have a 17R Inspiron N7110.

The SSD is recognized in the main BIOS screen but not in the boot order screen. I set my boot order like below and changed the HDD to inactive from active. It booted the SSD first.

This boot order boots the SSD first:

CD/DVD

USB storage device It booted the SSD first.

removable drive

eSATA

- Hard Drive
--- ST1000 hard drive

- Network
--- Realtek PXE B03 DOO

2 Bronze

By "USB storage device It booted the SSD first." you mean I need to have USB device plugged in? Or typing error when copy paste?

I will try this but if it works, it still doesn't help me set an ATA password on the SSD that can be unlocked in the BIOS.

Because BIOS always sets password for SATA port 0 which is the HDD.

Also as I've mentioned, using 3rd party tools like hdparm don't work because the BIOS uses some crazy character mapping and typing the password I've set in hdparm doesn't work. BUT IT DOES ask for  the SSD ATA password, so if someone from Dell can tell me how the character mapping works in the BIOS i should sort this out!

10 Diamond

It is absolutely vital that BEFORE you set up any hard drive password, you realize that the hard drive then becomes tied to the system - if the system fails, you cannot simply put the hard drive in another system and read it.  The only way to recover data once you set the hard drive password is to send the drive to a data recovery service.

ANY type of hard drive locking password or encryption scheme makes recovering data very, very difficult.  Be absolutely sure you keep an UNENCRYPTED backup of your data in a safe place at all times.

2 Bronze

I'm sorry!  "USB storage device It booted the SSD first." is an error. It should simply be USB storage device. As long as hard drive was after CD/DVD, USB storage device, removable drive and eSATA, it would boot the SSD first. You can change those 4 devices' order around and it would still boot the SSD first. I always kept the network last because I didn't have a network. It too could be ahead of hard drive in the boot order and it should still boot the SSD first.

I also moved the bootmgr to the C partition using easyBCD:  www.sevenforums.com/.../209885-bootmgr-move-c-easybcd.html

The method with HDD passwords and hdparm is beyond me. I can't help you with those things. I just changed my boot order and it worked even though the SSD wasn't even seen (listed) in the boot order priority screen. Maybe easyBCD was the key. All I know is that my SSD boots first and I didn't have to get into the things that you are trying.

Good luck with yours!

2 Bronze

@enj63

Well, not true if I set the password with hdparm and identify the character mapping of the BIOS when sending the password to the disk. But I don't think Dell wants to help.

 

Tried setting the boot priority in that order but still doesn't work. At least F12 works.

2 Bronze

Sorry the boot priority didn't work for you.

Give easyBCD a whirl. It might fix you up.

I used some of the information in the following tutorial when I installed my SSD: www.sevenforums.com/.../149969-ssd-install-transfer-operating-system.html

Top Contributor
Latest Solutions
comment leaving this incase mobile wants to be turned on again