Laptops General - Read Only

Last reply by 05-22-2017 Solved
Start a Discussion
2 Bronze
2 Bronze
43637

Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

I have a brand new XPS 13 9365, It boots find to windows but I'm having difficulty installing Linux.

1) Secure boot is disabled

2) The laptop will boot to the Ubuntu installer on a USB drive when in SATA-RAID mode, but Linux cannot see the SSD in RAID mode.

3) The laptop hangs on boot and will not boot the USB drive when in SATA-AHCI mode, I have verified the boot order. Also when in AHCI mode it takes over 5 minutes to get into the BIOS menu.

I'm running the latest 1.0.5 bios.

Is this a bug in the BIOS similar to what was seen with AHCI on the 9360 last year?

Please provide feedback on how the Developer Edition of the 9365 is configured.


Thanks

Casey

Replies (39)
2 Bronze
2 Bronze
8026

As explained in the answer by wahwah80, to be able to see the boot drive, you need to be in AHCI mode AND uncheck the "Legacy ROM" option in advanced boot options

5 Rhenium
8026

For Linux to see the drive, it has to be in AHCI mode.  For the drivers to be loaded, you have to boot the install media in UEFI mode.  Any device wanted to be booted as UEFI has to be available before boot or reboot so it can be read.

I know Ubuntu can boot as UEFI and Secure boot.  I am not sure about any other versions.

If you are imaging a system originally running as RAID, you may have to go through the process which uses msconfig.exe to switch SATA controllers.  

My 9365 runs Win 10 fine on a Samsung 960 Pro as PCIe and I did try Ubuntu also, which did see the drive and install.  Ubuntu would not see the drive is in RAID mode.  I am running the latest Bios.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
System fully Win 11 compliant
2 Bronze
2 Bronze
8026

I have this problem but have had no success even when using a WinPE disk!!! This is a bugger!

I have a client that has a normal Windows 10 Pro XPS 13 9365. SSD is listed as Samsung 961.

I switched to AHCI mode (painfully slow, grueling, annoying boot process once switched over)

BIOS/UEFI and everything else updated and the most recent blah blah blah..

I can boot into various recovery boot disks (cd or USB) regardless if it is in RAID or AHCI mode BUT none of my recovery or imaging disks see the boot drive!

Example - Acronis (linux based boot cd) works fine but cannot find boot drive.

Macrium Reflect - works fine as a boot disk created with latest WinPE files for W10, but does not see boot NVME drive.

Anyone have any suggestions?

2 Bronze
2 Bronze
8026

In January I ordered a 7510 Developer laptop running UBUNTU.  I could not boot from the USB port unless ALL hard drives were disabled.  Dell had me send the machine back after the second machine they sent had the same issue.  Dell stated it was an Engineering problem.  I never heard about a fix or the reason why it would not boot.  Does anyone have experience with the 9360 developer UBUNTU 16.04 ?  Will it boot from the USB port?

5 Rhenium
8026

Because in RAID mode (as the 9365 ships) linux won't see any drive it can install to.

I agree.  I used the live version of kernel 16.10 to check for the drive.  In AHCI/Disabled the drive was visible but in RAID it was not..  Possibly no SATA drivers being loaded for that configuration.

I did not have any problems booting the USB media and no Bios changes were necessary regarding Secure Boot or anything other than the SATA situation.

I did have to get another pair of glasses to see what was on the screen.. ;)

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
System fully Win 11 compliant
2 Bronze
2 Bronze
8026

Still not sure why you folks needed to change the SATA settings.  Linux should have installed fine on the Faux SATA drive, but I have not tried on this configuration.

Because in RAID mode (as the 9365 ships) linux won't see any drive it can install to. Hence we need the drive to be in AHCI mode for installation of Linux. This was mentioned and verified by multiple users in this thread, including me.

2 Bronze
2 Bronze
8026

If you already have a pre-installed OS like windows like Windows 10 then it won't allow to install old version of OS like, xp and windows 7.  The best idea is to either disable from BOOT section (please note that is diff between bios and cmos) and then install via bootable cd, i have seen that many times booting from pen drives takes lot of time.

5 Rhenium
8026

1. msconfig in windows 10. Set safe boot option. This is necessary as windows won't boot normally once AHCI set.

2. reboot and enter bios (F12)

3. uncheck legacy ROM option and switch from RAID to AHCI

4. let windows 10 boot in safe mode

5. run msconfig and uncheck the safe boot option

6. Reboot into Windows (should work now)

Thanks for checking that process.  We have been using in Windows for years I just wasn't sure it would work with this configuration.  I have reinstalled the original drive and can confirm the process works.

Still not sure why you folks needed to change the SATA settings.  Linux should have installed fine on the Faux SATA drive, but I have not tried on this configuration.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
System fully Win 11 compliant
5 Rhenium
8026

Nothing sees the PCIe drive in RAID mode, not even Windows.  It runs as a SATA drive and that is how my one week old 9365 was configured.

I am now running a Samsung 960 Pro which is recognized fine in Windows as a PCIe drive.  I do not know if Windows will pick up the Toshiba as a PCIe drive or not since mine came configured as SATA (RAID) and I did not try to reconfigure it.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
System fully Win 11 compliant
2 Bronze
2 Bronze
18087

In my case deactivating the legacy ROM option has solved the delay during POST and allowed me to boot!

I did the following:

1. msconfig in windows 10. Set safe boot option. This is necessary as windows won't boot normally once AHCI set.

2. reboot and enter bios (F12)

3. uncheck legacy ROM option and switch from RAID to AHCI

4. let windows 10 boot in safe mode

5. run msconfig and uncheck the safe boot option

6. Reboot into Windows (should work now)

7. Reboot and install Linux from USB media

Latest Solutions
Top Contributor