Laptops General - Read Only

2 Bronze

Sleep Issues and Wake Up Issues-xps 13


I am having a lot of issues with my new XPS 13. The computer is not going to sleep after having the laptop lid closed, it just burns through its power supply. I have checked all setting and it should not be doing this.

Also, I am having wake up issues sometimes when I close it and open it up again within a short frame of time, say, 5-10 minutes. The screen will remain black and I will have to restart the machine.

Is there a patch or driver I can install to resolve this? This is really frustrating from such a high-end machine, opening and closing should be the least of my concerns...



Solutions (2)

Accepted Solutions
2 Bronze

in my case - dell xps13 9360 - disabeling the connected standby mode helped:

  1. Start the registry editor (regedit.exe).
  2. Move to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power.
  3. Double-click CsEnabled and set to 0, then click OK.
  4. Reboot


since then the sleep mode works like it should be

(also disable the power saving option "allow to turn off the device" of the wifi adapter in the device manager - otherwise it takes a too long time to re-enable the wifi after reactivate from sleep mode)

since a new wifi-driver the wakeup from standby is faster with "allow to turn off the device" option enabled

View solution in original post

Community Accepted Solution
2 Bronze

Spot on, this worked perfectly for me and seems to have completely solved my sleep problem where closing the lid or telling it to sleep would turn off the screen but leave the computer running.  Seems to function as it should now.


View solution in original post

Community Accepted Solution
Replies (21)


What is the exact system model? What is the current OS installed on the system?

If the system was working fine earlier, then perform system restore to restore the machine to an earlier point where it was working fine.

Update the BIOS - - enter the service tag and download the BIOS, update and restart the machine and check.

Reinstall the chipset drivers and the video drivers from the vendor site - or (if applicable)

Create a new local admin account and check. 

If you are unable to find the required drivers and relevant info, then provide the exact system model and the OS installed on the machine and I can provide the right links.

Keep us updated.

2 Bronze

Hello Rishi 

It's an XPS 13 9350 running Windows 10 Pro (Version 1511, OS Build 10586.318)

System restore is pointless, this has been happening since I got the machine. Pls send me the exact links and I will try those. Thank you,



Hi Henry,

What is the exact issue with the machine? Kindly post a detailed description.

Does this happen with auto sleep or manual sleep? Do shutdown / restart and hibernate work fine?

Update the BIOS - - restart the system and check.

Reinstall the video drivers -

Try the local admin account -

Write me a private conversation with the service tag and your contact details(Name and Email) for case records.

Keep us updated.

2 Bronze

Hi, I am having a similar issue on my Dell XPS 13 9350 core i7

My computer will not sleep/hibernate as it should, especially manually.  I close the lid, or press the power button (I have it set up that way in order to sleep/hibernate).  The problem is many times (with no pattern), i will sleep the computer, only to come at a later time, with the battery drained.  

Any ideas?

The exact model I have is:

Dell XPS 13 9350 core i7, Windows 10 Home.  Version 1511.  OS Build 10586.420

Thank you

2 Bronze

I have the same issues with my XPS 15. The screen goes black and had to hard reset so I can keep using it (which makes me lose hours of work everytime making me send a return of this machine after using it for just a month). I think most of its problems is that expensive NVIDIA card.

I used to wake up with my "sleeping" computer drained of battery and burning. If your problem happens during the night like it used to happen to me I think that you can reduce it by disabling wake timers.

First, check if I have a wake timer by entering the following like in command prompt: powercfg /waketimers

If you have one, try enabling and disabling automatic maintenance: Control Panel > System and Security > Security and Maintenance > Maintenance > Change maintenance settings. Check Allow scheduled maintenance to wake up my computer at the scheduled time and click OK. Then enter again, uncheck it and click OK.

After that I runned powercfg /waketimers again in command prompt and it didn't have wake timers: "There are no active wake timers in the system" which I think reduced if not eliminated the times the computer woke up from sleep.

Hope it helps.



Does the system restart and shutdown fine?

Please try the steps as advised in my last response to Henry. This might help resolve the issue.

Write me a private conversation with the service tag and your contact details(Name and Email) for case records.

Keep us updated.

2 Bronze

Hi, thanks for your answer...I had already checked this, and no...There was nothing there, so that is/was not causing the issue.
Anyways, thanks for helping!

2 Bronze

Hi Rishi, 

Yes, the system restarts and shutdown is just fine.

You are telling me I should:

Update the BIOS (restart the system and check) and Reinstall the video drivers ?

Thanks again.

I await your reply before continuing! (Also I do not know how to answer you as a private conversation, my apologies!)

2 Bronze

Hi Rishi, I do not know if the private message went through:

I have checked the BIOS and have the latest update, version 1.3.3 updated mid April (issue was already going on before and still is after the update).

As far as the video driver... I currently have version:, the Intel Driver utility update recommends Version:, but it also says: "A customized computer manufacturer driver is installed on your computer.  Installing a generic Intel driver instead of the customized computer manufacture driver may case technical issues. Contact your computer manufacturer for the latest driver for your computer." 

Should I go ahead and do this update? 
What other thing may be causing the problem?
Thanks again!

Top Contributor
Latest Solutions