Latitude

Last reply by 08-08-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1240

E5440 BIOS upgrade doesn't happen

I have some Latitude E5440 where I want to upgrade the BIOS. One had A05 and successfully upgraded to A23. I have at least two E5440 with an A01 BIOS which don't perform an update. Not to A04 or to A05, not a reflash of A01 or a Downgrade to A00. I tried to switch of virtualisation, I tried the BIOS upgrade directly from BIOS boot menu, with freedos and with Windows 10. The BIOS rescue ([ESC]+[CTRL] while plugging power in) will not boot the BIOS_IMG.rcv (A01/A05/A21/A23 tested) even the /b=E5440A05.exe /forceit options on the A01 BIOS.exe will not work. Any other option I miss?
Labels (1)
Replies (2)
2 Bronze
2 Bronze
714

try this save the bios update file in a folder (probably bios) on your C drive

when starting up hit F12 to get the boot menu

there's an option to do a Bios update from that menu

select the folder and the file and update through that menu

106

How do i do that

Latest Solutions
Top Contributor