Last reply by 01-30-2023 Unsolved
Start a Discussion
1 Amber
1 Amber

E5570 BIOS Update 1.27.3 - Not Updating During the Reboot


One of our Latitude E5570s is not completing the BIOS update. The current BIOS version is 1.23.3 attempting to update to the latest version of 1.27.3

I have attempted the update from:

  1. Command Update
  2. Downloading the update from - unpacking it and rebooting
  3. Update BIOS from the Startup menu (F12) 

No matter the update method, the behavior is the same. During the reboot, the update is not executed and the laptop posts and starts normally. No errors or messaging.

The machine is not docked and is plugged in during the update attempts.

Any help would be appreciated.


Reply (1)
2 Bronze
2 Bronze

I know this has been sitting for quite some time, and probably no longer an issue. But I had the same issue on a few of my Dell Latitude E5570's. The BIOS version was 1.23.3. I would run Command update, it would find and run update 1.34.3, say it was successful, and prompt for a reboot. The unit would reboot right back into Windows without doing the BIOS update. I tried downloading and running the latest update manually with the same results. I ended up going to Dells site and downloading the oldest BIOS version I could (1.24.3...I think it was). I ran that update and it worked. Then I was able to install the newest version...1.34.3.

Latest Solutions
Top Contributor