Last reply by 01-31-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

TPM Device Not Detected

I have a Dell Latitude 3380, and I get "Alert! TPM Device Not Detected".  I've tried removing the battery from the laptop for about 30 seconds, then putting it back in.  I've updated the BIOS.  I've tried taking the laptop off its charger, then rebooting.  I'm at a loss of what to do to removed the alert.

Replies (5)
7 Uranium

Did you enable TPM in the BIOS? Also there is a TPM firmware update available in the drivers section of the support page for the 3380.

Now if you are trying to install Windows 11 be aware that the 3380 is not supported by Dell for Windows 11 because it does not meet the system requirements set down by MS. Having said that you can install Windows 11 and bypass the TPM and Secure Boot requirements. This YouTube video will describe the procedure in detail.

-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with GIGABYTE B560M DS3H AC budget build with an i3 10100
Real work on a Latitude E5430
2 Bronze
2 Bronze

There was no option to enable TPM in BIOS.  It would be under Security, right?

2 Bronze
2 Bronze


You can fix it Reboot the computer and press the F2 key at the Dell logo screen to enter BIOS or System Setup.

Click Security in the Settings menu.

Click the TPM 1.2 Security or TPM 2.0 Security option in the Security menu. Ensure TPM On and Activate are checked.

If the TPM is a TPM 2.0 and isn't detected by Windows, verify that your computer hardware contains a Unified Extensible Firmware Interface (UEFI) that is Trusted Computing Group-compliant. Also, ensure that in the UEFI settings, the TPM hasn't been disabled or hidden from the operating system.


I don't know how to go about ensuring that the UEFI settings haven't disabled or hidden the TPM.

I've gone through BIOS/System Setup, and I see nothing about TPM.  I will try again.


I talked to tech support. There is no TPM on my laptop. Now I need to find a way to disable the alert I get on boot up.

Latest Solutions
Top Contributor