Latitude

Last reply by 08-08-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
95

TPM device is not detected

Latitude 5480/5488

Hello everyone,

I's been more than a year that I'm seeing this error every time I turn my Laptop on. Nothing from Dell's recommendations worked, also I have tried to downgrade/update the BIOS with no luck.

As I see from community's discussion Dell recommends to replace the motherboard in this case.

But has anyone tried to replace the TPM chip itself on the motherboard with the working one? Is that possible?

Also is that possible to replace the 5480 motherboard with 5491's one with the next gen CPU?

Thanks in advance.

Replies (3)
8 Xenon
91

No, to both questions.  The TPM chip cannot be replaced, nor will a mainboard from a subsequent model fit the system you have.

There is a thread here with some ideas as to how to fix the issue

https://www.dell.com/community/Latitude/Latitude-5480-TPM-Device-Not-Detected-Error/td-p/8015937

However, the other consideration:  in what market was the system originally sold?  There are markets (China, Russia and others) where TPM technology is forbidden by law.

 

85

Thank you for your response. I bought my laptop in Russia. Initially there was a TPM option in the BIOS, but after an update it disappeared.

Thanks for the link, I already looked it up.

I found this TPM chip NPCT650JB2XY in the board review and you can buy it in a Chinese store.

Why to replace the whole motherboard because of one little chip?

83

If you have the tools and expertise to replace the chip, and are willing to gamble on a repair, there is no reason not to try other than the cost in time and the cost of the chip.

You will need a hot air rework station or access to one -- it's not something you can do with a handheld soldering iron.  If you don't have one, they're a few hundred dollars' investment. And if you have to pay a shop the labor charge to do the job, it'll cost as much or more than replacing the board (the boards are in the $200-250 range;  labor with a repair shop will be that much if not more).

 

Latest Solutions
Top Contributor