Linux Developer Systems

2 Bronze

After latest Update (Kernel 3.19.0-65) wireless is no longer working

I've applied the latest update that included minor Kernel update to 3.19.0-65). Install went fine but after reboot Wireless is no longer available.

I'm sure it has to do with Broadcom drivers but I'm not sure how to get the latest matching one.

Any help is appreciated.

R

Replies (61)
2 Bronze

Same problem here with xps 13 9350 DE (intel wireless) Bluetooth device not recognized either.

2 Bronze

I just had this exact issue with the Precision 5510..  upgraded to 3.19.0-65 and both wifi and my trackpad stopped working.

To fix it I ran the following in terminal to rollback to the previous kernal version and then rebooted the machine:

sudo apt-get purge linux-image-3.19.0-65-generic

The downside is it will no longer notify you of future kernal updates until you reinstall the following package:

linux-image-generic-lts-raring

----

Precision 5510  (Xeon E3-1505M, 32GB RAM, 1TB SSD, Quadro M1000M, 4K touchscreen)

2 Bronze

Me too, today.  Another Dell XPS 13 9350.

I've now booted into 3.19.0-64 and everything seems okay again.  But obviously I don't want to get stuck on an out-of-date version, so I'm hoping to get this sorted ASAP.

When you were doing the update, before the restart, did you get a popup asking you to "Disable UEFI Secure Boot"?

I did.  So did the person who asked this askubuntu.com question yesterday.  But he* doesn't seem to have had any adverse effects, unlike me.  (He doesn't mention his hardware or kernel version.)  The first comment on that question links to this other question, where the answer by Majal suggests signing some 'kernel modules'.  I'm wondering whether that will work for me so that I can go back up to 3.19.0-65


* - assuming male

2 Bronze

Me too, today.  Another Dell XPS 13 9350.

I have no kernels to boot into though...I will try to do a fresh install of 16.04 and see where that takes me. Not much I can do without wireless :( 

2 Bronze

Booting on the 3.19.0-64 kernel makes the Lptop operational again. Thanks for the hint.

It seems that the update to 3.19.0-6broke more than just the Wireless. Sound is broken (dummy device) even after reboot and Bluetooth.

Luckly wired connection (USB network adapter) works so that I can update once a fix is available.

R

2 Bronze

Hello,

we have the same problem with our precision 5510. I changed grub configuration to let us switch to the old kernel (askubuntu.com/.../grub-menu-at-boot-time-holding-shift-not-working) and everything works fine again. I hope to get a solution in this forum.

2 Bronze

I had to uninstall the last kernel (3.19.0-65) with Synaptic Package Manager to be able to boot with the previous one. If the same problem happens again, is there another way to select a kernel to boot with ?

2 Bronze

Thanks a lot for your input.

This worked well and is the best solution to get the system back in order.

Cheers

2 Bronze

In order to access 3.19.0-64, I used the grub menu.  (I used the answer by "Vojtech Trefny".)

But using 64 is only a temporary solution.

It seems that 65 contains a fix for this security bug.  For most people that bug may not be too serious.  But what about the next security bug to be found and fixed - perhaps in 66 (for example)?  It might be a very serious bug.

So we need to make sure that our problem with 65 is resolved as part of 66 / by the time 66 is released.

Please could everyone who had the problem let me know; when you were doing the update that contained 65, some time before the restart, did you get a popup asking you to "Disable UEFI Secure Boot"?  Or was it just me who got that?  (And what hardware are you on?)

Top Contributor
Latest Solutions