Linux Developer Systems

Last reply by 12-25-2022 Unsolved
Start a Discussion
1 Amber
1 Amber

Dell XPS 13 9310 Ubuntu - WiFi issues after upgrade to 22.04 LTS

I've been experiencing two Problems after updating my Dell XPS 13 that came with Ubuntu 20.04 pre-installed - I'm now running LTS 22.04. One of the issues I've solved, one I need assistance with:

Problem 1: Wifi randomly "quits" after 10-30 minutes of use. May happen after idle time, or even during use. WiFi would just randomly give out and require a restart to work again. Manually turning WiFi off/on would not solve the problem. IIn order to reset the WiFi I would run:

sudo dhclient -r 
sudo dhclient

This problem persisted for months. Weirdly, the problem was worse on wifi's that didn't have great connectivity. Eventually I figured out the solution, there was a missing firmware file.

Solution 1:

<Find wifi name then:>
modprobe -r iwlwifi
modprobe iwlwifi

sudo dmesg | grep iwl
< here I would notice that kernel would attempt to load firmware version 72.something.ucode, and then would fail and revert to 71.something.ucode, error looked like this:>
Direct firmware load for iwlwifi version 72.daa05125.0 QuZ-a0-hr-b0-72.ucode failed with error -2

<check if the firmware file was existed (QuZ was my specific file), it did not:>
ls /lib/firmware/iwlwifi-QuZ-*

Then go to linux git tree and download correct firmware file, in my case, 72.something.ucode.

Then place the file in  in /lib/firmware

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

sudo dmesg | grep iwl

[    3.644860] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    3.659415] iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
[    3.659429] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version:
[    3.660064] iwlwifi 0000:00:14.3: loaded firmware version 72.daa05125.0 QuZ-a0-hr-b0-72.ucode op_mode iwlmvm
[    3.948291] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX203, REV=0x351
[    4.073761] iwlwifi 0000:00:14.3: Detected RF HR B3, rfid=0x10a100
[    4.146362] iwlwifi 0000:00:14.3: base HW address: 68:54:5a:98:74:6b
[    4.179065] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0

And no issues seen this time.


Problem 2: Wifi no longer randomly quits, but I still get very many "err connection changed" errors when browsing the internet. Also, downloading file occasionally fails if there is a network change during download. it's like the network drops for a split second, then automatically reloads and continues on. 

Solution 2: Please help!

Replies (0)
Latest Solutions
Top Contributor