Linux Developer Systems

Last reply by 11-29-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Dell XPS 13 9350 + Linux + Thunderbolt 3/USB-C

Hi all. I've been following these forums for a few weeks hoping to find a solid solution to my problem. Through my searching and browsing, it seems like there are numerous people mentioning the same or similar issue, but so far I can't seem to find any concrete solutions or knowledge from the community or from Dell. I'm hoping this post is more on-topic and provides more detail for the issue so we can better diagnose it and find a solution.

First though, the issue. I'm running the 2016 Dell XPS 13 9350 with an external Dell 4K monitor (P2415Q) using the USB-C/Thunderbolt 3 output with an adapter to mDP. I'm running Ubuntu 16.04 with 1.4.4 BIOS, and 4.7 mainline kernel. All drivers were updated as of two weeks ago prior to wiping Windows and installing Linux.

The external is recognized (i.e., it shows up in both xrandr and in Display settings) but the picture never remains. It will appear briefly, maybe for a few seconds or so, but then the screen goes black. I'll add that the external doesn't turn off (or go to sleep), but it doesn't display anything and is still shown in settings.

I've read that this could be related to ACPI power modes, namely RC6 with Skylake processors. I've tried appending a line to my kernel to disable RC6 entirely, but that doesn't seem to work. Along these lines, I've also read that this does fix some instances and this patch will be included in the 4.8 mainline kernel update (it's in RC2 right now, so soon?).

Admittedly the adapter I'm using is a $20 "cheapo" from Amazon, though the vendor does say it supports 4K at 60Hz (but I guess vendors can say whatever they want). I've been hearing positive things about Google's adapter, but don't want to shell out the $40 until I've narrowed the problem to the adapter. From the numerous other posts from folks using various adapters all whom are experiencing the same issues, I'm led to believe the adapter isn't the culprit.

I've also read that there could be some conflict with the wireless adapter, and that reducing its power stabilizes things. Unfortunately, reducing the power of my wireless adapter does not fix the issue, and even if it did, it is a suboptimal solution as it slows my connection considerably.

Some questions I'm hoping to get answers for are:

* is this a known issue and are my experiences on par with others, or are things slightly different?
* does Dell know about this issue, and are they working on a solution? I'm totally OK waiting for a solution, it'd just be nice to know one was being actively worked on
* is there a problem with the hardware? Is this Dells problem and I should return my device?
* is there some hidden driver update out there that fixes this issue (that's for Linux, not Windows)?
* has anyone found a temporary solution that does work?

I would like to scope this conversation to linux operating systems using external displays via the USB-C/Thunderbolt 3 connector, to hopefully keep it on-topic.

Thank you all in advance. I hope this thread proves useful to many.

Replies (37)
2 Bronze
2 Bronze

Thank you for your post, hopefully we can keep it on-topic.

I am afraid that I can not help you with how to make it work, but I can share that I had no luck using neither these two adapters [1] [2].

I have tried different displays (including P2415Q) without success. USB-C to HDMI adapters work though (but I'd prefer to use DP so I could in theory get 60Hz in 4k)

Could anybody answer the questions posted by FULLONUTS? Has anybody being successful using USB-C to DP in a 2016 XPS developer edition?

System info:

2016 Dell XPS 13 9350, Ubuntu 16.04 and kernel 4.4.0-34 



2 Bronze
2 Bronze

Thanks for replying. I tried 4.8RC2 kernel last night, but had no success. However, xrandr does report the external monitor along with appropriate resolutions (including 60Hz) and interestingly the 60Hz line was marked with *+ which means it's both the set and preferred settings.

Clearly the hardware recognizes the external and even its capabilities.

I'm beginning to think that the issue has more to do with the adapters or hardware, and more to do with the power management. It seems as though the XPS doesn't quite understand how to consistently power the PCIe port in the Thunderbolt connector. This may explain why one second I see my desktop on the external and the next I don't.

The flickering is inconsistent too. It isn't a fast flicker, it's a slower flicker. The display may be on and working for ten seconds, then cut out for a few, then back on for another ten, then back out for thirty seconds, etc. Very strange. But could be related to power management.

Maybe this sparks some ideas for someone?

2 Bronze
2 Bronze


I have the same issues with my XPS 13 DE 9350, Ubuntu 16.04, Kernel 4.7. I'm using the Dell DA200 adapter [1] so I doubt it has to do with cables or adapters as it seems a common problem across adapters and cables.

In my case, when using HDMI, the second monitor (or tv) is recognized but no signal is sent to it. When using VGA, nothing is recognized. Dell ProSupport suggested upgrading the Thunderbolt controller and firmwire, but my understanding is that this requires Windows (different to the BIOS update that could be done directly in Ubuntu). Enough to say that my laptop never had Windows so I have no idea how to do the upgrade (the laptop was Ubuntu-loaded at factory). After I pointed this out, the reply was "This is as much as we can do"... which is not what I was expecting from "Pro"Support.

2 Bronze
2 Bronze

and the forgotten link was [1]

3 Silver

I have this setup. Running fc24 with rawhide kernel which is 4.8rc2 for the moment. 4.8 had alot of i915 updates to it so I hope they update the updates soon. I run  wayland but also use x11 and both show multi-screen issues.

I noticed greater instability with 4.8rc2 and I completely lost my ethernet from the TB15 with the latest kernels (regression?) regardless of the plugin sequence.

I get screen blanks of various types that affect my overall display stability. Very slow blanking frequency, every minute or so, and I have two monitors hooked up (mDP and HDMI) and they cycle in and out. I've tried various i915 flags to no avail.

It's so unstable that I've stopped using the TB15 mostly so its been a step backwards lately.

I found brcmfmac to be unstable under 4.8, in and out connectivity. I disabled ipv6 for awhile to see if that helps based on a note I fonud. Currently, since usb-ethernet through TB15 is not working, the brcmfmac issues are now critical path for me. I have not been able to get b43 to work so I just hope brcmfmac stabilizes.

2 Bronze
2 Bronze

I've purchased the Google USB-C to DisplayPort cable that so many have said worked. It does not. I'm running 4.8rc5 right now, hoping that with each release candidate the display will get more support. It does not.

I'm running updated drivers from Intel ( and no additional customizations to Linux, other than the rc kernel.

Why is it so difficult to get this working? I understand that USB-C/Thunderbolt 3 is relatively new, but why would Dell produce a product that was questionable?

I'm tempted to sell my XPS and pick up a Lenovo X1 Carbon, which I know works (we use them at work). I'm just trying to avoid the hassle.

Can Dell chime in here?

2 Bronze
2 Bronze

Important update:

I came across a post or two that discussed dialing back the power of the wireless card. I started more simply and disabled networking entirely. I had 100% success with my external monitor using both the Google cable and the "cheapo" adapter from Amazon.

This leads me to conclude that the issue isn't with drivers, the kernel, or anything with Linux, or with cables or adapters, rather an issue or some sort of conflict with the wireless card. I'm using Dell's card, which I believes is a Broadcom chip. I've read things about Broadcom and Linux not playing nice and I guess this confirms it.

Before I run out and by the Intel card that many recommend as a replacement, I want to find or hear if others can confirm this. Additionally, if anyone has the "upgraded" card for the XPS (the Intel) card, can you confirm that your externals work? (Though, I suppose if they did work, you wouldn't be here reading this...).

I feel both better and worse. Had I known that the Dell wireless card had so many issues and prevented my external display from working, I'd have either upgraded when I bought the machine, or bought a different machine. Luckily, the recommended replacement card is $20 or less on Amazon, new.

Those of you who are experiencing this same issue, can you try disabling your networking/wireless adapter, and then try you external and report back if it works or not?

3 Silver

I'll give this a try. I found that disabling ipv6 helped as I had heard that power issues on the 9350 wireless card can cause the network to fluctuate and I was having alot of trouble with it. My wireless stabilized as soon as I turned off ipv6.

2 Bronze
2 Bronze

I gave it a try.
I have a Samsung 4k monitor plugged with HDMI in the TB15 dock.
The TB15 dock is plugged in my Dell XPS 9550.
I applied all the updates related to the dock and my laptop.
I'm on Debian testing with Linux kernel 4.7.0.

Before disabling my wifi card, the connection to the monitor would be lost every 5-10 minutes, with other weird behaviors like CPU spikes in kernel processes.
After disabling my wifi card, no more lost connection and weird CPU behaviors.

So yes, it fixes that.

Latest Solutions
Top Contributor