Linux Developer Systems

2 Bronze

XPS 13 2015 9343 (QHD) with Ubuntu 15.04: screen goes blank at random times

Very odd. It even happened once before I logged in, still in the session manager, when I was typing my password.

The screen goes off (completely black) but the system is still running (sound keeps on going, and I can pause/play a movie with the space bar, even if I can't see it).

Often just pressing power and making the computer suspend, and then pressing it again to wake up solves the problem.

The issue doesn't happen in Windows, so I don't think it's a hardware issue.

I saw some postings in of people having similar issues, but none of the solutions worked for me.

Any ideas ?



ps.: This is a re-posting, since I haven't gotten any responses on the original post, and I thought it was time to try again.

Replies (55)
2 Bronze

did you find any solution for that issue? which version of OS and kernel you are using?

2 Bronze

I've seen this and have no solution other than suspend.

I'm currently on Mint 17.2 Cinnamon with kernel 4.1.2. I've seen this with the stock 14.04, with Ubuntu 15.04 and Gnome and now here as well. It seems worst shortly after the screen wakes from off. Once it's been on for more than a minute, it usually stays on.

I think that others have reported switching to a console (e.g. Ctrl+Alt+F1) then back (Ctrl+Alt+F7/F8) can also restore the video. That has not worked for me. In Gnome, locking & unlocking the screen worked for me because it blanked the screen. That doesn't work in Cinnamon because it leaves it on. So I'm currently stuck with suspend + resume.

I believe that it has something to do with the following log messages:

[396164.719424] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[396164.719442] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[396164.719549] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment

It sounds similar to this Arch topic, but that was resolved by a downgrade to 3.14. I've seen this in 3.13, 3.16 and now in 4.1. My next step is to update xserver-xorg-video-intel. Mint 17.2 tracks Ubuntu 14.04 so I've currently got 2:2.99.910-0ubuntu1.6 installed. Maybe a newer version of that package with kernel 4.1 will help? 

2 Bronze

Nope :( ... I'm using the up-to-date Ubuntu 15.04 kernel, which I believe is 3.19.0-22 or 23 not sure.

Every now and then the screens blank and I'm forced to go to suspend and back.

I'm yet to ssh into the laptop when the screen in blank and try to fix it by changing the resolution or something (xrandr). If that would do it one could configure some shortcut key combination to do that ...

2 Bronze

I've tried going to the console (alt+cntrl+F1) and back but it doesn't help.

I haven't tried going into a blank screen saver though ... could be an option. And if that fixes it, do you know of a command one can use to blank the screen and then bring it back ? That could be easily assigned to a shortcut key ...

2 Bronze

Ha, it actually worked. I created a simple script:


xset dpms force off

sleep 1

xset dpms force on


And assigned this to Super+Alt+S. Now every time the screen blanks I just click Super+Alt+S and in a couple of seconds I get the screen back.

Not ideal, but minimizes the annoyance of the bug. 

2 Bronze

I am experiencing the same problem: on an XPS13 developer edition (2015), with Fedora 22 installed, the screen goes black randomly, as far as I can tell. I have checked "journalctl" for any relevant log messages, but didn't find anything that seemed relevant or matched on the timestamp.

It seems that it's just the screen turning off-- for the rest the system seems to continue running without problems. The "xset dpms force off/on" script workaround works for me (thanks for the suggestion!), but I would prefer a proper solution.

It's hard to troubleshoot, because I cannot reliably trigger the behaviour myself. On average it happens a couple of times a day.

2 Bronze

Your screen is QHD right ? (3200x1800) I think it only happens in that screen.

2 Bronze

Correct. I am experiencing this problem on the QHD 3200x1800 screen. Otherwise:

 - sound, video, and trackpad all work well with the stock kernel shipped with Fedora 22

- bluetooth worked after extracting the firmware from a windows driver following the process outlined on

- after upgrading the BIOS to A04, the keyboard seems to work well

- I do lose SYNC if I switch to a TTY console (which I tried to get my screen back, before I implemented the `xset dpms force off/on` hotkey solution); I think this is

(it means that TTYs are currently not usable, but in practice they already weren, because of the font size. Any way to reconfigure the resolution to be used for text TTYs?)

The random screen blanking is definitely the most urgent problem right now. The hotkey solution reduces it to a major annoyance, but I when it happens during a presentation it will look rather silly.

2 Bronze

Try this to reconfigure TTYs to use a larger font size:

Top Contributor
Latest Solutions
comment leaving this incase mobile wants to be turned on again