Linux Developer Systems

2 Bronze

XPS 13 9343 and 9350 QHD+ No Display Issues on Linux

There is a misconception that there is a power management issue on the XPS13 QHD+ machines with the latest kernels. I can confirm that there is an issue with the intel driver which affects both the XPS13 9343 and 9350 models with a QHD+ display. A quick rundown on my symptoms with my 9350:

With kernel 4.2 on Ubuntu, I can boot to X but I can not get my display working after a resume from standby. After a resume, there is no backlight at all, but the operating system is still running.

With kernel 4.3 on Ubuntu, when I boot I get a black screen with a backlight, but nothing else. To bring the display up, I suspend the computer either remotely through ssh, by closing the lid, or by pressing the power button once. These suspend methods are of course relevant only to my setup. Once I resume from suspend, I am greeted with my desktop environment as the display activates correctly.

I have found a temporary fix for now until the fix gets pulled into a distribution kernel. The fix resides in a drm-intel-nightly build of the 4.3 kernel. I am currently booting with 4.3.0-994-generic. I got it from . As of right now though, the two architecture specific header and image files are not available. I saw this yesterday as well. I think if you keep checking, a successful build will finish and you can download a copy of that nightly.

On my 9350 (with skylake) when I was installing the kernel though, I ran into an error that said I was missing skl_guc_ver4.bin. To satisfy the dependency, I downloaded the original archive which is used to make firmware-misc-nonfree in debian. In particular, I downloaded the orig.tar.xz file from, extracted the skl_guc_ver4.bin softlink and skl_guc_ver4_3.bin binary file and moved them to /lib/firmware/i915/ . I then had to run update-grub in order to regenerate my initramfs so that the firmware file would get included. Again, this step may be completyely unnecessary on a non-skylake machine (9343).

Let me know if this helps anyone. I give most of the credit to @dmcrtr as he filed a bug report at launchpad and had someone help him to find this kernel to try on his 9343 QHD+ machine.

Replies (7)
2 Bronze

I wanted to include the relevant launchpad bug report:

2 Bronze

Close-the-lid-and-open is a pretty great workaround for a problem that only occurs on boot -- and I can confirm this works fine for me! Thanks very much for spelling this out!

Now I have wifi *and* my display working at the same time :-)

2 Bronze

Great Success!

Just tried the nightly kernel from 11/5/2015 and suspend/resume works, and booting works for me WITHOUT having to close and open the lid.

I am running an XPS 13 9350 with QHD+ (4k) screen. I'm on Xubuntu 15.10 (XFCE).

WiFi works too, but I have the Intel 7265 WiFi card NOT the Broadcom

2 Bronze

Fascinating!  you install the Intel wifi card yourself? I wwas unable to find a momodel with it pre-installed.

2 Bronze

How did you get the Wifi to work?

2 Bronze

Had you tried the Ubuntu 15.10 live CD at all?

I got my 9350 yesterday and got right to setting up Arch on it, but hit this exact issue. There is an AUR build script for the drm-intel-nightly build as well, however when I tried that kernel, it wasn't initializing the nvme drive, and when it dropped me into the rescue terminal, the keyboard wasn't working either. So that seems like a no go.

But on a whim, I tried booting Ubuntu off a USB disk and X loaded just fine on it, full resolution.

Kind of left scratching my head.

I love Arch, but contemplating Ubuntu for now just to get around this.

2 Bronze

Yes I installed the card myself. Dell doesn't offer it as an option. I was very easy to install.

Here is a link to my notes on installing ubuntu 15.10 on a new Dell XPS 13 9350.

It seems to be running pretty well right now, but there are still a few small issues I'm trying to tackle, like the touchpad and encrypted swap. I'll be updating that document as I go along.

Top Contributor
Latest Solutions