Linux Developer Systems

Last reply by 01-03-2017 Unsolved
Start a Discussion
2 Bronze
2 Bronze

[XPS 9360 DE] Kernel 4.9 fixed my suspend problems

I have the following setup:

  • XPS 13 9360 (dev edt. with touchscreen)
  • Ubuntu 16.04.1 LTS (as shipped, with updates)
  • BIOS updated to 1.2.3
  • Kernel was the latest 4.4 (as shipped, updated to
  • Problem was as follows:

After being connected (and disconnected) from external display with mDP (via WD15 adapter in the USB-C slot), it would fail to resume from suspend. Screen would stay black, keyboard lit up but did nothing, only thing to do would be to power off by holding the button.

After booting again, syslogs showed only the suspend had taken place (with some warnings and stuff, I was unable to relate whether any of these had to do with the crash), and then the next log entry would be the next boot after hard reset.

Note that otherwise suspend and resume worked fine on the laptop. Only when it had been connected to my external display it would start this behavior. Another way to trigger it was to connect the USB-C/mDP, suspend, and then unplug. The laptop would also fail to resume from that state.

I now just tried the recently released 4.9 kernel, and although I haven't tested it for long, the problem above in particular seems to be resolved. Not sure if it introduces any new problems though (it does seem like it now makes little pauses when loading files some times).

I know this is a bit like stating that this cannonball killed that sparrow, but in case anyone else is looking for a workaround for this really annoying problem, there it is.

Replies (5)

May I ak you how you updated the Bios ?

I get the same confifuration than yours (XPS 13 9360 (dev edt. with touchscreen)

All my best,

Ubuntu 17.10 - XPS 13 9360 - BIOS version: 2.5.0

2 Bronze
2 Bronze

May I ak you how you updated the Bios ?

Sure. Whereas in the old days one would have to boot from some DOS boot stick and run the .exe from there, it is now possible to do this from the BIOS directly (not sure which version of what introduced this, but I saw it on this forum somewhere).

You have to first download the update .exe (find it via Dell Support pages, or simply click this link for the current 1.2.3 version) and copy it into the boot partition:

sudo cp ~/Downloads/XPS_9360_1.2.3.exe /boot/efi/

Now enter the BIOS menu (press Esc and F12 during Dell logo during boot) and select update BIOS from there. You should be able to see the exe file there directly. Follow instructions from there.

Disclaimer: This may break your computer if you don't know what you're doing or if you don't do it right.

Thank you very much !

As I am a DELL XPS 13 DEVELOPER EDITION, without Windows, i was asking if i have to change my BIOS now? Is it helpful?

And do you know how I can know the version of my BIOS installed ?

My very best


Ubuntu 17.10 - XPS 13 9360 - BIOS version: 2.5.0

2 Bronze
2 Bronze

Well, no you don't *have* to upgrade the BIOS. Some people think it's healthy to keep it updated, others think it's an unnecessary risk unless you need to get the features in the latest version. The 1.2.3 BIOS brought the following changes <ADMIN NOTE: Broken link has been removed from this post by Dell> to the XPS 13. Next time a BIOS update comes out, you might first have to upgrade to v1.2.3 anyway, but I'm not sure about that.

Here's how to see the current BIOS version:

sudo lshw | grep -A 4 BIOS
[sudo] password for me:

description: BIOS
vendor: Dell Inc.
physical id: 0
version: 1.2.3
date: 12/01/2016


Mine is

 description: BIOS
          fabriquant: Dell Inc.
          identifiant matériel: 0
          version: 1.0.7
          date: 09/13/2016

I am pretty surprised because my XPS is the last version and got it 3 weeks ago only...

Ubuntu 17.10 - XPS 13 9360 - BIOS version: 2.5.0

Top Contributor
Latest Solutions