Linux Developer Systems

2 Bronze

XPS13 9350 skylake no wifi on Ubuntu 15.10

With Ubuntu 15.10 (default kernel 4.2), 9350 almost works out of box, except this DW1820A wireless card. It has been a few days, I still couldn't get the wireless card working. From what I have read on Linux Wireless, BCM4350 driver is queued to be included in kernel 4.4. That's a long wait. 

Could anyone help?

Replies (152)
3 Argentum

If you go to Additional Drivers, is the proprietary driver enabled for broadcom? (If so in the future please always mention in your messages what you have tried so far).

2 Bronze

Yes, I tried the additional driver on Ubuntu 15.10 via the UI, it doesn't list any additional boardcom drivers. I made sure I enabled multiverse repo.

I also tried manually installed bcmwl drivers, still no luck.

2 Bronze

I've tried to understand what exact Broadcom card is inside the Dell and rebranded as a DW1820A, see this thread on reddit.

Are you able to figure out if the card fits the one announced in the upcoming kernels on the linux-wireless wiki?

Also, is your sound working? I seemed to be in the work too...

this thread on reddit

3 Argentum

Thanks for the details. I am on a fresh install of 15.04 and although there are some issues with the wifi drivers it works for the most part. All I did was enable the proprietary drivers.

Did it work for you before 15.10?

What is the temporary workaround you are using? These little guys work amazingly well (plug-and-play):;qid=1446389931&sr=8-2&keywords=panda+wifi

2 Bronze

Please note my device is 9350 instead of 9343. 

When I tried with Ubuntu 15.04, not only the wireless isn't working, but also the graphics card, and power management had serious problems.

I can use my Android USB tethering for now. But, this ***!

2 Bronze

What steps did you take to install 15.10 om the 9350? Having some difficulty doing a dual boot. Any insight you have would be appreciated. 

In terms of the wireless card, you should get an Intel 7265 for 30 bucks. Should get you up and running.

2 Bronze

Yes, my card is indeed: "14e4:43a3", and I have saw the news on linux wireless that the driver is queued for kernel 4.4. 

That is a long wait. So, I am hoping someone or organization can backport the patch to current linux distros.

2 Bronze

I know the OP asked about WiFi, but for those of you who have the 9350, have you found workarounds for power management functions like suspend/hibernate/etc. not working out of the box?

2 Bronze

Since my 9350 is currently on the way, I am also interested in this. I could try to backport the firmware, however, I have never done that before. So if compiling goes wrong, I will probably not be able to get this error fixed. 

Anyhow, does anybody know if the firmware is compiled into the kernel? B/c I think compiling your own Kernel is a bad idea for Kernel updates will most likely break the firmware again. If it lies outside the Kernel I could try it.

Top Contributor
Latest Solutions