Linux Developer Systems

Last reply by 06-27-2017 Unsolved
Start a Discussion
2 Bronze
2 Bronze
104064

disable touchpad while typing

I want to disable the touchpad while typing.  There is a setting for this under mouse options but it doesn't work.

Also tried 

syndaemon -i 1 -K -d

also didn't work.

Is there a way to make this happen without installing new mouse drivers (which possibly seems risky to me).


					
				
			
			
				
			
			
				
			
			
			
			
			
			
		
Replies (9)
2 Bronze
2 Bronze
5845

You should be able to double tap in the upper left hand corner to disable the touchpad quickly without having to make any changes to the drivers or the settings. Hope this helps.

2 Bronze
2 Bronze
5845

doesn't seem to work, also i would much rather disable the touchpad for 1-2 seconds after typing a char

2 Bronze
2 Bronze
5845

There is a lot of valuable information here:

https://github.com/mpalourdio/xps13/

The BIOS upgrade A06 is supposed to solve these issues, but I am not sure what its status is.

2 Jasper
2 Jasper
5845

You should be able to double tap in the upper left hand corner to disable the touchpad quickly without having to make any changes to the drivers or the settings. Hope this helps.

Hi, the upper left hand corner of what would one double tap?

Could you elaborate on the steps or point to some documentation?

Thanks!

2 Bronze
2 Bronze
5845

My apologies. The question was how to disable the touchpad? Double tap in the upper left hand corner of the touchpad. It works for most except for my HP Probook 4440s. Bloomin thing has only worked half of the time in the past 2 years.I hope this helps. If not, post your system model and we'll get it fixed up hopefully.

2 Bronze
2 Bronze
5844

I'm using an xps 13 9343

2 Bronze
2 Bronze
5844

I'm in the same boat.  I've tried every fix I can find, and still no dice.

I've ran into so many issues with this distro that I started my own post that I'm going to start logging all my bug fixes and attempts.  So maybe we can collaborate.

2 Bronze
2 Bronze
5844

Hi,

Long story short, you have to disable an input method in the X config. The full answer:

ubuntuforums.org/showthread.php

It looks like the system starts with 2 different input methods after full boot, and it gets syndaemon confused. You don't need to start that daemon manually.

PS: I'm running, pre-installed  Ubuntu 16.04.2 LTS in a Dell XPS13 (9360)

2 Jasper
2 Jasper
5844

On Fedora 26, default install but with 4.12.0-rc7 and libinput 1.8 installed the touchpad is disabled while typing. In Firefox, the cursor stays on the screen but doesn't move. When typing in gnome-terminal, the cursor disappears, too, which is nice.

Latest Solutions
Top Contributor