Linux General

Last reply by 09-23-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
31446

Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

  I need to install ubuntu on 7490, but now it blocks by the intel RST mode. The disk can't be found when installing. As guide , i need to turn off 'RAID on', and swith disk mode to AHCI, but how to do that? i realy can't find related items from current 7490 bios. Who can support here?

Replies (94)
6 Indium
16610

Welcome to the Dell Community @bulaqi 

EDITED: Removed reference to wrong manual.

Best regards,

U2

7 Plutonium
5976

As mentioned above, typically this option is called "SATA Operation", and despite the name it also affects NVMe SSDs.  If you can't find that, then Dell may have changed the name of that option in newer systems.  I haven't used an Inspiron 7490 specifically.


16579

Yes, i can find following options in another Latitude 7490 laptop    

  • Disabled
  • AHCI
  • RAID On: This option is enabled by default.

But, unfortunately, these options was changed in Inspiron 7490, only 2 options are left:   

  • Disabled
  • RAID On: This option is enabled by default.

I really can't undestand why dell change this key feature. Or there is another item in other place can do same thing?

16576

bulaqi,

 

If you switch the storage interface to off can you then select disable and then switch it back on. What does it do?  Let me know. If this does not work I will need to contact a level 2 technician to see if this is by default and not able to change.

 

 

 

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

16573

Jesse L,

   Thanks for your supporting.

   I did all steps as your suggestion: turn off interface -> disabled SATA controller -> switch interface back on.

   But, things still can't run lucky . Contents in 'Device information' show:

        Type = (none) and device = (none).

   During bootup,  a popup waring was shown:

            SupportAssist was able to identify a possible issue with your system..

           warning message: Hard Drive - Not installed.

    Boot OS from USB disk, system also can't find the hard drive.

 

 

16569

bulaqi,

 

Start the computer and tap the F2 key to enter the bios. Choose the option to restore defaults ,save the changes and exit. Is th hard drive seen in the bios? Also, start the computer and tap the F12 key and choose to run the ePSA Diags. Post back with any failures.

 

 

 

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

4 Beryllium
5939

This has worked for many people over the years. Please be sure to create a Full disk Image before attempting.

https://www.tenforums.com/customization/104898-switch-raid-ahci.html

The correct way to switch from RAID to AHCI is to make the BIOS changes then, USe Disk Part to Clean your Disk/SSD and then  Do a Clean install to the AHCI disk/SSD

It is important to use Diskpart to Clean your Disk/SSD prior to completing the Clean Instll, The easist way is to start the clean install once you get to the part where you need to select a volume to install too. Press Shift and F10 this will bring up a comand prompt type in

Diskpart

Select the disk you want to Clean," it should be the only disk you have connected"

Type Clean

after clean is complete your Disk/SSD will be in RAW condition exactly as it first came from the factory

Type Exit

Your Disk/SSD should now be available as a volume to install too.


- Please kudos posts you like!
- Please "Accept as Solution" posts that are a solution.

Inspiron 13 7386
16GB RAM
Samsung 970 Evo 1TB SSD 2nd SSD 512 GB Hynix

Precision 3440 SFF CTO BASE, Intel Xeon W-1250 (6 Core, 12M cache, base 3.3GHz, up to 4.7GHz) 16GB 2X8GB DDR4 2666MHz or 2933MHz (2933MHz requires Intel Core i7 or above) UDIMM Non-ECC Memory Windows 10 Pro for Workstations

16552

@bulaqi  just out of curiosity, have you tried Disabled?  I'm wondering if Dell changed the meaning of that option so that "Disabled" now just means "RAID Mode Disabled", i.e. AHCI mode, instead of disabling the interface entirely. I would be surprised if they removed AHCI mode, but I could see them removing an option to disable the entire interface since that's not typically necessary.


16494

Yes, i have tried the action to "Disabled". but unlucky, it does NOT means "RAID Mode Disabled", and use AHCI mode. It exactly disabled the disk fully, just as it's not plugged.

I' m so wondering and surprised this new 'FEATURE' now. and looking forward to finding a workaround.

 

 

 

Latest Solutions
Top Contributor