Monitors

Last reply by 11-15-2015 Unsolved
Start a Discussion
Community Manager
Community Manager

DUCCS Downloads

DUCCS qualified monitors (UP3218K, UP3216Q, UP3214Q, UP3017, U3014, UP2718Q, UP2716D, UP2715K, U2713H, UP2516D, UP2414Q, U2413) have in their OSD (On Screen Display) -Color/Color Settings -Preset Modes, two color spaces called CAL1 and CAL2. You would use these two color spaces to "save" the X-Rite i1 Display Pro colorimeter hardware calibrations into the monitor.

For monitors that do not have hardware calibration capability, DisplayCAL is a good software choice.

* Once DUCCS is installed, use the Application Info: "Check for update now" button to update to the latest version. Check the changes log to verify that your monitor model is supported in the new version. When done, restart the computer
* Press the Menu button to open monitor OSD (On Screen Display)
- Go to Other Settings- Factory Reset- Reset All Settings
- Go to Displays or Display Settings and disable DP 1.2/MST
- Go to Color Settings- Preset Modes
* Choose Color Space
- Highlight/check either Cal1 or Cal2
* Exit the OSD
* The monitor USB upstream cable must be connected to the computer USB port
* In a two or more monitor setup, only ONE monitor should be connected to the computer at a time when calibrating
* The X-Rite i1 Display Pro colorimeter should be tested in TWO ways =
Test it on all of the computer USB downstream ports
Test it on all of the monitor bottom USB downstream ports

APPLE

1.6.6
11/27/19

1.6.2
12/22/17

???
4/26/17

???
7/19/16


1.5.10
DUCCS 1.5.10 was only used used to update the UP2716D/UP2516D firmware from from M3T101 to M3T102. If your UP2716D/UP2516D 20 digit serial number shows A06 or higher, it already has firmware M3T102 or newer. This means that you should be able to use any of the DUCCS after 1.5.10.

???
10/14/15

1.5.8
7/7/15

1.5.7
2/9/15

???
2/21/14
136MB

WINDOWS 

1.6.2
12/22/17

1.6.1.2844
8/1/17

1.6.0.2151
4/26/17

1.5.11
7/19/16

1.5.10 
5/4/21
DUCCS 1.5.10 was only used used to update the UP2716D/UP2516D firmware from from M3T101 to M3T102. If your UP2716D/UP2516D 20 digit serial number shows A06 or higher, it already has firmware M3T102 or newer. This means that you should be able to use any of the DUCCS after 1.5.10.

1.5.9
10/15/15

1.5.8
8/3/15

1.5.7.141118
12/16/14

1.5.3
2/18/14

1.5.1
2/28/14

1.0.1.0
4/29/13

1.0.0.0
11/14/12


Social Media Support

#IWork4Dell
Find your Service Tag

Replies (0)
Top Contributor
Latest Solutions