NetWorker

Last reply by 10-26-2022 Solved
Start a Discussion
2 Jasper
2 Jasper
442

sbtinfo2 The fetchss_range() function did not return a valid list

Hello all,

we upgraded NW client and NMDA package from 8.5 to 19.6.1.2. Oracle server with an Impax system is running in a 2 node cluster. During upgrade to the newer NetWorker version the nmda_oracle.cfg was overwritten and something more happened, but I don’t know what. After upgrade no backup was possible anymore. Neither database backup nor redo logs. I found out that I need to copy the ibnsrora.so into the libobk.so file. Linking libnsrora.so into libobk.so didn’t help. Then the redo log backup ran successfully again. But the database backup still fails with this error. I searched with Google and also on Dells support pages, but without success. Also adding *@* in remote access didn’t help as this was missing. Please can someone help to find a solution? Thanks a lot.

Starting backup at 27-SEP-22

channel t1: starting full datafile backup set

channel t1: specifying datafile(s) in backup set

including current control file in backup set

channel t1: starting piece 1 at 27-SEP-22

released channel: t1

RMAN-00571: ===========================================================

RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

RMAN-00571: ===========================================================

RMAN-03009: failure of backup command on t1 channel at 09/27/2022 06:47:41

ORA-27191: sbtinfo2 returned error

Additional information: 3282

   The fetchss_range() function did not return a valid list.

 (100:13:11)

 

Recovery Manager complete.

The backup process failed:

RMAN exited with return code '1'.

Exiting with error:

RMAN exited with return code '1'.

impaxdb:     RMAN exited with return code '1'.

Solution (1)

Accepted Solutions
2 Jasper
2 Jasper
410

Yesterday I found a way to get the backups running again. I made a downgrade of client and NMDA and this solved the issue. It seems to be a bug in this version. Unfortunately also Dell support couldn't deliver a solution as they did not know this problem. 

Error "The fetchss_range() function did not return a valid  list" is definitely caused by NetWorker.

View solution in original post

Replies (4)
2 Jasper
2 Jasper
439

one additional info. The backup does not fail directly. I can see that all databases are backed up. Only at the end there is listed again the  RMAN script with path /u01/app/ora11/backup/rman_nmo/oraback.xxxxxx.rcv. And there the error appears. 

ORA-27191: sbtinfo2 returned error
Additional information: 3282
The fetchss_range() function did not return a valid  list. 

2 Jasper
2 Jasper
411

Yesterday I found a way to get the backups running again. I made a downgrade of client and NMDA and this solved the issue. It seems to be a bug in this version. Unfortunately also Dell support couldn't deliver a solution as they did not know this problem. 

Error "The fetchss_range() function did not return a valid  list" is definitely caused by NetWorker.

359

a downgrade back to nw8.5 again? or a higher version but still below nw19.6.1.2?

And what version is the NW server running, as clients normally should not be higher than the backup server itself, at least not without careful testing...

We also tend to be a bit defensive, not running the latest and greatest (regardless of what Dell wants their customer to run, they don't see any problem in running nw19.7.0.x, we - however - do).

-----------------------------------------------------------------------------------------------------------------
Not a Dell employee. Just doing this to try to help out others. Sharing with the community.
-----------------------------------------------------------------------------------------------------------------
2 Bronze
2 Bronze
257

Could you please share the O/S this db is running on and the version of  Oracle DB such as 19c. Also wondering where did you get NWR 8.5 binaries from?

Latest Solutions
Top Contributor