Networking General

Last reply by 05-31-2022 Solved
Start a Discussion
2 Iron

N2000 and N4064 Trunk issue

N4064 is the core switch with all VLANs. Core switch has a LAG set to trunk to N2000 switch and the lag is a member of all VLANs. The ports the core are attached to on the N2000 are a LAG set to general. For reasons beyond me, if I change the LAG on the N2000 series to trunk, I loose all management access to the switch. No CLI or Web UI. Interface is not pingable. All other traffic appears to be flow as normal. The LAG is a member of all VLANs on the N2000. Any suggestions?

Solution (1)

Accepted Solutions
2 Iron

I've figured this out. Purely overlooking on my part. While I set the Vlans in question to tagged under the Lag while it was in general mode, when changing it to trunk it reverted them to forbidden in the trunk. I consoled into the switch and went through the config one by one and discovered this. Setting them back to tagged resolved the issue.

View solution in original post

Community Accepted Solution
Replies (2)

Hi,

"

A Trunk connection allows multiple tagged frames across the connection. On some switches it will only allow tagged frames. On others it will allow 1 VLAN to pass untagged frames, this VLAN is the native VLAN.

A General connection can send and receive tagged traffic for multiple VLANs. Untagged traffic may also be sent via several untagged VLANs. However returning untagged traffic will only be received by the PVID and therefore will not be forwarded to a specific VLAN.

In most cases you will want to try using Trunk mode first. But sometimes when connecting different model switches together Trunk mode may not work, in which case you would then use General mode."

 

 

 

https://dell.to/3MOwbi5

Here is a quick overview of General mode and it's configuration.

 

 

https://dell.to/3wLeMl1

Here is a short blog someone put together with some of the same information

 

It should be either trunk to trunk(end to end ) or general to general(end to end)

 

 

We should not use trunk (source) to general(destination) =>end to end

 

 

 

 

 


DELL-Young E
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

2 Iron

I've figured this out. Purely overlooking on my part. While I set the Vlans in question to tagged under the Lag while it was in general mode, when changing it to trunk it reverted them to forbidden in the trunk. I consoled into the switch and went through the config one by one and discovered this. Setting them back to tagged resolved the issue.

Community Accepted Solution
Top Contributor
Latest Solutions