Optiplex Desktops

Last reply by 10-01-2022 Unsolved
Start a Discussion
1 Copper
1 Copper
100

No GPU display after upgrading CPU

SPECS -

GPU: NVIDIA GEFORCE GTX 1060 3GB

CPU: FROM INTEL I5-2500S TO INTEL I5-3570K

MB: OPTIPLEX 7010 DT

PSU: EVGA 450W B3

RAM: 2x4GB 1333MHz

Recently replaced the CPU in my optiplex motherboard with a slightly better one, but now I'm having issues with getting my GPU to display anything onto my monitor (connected via. HDMI cable) when it's slotted into the motherboard (the GPU's fans still turn on, so it's getting electricity from the PSU ruling out the possibility that the PSU is faulty, and yes the PSU voltage of 450W is more than enough for all of my components in my current build, including things like the CD drive and any other peripherals connected via. USB)

Prior to replacing my i5-2500S with the 3570K, the GTX 1060 was displaying fine when using HDMI to connect it to my display, but now after replacing the CPU it refuses to even get a signal with my monitor.

I thought it may've been an issue with the processor itself but when I use the integrated Intel HD 4000 graphics that came with the CPU instead of the GPU by connecting a VGA cable to my motherboard and my display it works perfectly fine and both task manager and CPU-Z recognized the 3570K as the correct processor. Logically one would think that something may be wrong with the GPU itself at this point so I managed to try it out in another computer system with the same monitor and HDMI cable just to keep things fair and it worked like a dream, no display issues at all.

Currently, I am waiting for a larger case to arrive early next week (as of this post) as I'd like to see if it's possibly an issue with the first PCI-e x16 slot and if using the GPU through the PCI-e x16 (x4) slot may solve my issue (my current case is too small to place my GPU into the second PCI-e slot). I have a slight suspicion that it may be the slots fault as I've had similar issues from time to time using a GTX 660 via. DisplayPort cable in the past.

I made sure to update the boards BIOS to the most recent version (A29) prior to installing the new CPU, so that shouldn't be the cause for this issue either. As of right now, I've tried to reset the BIOS of the motherboard through the menu itself and manually by removing the CMOS battery for a couple of minutes, neither of these have seemed to work though.

Has anyone faced an issue like this before? It really boggles the mind on what could be causing the issue, as none of the components seem to be faulty.

Replies (2)
7 Thorium
82

It may be worth replacing the CMOS battery with a brand new one and before installing the new battery and leave the battery out of the MB for at least 15 minutes. Also make sure the display setting in the BIOS is set to Auto and not just Integrated display.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with GIGABYTE B560M DS3H AC budget build with an i3 10100
Real work on a Latitude E5430
79

OP has done some thoughtful test.  Now what if you swap back the i5-2500s while keeping gpu in x16 slot?


Latest Solutions
Top Contributor