PowerEdge Hardware General

Last reply by 12-07-2014 Unsolved
Start a Discussion
2 Bronze
2 Bronze
53949

R220 fails to boot to Debian 6.0.9

Greetings,

Tried to install Debian OS in my first R220. Boot failed in acpi. The BIOS version of my R220 is 1.1.4.

If I hack my boot media to add "acpi=off" in the kernel boot option then it boots successfully.

If I boot the blade with CentOS it boots successfully too. So problem is only with Debian and perhaps its version of acpid.

Questions:

  • Is there a BIOS setting which will allow me to boot Debian without adding "acpi=off" to kernel boot option?
  • Will updating BIOS from 1.1.4 to 1.2.1 fix this problem?

Thanks for help.

Replies (4)
839

Hi,

You could try updating the BIOS, but the release notes don’t show anything that would change this behavior. I found some instances where older kernels worked, you may want to try that. Debian is not a validated OS, you might want to see if Ubuntu which is Debian based, works.


Thanks,

DELL-Josh Cr
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

2 Bronze
2 Bronze
839

Hi Josh,

Unfortunately our product is based on Debian 6.0.9.

Moving to Ubuntu won't help anyway. I got the "acpi=off" hack from the web. There are quite a few complains about R220 won't boot in Ubuntu 14.x.x. I am surprise that Dell has not heard of this problem.

We previously use the PowerEdge R210 II for our product. R210 does not have this problem. 

Right now I am only investigating if our software is compatible with the new R220. the acpi=off option is only feasible in the lab here. This hack cannot be use out in the field.

Thanks for the update though.

2 Bronze
2 Bronze
839

Hi

I have the same problem with R220 and Debian. I cant install the newest version of Debian, because of  the instalation stops, the screen gets black. And for example when i install the newest, stable version of Ubuntu, it don't see the hardware raid1, but only the 2 hard drives. 

Have you any solutions of these situations?

Andrzej

2 Bronze
2 Bronze
839

  • 64-bit Debian seems to work, if 64-bit is an option for you.
  • Otherwise at the beginning of boot sequence, look for a keystroke to get into alternative boot options (alternative as not the default). Once get into the option screen there should be one that allows you to append kernel options. Type acpi=off and let it boot. Note that if you boot successfully this way, and install Debian on the hard drive, it will fail to boot from hard drive due to the acpi/BIOS issue. When the installed OS boots up, you have 5 sec to hit some key to enter grub menu. In grub menu again look for the option that let you append acpi=off kernel option. After it boots up, cd into /boot/grub and edit grub.cfg to add the acpi=off option to all entries. Then your R220 will be good to go, that is until next time you upgrade the kernel.

Latest Solutions
Top Contributor