Precision Fixed Workstations

Last reply by 12-01-2022 Unsolved
Start a Discussion
3 Argentum
6919

T7910 HDD Recognition

I just discovered that the T7910 does not recognise HDD's with SAS Enabled in the BIOS with UEFI mode. SSD's are fine. Is this expected behaviour?

Replies (27)
10 Diamond
4660

SAS PERC controllers need F6 mass storage drivers.

Integrated RAID Controller
The PERC H330/H730P storage controller driver 

https://downloads.dell.com/FOLDER04038968M/2/SAS-RAID_Driver_M1N4H_WN32_6.604.06.00_A00.EXE

is installed by the F6 method.

You cannot point to the EXE file.  Rename .ZIP and extract the contents to a flash drive to point to.

Chipset drivers are not native to windows.

Nothing whatsoever to do with UEFI

https://www.dell.com/support/article/us/en/19/sln298613/dell-precision-workstation-r7910-driver-inst...

 

 

perc sas 3perc sas 3

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support


Get Support on Twitter @DellCaresPro


Diagnostics & Tools

4651

Speedstep, aren't SSD's also mass storage devices? The T7910 BIOS recognises my SSD drives but not my HDD drives! I tried three different SATA Hitachi Ultrastars with SAS on and none of them are recognised by the T7910! Again, the T7610 is just fine. Why one and not the other?

2 Bronze
2 Bronze
4099

Is this after you updated firmware with DELL firmware update for SAS 3008 from their support page?
For me, that update nearly bricked my T7910, until I discovered that the problem is that UEFI refuse to accept the internal SAS controller.
Disable Secure Boot and it can find all your harddrive again.

I have tried find info about this and so far, I suspect DELL put the wrong UEFI firmware in the package. I suspect they put in the non-signed version.
According to my findings, UEFI only accept signed firmware in secure boot.
And, to make it more difficult, support for my T7910 ended August 2020, so I cannot have this problem corrected by DELL:
I need a firmware for UEFI that is signed.
Maybe this is your problem too.

4084

Thanks for your contribution @PeterSfa. I ended up not using any HDD's! I agree that there is something odd about the T7910. It doesn't seem to like "legacy" hardware at all.

One other issue that I have been struggling with, for over a year now, is the white PCI slot (not PCIe) on the motherboard. I simply cannot get a parallel port adapter card to work in it.

Someone suggested that I should buy an old parallel port printer, and see if I can make that work, but I suspect that the problem is with the T7910 system.

With "Enable Legacy ROMS" on, the BIOS reports that an ISA bridge is present in the PCI slot. Further, Windows 10 Device Manager reports that the device is working properly, with no conflicts, but the card simply refuses to work. I constantly get a "The system cannot find the device specified" error message.

Very frustrating, because I tried everything, and my T7610, with an almost identical configuration works just fine. Go figure!!

4057

Strange indeed, Today I tried to install a Firmware from Supermicro for the SAS3008 and surprice, it works. Windows changed some name for the SAS3008 driver in Device manager, but it works. DELL BIOS find my harddrives. DELL Diagnose from thee boot menu find my harddrives and report no errors. My UEFI Secure boot works. And the firmware is newer then what DELL present on its support pages. One might wonder why DELL have problem with this, when Supermicro shared firmware works better on DELL hardware then whatt DELL shared Firmware does. Something is very wrong. I have tried to alert their support, but so far no response. If they can correct their firmware I will update with it, only for the reason to have correct names in the firmware. But, we will se if that happens. To have a Firmware update on their support pages that is marked "This computer" when you access with your computers service tag and then the firmware brick the computer until you figure out it no longer support Secure Boot, and claim that there is no longer any support for your harrdware, that.. Is more then stupid. On top of this I even think this firmware is propageted with the DELL Optimizer software.. Trying to have folks buy 7920's?? Wont work, we buy something else instead. Regarding the PCI Parallel port adapter. I cannot test on my workstation. I have moved from Sweden to Thailand and could not bring with me all my cards (I have at least two different adapters, from different manufacturer and other chip). It was too limited space and a limit on the weights. Else I would have tried to see if I can replicate your problem here. At least in Legaly mode it should work. In UEFI I suspect the controller must be correctly signed as ex in this problem with the SAS controller. But in Legacy should be exactly as it says, Legacy... Support for all our older stuff. Strange.. Btw, I belive I will take the route with NVMe M.2 in the PCIe for my OS, but I still have need for larger storage, so HDD's it is. I have not decied yet if I wil luse DELL PCIe card for M.2 or if I choose another card. There is no support for RAID in NVMe on a 7910, it was added in 7920, so maybe I try some of the other that have RAID built into the card it self. Not sure if they support boot,.. But this is a later problem. For now I am happy to have Secure Boot working.
4041

BTW, If yoiu ever want to have your computer recognize your harddrives, there is a solution. If you have updated your HBA with the PH15 from DELL, then you can get the signed UEFI directly from broadcom. DELL do not modify this .rom, but they choose the wrong one to include in your update package, they choose non-signed, where you must have the signed version. Go to this page: https://www.broadcom.com/products/storage/host-bus-adapters/sas-9300-8i#downloads Choose Firmware and then Archive. Choose the package 9300_8i_Package_P15_IR_IT_FW_BIOS_for_MSDOS_WindowsArchive Where it says 15.00.00.00, that is the one DELL use in this update. (There is also a 15.00.02.00, but I beleive it is better to use the same version as DELL used) In the folder: 9300_8i_Package_P15_IR_IT_FW_BIOS_for_MSDOS_Windows.zip\9300_8i_Package_P15_IR_IT_FW_BIOS_for_MSDOS_Windows\uefi_bsd_rel\signed Grab the file mpt3x64.rom and replace the one in DELL driver folder where you have your firmware update. Flash firmare again per intruction. Now your computer will recogize your HBA. Pay close attention that you do not take the file from the parent folder above signed, that is the error DELL made. That one is not signed and cause the problem. make sure you take the one from the folder with the name signed. Also, there is a relase 17 for this HBA, but DELL have not published this update. There are several critical updates made in this new relase. You can get it from Supermicro, they have published it. I have flashed my HBA with it since yesterday and it works perfectly. If you need a link to where, post me a note about it. I know you said you do not use harddrives anymore, so maybe you do not need. But if you want, just for the principle to have a 100% working computer, it can be fixed.
4033

@PeterSfa Your best option, if you want to boot an OS from a PCIe NVME M2 drive on the T7910, is to use a quad Dell adapter card, which is expensive.

I have one, and can report that a Samsung 950 Pro stick works fine with it as a boot drive. Not all do! The others are fine for storage but not for booting, so be careful.

I wouldn't waste money on single third party adapter cards because they are a bit "iffy". Most simply do not work.

The Dell card may turn out to be more economical in the long-run. I'm sure that your time is more valuable than testing stuff eventually destined for the scrapheap.

Have you thought about using a normal PCIe drive? Samsung and Intel make fast large capacity models. Again, you must be careful. The Intel Optane, for example, may not work with the T7910 at all. I'm not aware of anyone using one.

4024

Yes what I had in mind from the beging was DELL Duo or Quad. When I dig into it I discovered they do not support RAID.
Here in Thailand I can buy a Dell Ultra Speed Drive Duo, for about 1790 TBH, that is around 60 USD (new). If I would buy on eBay or similar, the shipping would make it too expensive compared to what I buy here locally.

I was thinking about RAID for speed, so a striping was what I had in mind. I make a copy of my boot drive from time to time and I can afford the time it takes to restore my system if needed.
Data is on another drive.

HighPoint make a RAID NVMe. I used them before for SATA RAID and had no problem with them at that time. I saw this modell: https://highpoint-tech.com/USA_new/series-ssd7202-overview.htm But it is new, so maybe wait and se what people say about them. The ad claim it is bootable.
I am curious about this HighPoint NVMe RAID.

About the NVMe drives, yes I have look into them a little bit, but to my understanding they are similar to using a Duo or Quad card from DELL and put M.2 NVMe on them.
I also belive the Quad card would be cheaper in the long run. But, then again, I have never had one of those, so I do not have experiense with them.
In old times they where only HDDs mounted on a PCB and into the PCI, not much difference.
Today with NVMe and PCIe its another story.

I use my T7910 manly for CAD and software development. In CAD feel the most performance is in the grapichs, but I belive my compiler would gain speed with faster NVMe in RAID 0 mode.

Boot time would also be faster, but, most of the time for boot is the BIOS enumerating anywhay, soo.

I was thinking about maybe erase the BIOS version on the SAS controller and only use Firmware with UEFI. I have not tested, but as long as I use only UEFI, the BIOS should not be needed on the controller.
That would bypass the SAS Bios time it makes before the DELL LOGO, some time saved. But, then again, I only boot it once a day, not a big deal.

4023

Latest Solutions
Top Contributor