Precision Mobile Workstations

Last reply by 09-10-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1255

Precision 5520 Bios Update Fails

Precision 5520 with bios 1.23.1 will not update. I have tried reinstalling 1.23.1 and tried installing 1.24 and 1.25.  The "preparing" screen shows up and the crawl bar completes, then the system reboots and nothing happens.  The bios just remains at 1.23.1.  I have also tried running each one from a flash drive, with the same failure.  Have shut down every possible running program and run every boot attempt as Administrator, with no luck.

Anyone have a way to get these bios updates to complete?

Replies (12)
4 Tellurium
1070

There is something you can check before running the bios update:

If you are using BitLocker, turn it off.

Make sure to plug in AC adapter.

Removing any attachment devices.

1128

BitLocker is not running.

AC adapter is always plugged in

No devices are attached.

Antivirus and most every other not needed program is shut down.  

I right click on program and run it as Administrator.  The installation program starts and screen comes up showing old bios and update bios.  I click install and it runs "Preparing to install".  That completes and the PC reboots, but it just goes back to my Windows screen and never installs the new bios.  I am my wits end trying to get the dumb this to install.  I am now to generations behind on the bios.

1117

@MyBriteStar , next suggestion is to download this bios recovery image file and follow the instruction to run bios recovery

If it fails, another suggestion is to take note of your current bios settings and perform a hard reset on your workstation, set bios to default settings, run bios update, then change the settings back to match with your hardware environment.

1043

I have now tried resetting the bios to default and also using the recovery image .rcv file to recover the current bios.  After doing both of these things I have attempted to update the bios from 1.23.1 to 1.24 or to 1.25 from windows, by using f12 and going to flash bios and by trying from a bootable usb.  In every case, the .exe file runs and then the laptop just reboots directly to the windows login screen with no update to the bios.  

This inability to update is really driving me crazy.  There are no errors, it just seems like the update attempts never go anywhere.  

2 Bronze
2 Bronze
1028

I am also facing the exact same issue on my Precision 3510 laptop. Cannot update bios from 1.23.3 to later versions. And I feel this is the same problem stopping me to update from tpm 1.2 to 2.0

2 Bronze
2 Bronze
1027

I guess I am going to have to give up and stay with the older bios, since I can't figure out anything more to do.  At least everything has been working normally.

2 Bronze
2 Bronze
1026

I just tried re-flashing the same bios (1.23.3) again and was able to get it working... Currently doing step by step upgrade --- 1.25, then 1,26 and upto 1.28

670

Same issue with my 5520.  Can not update bios past 1.23.1

670

Hello, we see you are looking for assistance. Click our DELL-Cares username, on the right click, "Send this user a private message". Provide to us the private Dell PC Service Tag.


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Latest Solutions
Top Contributor