Productivity Software

Last reply by 04-18-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
6610

My Dell update stuck in a loop

I've got the exact same problem. I unistalled the app, got the My Dell app from the Microsoft Store, no other way to download, it installed. Then it wanted to update!!!! Why the latest version isn't on the Store??? I then have the same problem, starts installing the update states this could take a while, then goes back to update available... only way out is to cancel update, then app closes. 

Replies (15)
2 Jasper
2 Jasper
858

unfortunately, this morning I restarted my XPS-15 laptop and when I started My Dell, the same problematic update loop started again! I check the version of Fusion service and it is the new one.

On the older Win10 system, My Dell starts properly (same new Fusion version installed).

 

2604

Thanks for the link, @CharlesMH - worked a charm!

 

2 Bronze
2 Bronze
827

I had the same issue with XPS 13 9380, can confirm the fix of manually updating Fusion Service works. I used the newest version 2.0.58.0 released April 15 2022, restarted laptop and then when opening My Dell after restart it worked again.

https://www.dell.com/support/home/en-us/drivers/driversdetails?driverid=m93kw&oscode=wt64a&productco...

2449

Thanks, Charles for the link. MyDell is working now

773

My Dell went into an update loop again on Saturday, this time network connection error. Advised Dell Support, eventually advised that it was a server problem, and to try again. Ran My Dell today and it updated. I don't know if Microsoft Store does automatic updates, but it appears to have the old version of My Dell!!!!!!

2 Jasper
2 Jasper
5252

Hopefully this will be my final update on this. A Dell support person told me today that there have been a lot of customers having this problem. The issue has apparently been resolved with a new version of "My Dell" which, when installed using the Fusion Service 2.0.58.0 fixes the problem.

So the Dell support person updated my system using this procedure (for a system that has the problem):

 - Uninstall current My Dell Fusion service, uninstall My Dell, restart the computer

 - Install My Dell Fusion Service 2.0.58.0, install My Dell via the Microsoft Store

This worked for my Dell XPS 15  9510   Win11 Home.

I followed exactly the same procedure on my Dell Studio 1558  Win10 Home. With this system, after I uninstalled and restarted, I couldn't get the Microsoft Store to show the download for My Dell (to reinstall) until I restarted twice. Then the dnld/install was ok. The first time My Dell installer finished, it asked for the update which worked. If there are any other issues that surface, I'll post here.

The new version of My Dell (ABOUT link at bottom right of app window) is 2.0.30.0  (previous version 2 days ago was 2.0.24.0).

Thanks to Dell Support for getting this fixed and explaining the issue.

Latest Solutions
Top Contributor