Systems Management General

2 Bronze

Installing OpenManage on CentOS 6.3 x64

Hello fellas.

I've found an thread here, that helped me a bit:

Well, i've followed some procedures there and managed to do most stuff.

But when i run "yum install srvadmin-all", i always get the message "No package srvadmin-all available".
Is there anything else i could do, or my OS is really not supported ?

The instructions followed were:
1. Does your servers have direct internet access ? or is this through a proxy server ?

try accessing " wget "
(i changed that one - i downloaded this: )

and see if you are able to download this file. If successful then try

2. try from step 2.

2. yum clean all

3. wget -q -O - | bash

4. yum install srvadmin-all (this is the step i'm stuck)

Thanks in advance everyone
Replies (6)
2 Bronze

im Stuck at the same spot also. running centos 6.3 32-Bit

2 Bronze

Well dude.


I managed to install it.


what can i say, basically i deleted the openpegasus package.

i don't have the info right now, but i had to do some commands in order to remove it completely. basically only linux rpm stuff, in order to leave NOTHING from it in the system.


After that i installed without problems.

Only storage part isn't working - but since i have gold support from dell i'm talking with an

analyst in order to fix this


If you need anything, mail me.

<Email id removed>

Bye ! 

2 Bronze

Hi!!! i have one error when install omsa 7.2 into centos 6.4 x64. The same error when upgrade from 6.3 to 6.4.

[root@asterisk ~]# start
Starting Systems Management Device Drivers:
Starting dell_rbu:                                         [  OK  ]
Starting ipmi driver:                                      [FAILED]
Starting Systems Management Device Drivers:
Starting dell_rbu: Already started                         [  OK  ]
Starting ipmi driver:                                      [FAILED]
Starting DSM SA Shared Services:                           [  OK  ]
Starting DSM SA Connection Service:                        [  OK  ]

into 6.3 omsa work well.


2 Bronze

In RHEL 6.x (and by definition, CentOS 6.x), you will have to remove the tog-pegasus package because of some conflicts:

# yum remove tog-pegasus tog-pegasus-libs

(is it openpegasus in CentOS? Don't know)

Also, you will have to hack /etc/redhat-release and make the install script think you're installing on a RHEL system, so for RHEL 6.3, for example, just put in:

Red Hat Enterprise Linux Server release 6.3 (Santiago)

Finally, don't know if this will work on CentOS 6.x 32-bit, since only 64-bit is supported on RHEL6/CentOS6.

2 Bronze

the problem is when uppgrade to centos 6.4. In this version omsa failed to start. Centos 6.3 work fine.

2 Bronze

This is what I used and works great! Easy to upgrade also

Top Contributor
Latest Solutions