Tablets & Mobile Devices

2 Bronze

Dell Venue 8 Pro, boot to USB

I can't for the life of me figure out how to boot to USB.

I can enter the BIOS and turn off secure boot and set my USB flash drive as the first bootable device but I can't get it to boot.  The boot menu shows my flash drive as UEFI (flash drive name).  I think that may be the problem because I cannot find any option to enable legacy boot.

Is there a way to disable UEFI boot and is there a way to boot any bootable flash drives that work in other systems?

If this is limited to UEFI boot and does not support 64bit, how on earth do you make a PE4.0 32bit support UEFI boot?

Thanks for any help you can give me,

Dave

Replies (39)
2 Bronze

I want to boot from USB as well, I even had a UEFI operating system Ubuntu on the USB drive and it won't boot.

We should be allowed to boot from USB, hopefully some one can figure it out. Thanks.

 

2 Bronze

I worked on getting windows 7 32bit to boot all day, I tried some with windows 7 64bit but stopped because dell has no 64bit drivers for the venue 8 pro. There is no use trying to install windows 7 so don't even try. It is clear this device is made for windows 8 32bit only. If some one can even get Linux to boot I will be shocked, I've had zero luck. Some one prove me wrong? :emotion-15:

2 Bronze

You may need to format the USB as GPT not MSDOS.  Then Create the EXT4 partition.  Then use the USB utility to make a bootable Ubuntu system.

2 Bronze

I have to agree with Jason, I think your going to find it's Windows 8 32bit only.

I'm unaware of any way to launch Ubuntu in 32bit UEFI and even if you could I have a feeling the Atom is made for Windows only.

I was able to find a third party program that can boot the system but only because it uses the Windows 8 recovery enviroment to boot.  Thanks to my friend Brian_K for helping me with it.  http://www.terabyteunlimited.com/howto/tbwinre_tutorial.htm

So at least I can image the system and boot to a USB to restore it without using the Dell factory image restore that I could not figure out how to use from a USB drive.  I created the option to create the factory restore onto a USB drive and the USB drive did indeed boot the system but the first box that came up says "the system must be plugged into a power source for a recovery".  Thats where I hit a dead end, if I unplug the flash dive to connect the power it will not continue (of course), if I don't plug it in then the recovery will not contine.  Glad I tried it, thank god I wasn't depending on it.

One interesting thing is that after creating the factory recovery onto a USB, it's setup like a windows 8 installation disk.  The Sources\Boot.wim file can be switched with another .wim file and the flash drive will boot it.  I replaced it with a PE2.0 wim file from another boot CD (Ghost 15) and it started the program but I got stuck because the touch pad did not work on the first screen to accept the license agreement.  I have not had time to play around with it but a PE4.0 wim file may work fine although I don't see any benifit of booting Windows 8 to go on a Windows 8 system.

I'm also disappointed that the SD card is not listed as a bootable device, it would save me from having to use an external flash drive and the SD card is always with the system.   On all my other laptops I make the SD card bootable with grub4dos and have several ISO's, recovery disks, and Linix distros I can boot to.

Oh well, at least I can image it and recover it now.

Dave

2 Bronze

I'm going to try and boot from the windows 7 DVD and Ubuntu DVD from an external DVD drive I have, I'm waiting on a USB cable that powers the DVD drive though from eBay, if it boots from DVDs that will be good, may be it just docent like USB flash drives. I'll let you know if it works when I get the cable and try it out, wish me luck. :emotion-14:

2 Bronze

I heard even if you get to boot, dell doesn't provide the drivers for the touch screen - so you have to control the OS with mouse and keyboard.

My Win partition got corrupted and I can't boot into windows. so I am in the same boat, trying to figure out how to get the recovery partition to boot and restore the dell Win8 32bit

2 Bronze

I booted Fedora 17 but it would not load the GUI. I found out this device only supports a 32-Bit Uefi operating system, Linux currently won't support 32-Bit Uefi so were stuck with Windows 8 32-Bit Operating system. Request dell to add a legacy boot mode to the Uefi bios, I did, that will allow us to boot any operating system from USB. Lets all ask dell to add legacy boot mode to the Uefi bios, they might just listen.

2 Bronze

Does anyone know if we can switch this to 64-bit Windows 8.1 via any method and have the touchscreen work?  I realize there is no benefit from a ram perspective since there is only 2gb in it but there are some sdk's (i.e. win phone 8) that only exist for 64 bit and I would love to switch windows 8.1 from 32 to 64 bit.  The quote below is a bit ambigous to me since it talks about emulation.  Has anyone tried this?  Most of the above is attempting linux.

Dell Update Packages in Microsoft Windows 32-bit format can be deployed on Microsoft 64-bit operating systems by implementing the WOW64 emulation applications. WOW64 is a standard feature on most Microsoft operating systems.

2 Bronze

You really can't boot a 64-Bit operating system on the Dell Venue 8 Pro, you can only boot a 32-Bit Uefi operating system, so you can't run windows 7 32-Bit because it does not support Uefi and you can't run windows 7 64-Bit because it only supports 32-Bit with Uefi support. If we had legacy boot mode to enable then yes I think we could boot any operating system installer 32-Bit or 64-Bit, keep asking dell for it in the forums and they may just decide to give us legacy boot mode in a bios update, the more users ask the more likely they will listen.

Top Contributor
Latest Solutions