Vostro

Last reply by 05-11-2022 Unsolved
Start a Discussion
1 Copper
1 Copper

Dell Vostro 15 5568 BIOS Update TPM Error

Laptop has been working perfectly fine for years.

Installed the latest updates from the Dell Website using the Dell Assistant Tool.

Laptop rebooted to do the latest V1.20 BIOS update.

Every time I switch the laptop on it now gives me a "Alert! TPM has not been detected." error message during POST.

Tried rolling back BIOS version, but could only go back to V1.13.2, as V1.20 blocks downgrading lower than that.

Contacted DELL and they said laptop is shipped with a TPM chip.

On further discussion, they informed motherboard is faulty and would need to be replaced and that there is nothing more they can do.

Terrible service, and would definitely NOT recommend getting any Dell device in the future if this is how they go about doing updates for their devices.

Reply (1)
Moderator
Moderator

We tried reaching you on a private message asking for the Service Tag number to ascertain the warranty but did not receive a response. Please feel free to reply to the private message whenever you are available.


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Top Contributor
Latest Solutions