Windows 10

Last reply by 09-27-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
3038

Alienware Command Center Incompatible Software error.

Dell G3 15 3500

I recently updated my drivers and I am getting this pop-up in AWCC.

01.png

The CPU overclocking and monitoring features are not working anymore and I'm persistently getting the following error.

02.png

Even after uninstalling and re-installing the AWCC application, it gives the same error.

Replies (16)
2 Bronze
2 Bronze
2659

I am facing the exact same issue, I uninstalled the command centre itself and reinstalled it from dell.com/support in hopes that it would get fixed. But it's showing the same error nonetheless. I think it's just a software bug that will hopefully get fixed with the next updates.

2 Bronze
2 Bronze
2567

Has anyone figured this problem out. I am having the same issue??

2 Bronze
2 Bronze
2506

I have a feeling that it is related to some other low level driver update (for me maybe via AVG Driver Updater) and so not fixed by re-installing AWCC.  As to which driver I don't know.  Unfortunately, I do not appear to have a system restore point for the driver updates

3 Argentum
2503

Solutions to fix-

 

Solution 1: Change the Start Up Type of AWCCService to Automatic
The Command Center might stop working if its service (i.e., AWCC.Service) is not configured to startup automatically, leading to delay responses from the Command Center (if any). In this case, setting the start-up type of AWCCService to Automatic may solve the problem.

Exit the Alienware Command Center (if possible) and right-click on the Taskbar of your system, and in the resulting menu, click on Task Manager.

Open Task Manager
In the processes tab, make sure no Command Center process (you might see Alienware Command Center and AWCCService processes) is running by right-clicking it and then clicking on End Task.
Then navigate to the Services tab and near the bottom of the window, click on Open Services.


Now, in the Services window, right-click on AWCCService, and in the menu, click on Properties.

Right Click AWCCService
Then, open the drop-down of the Start-Up type and change it to Automatic.

Change Start Up Type of AWCCService to Automatic


Now, click on the Apply and OK button and then restart your system.
Upon restart, check if your system is clear of the error.


Solution 2: Remove / Disable 3rd Party Applications
In a Windows environment, applications coexist and share system resources. You may encounter the error under discussion if any of 3rd party applications interfere in the operation of the Alienware Command Center. In this context, removing or disabling 3rd party applications may solve the problem.

Right-click on the Windows button, and in the resulting menu, select Apps & Features.

Open Apps & Features
Now expand MSI Afterburner and then click on the Uninstall button. If you do not want to uninstall, then clean boot your system and make sure none of the problematic applications load at the startup.

Uninstalling MSI Afterburner and Rivatuner
Then confirm to uninstall and follow the prompts on your screen to uninstall MST Afterburner.
Now follow the same procedure to uninstall all the problematic applications (RivaTuner is also known to create the issue, or you can create a profile in Riva Tuner for the Command Center) and then check if the issue is resolved.

 

This may help you,

Rachel Gomez

2 Bronze
2 Bronze
2502

So, to the original issue, I have found a solution (sort of)

According to this https://www.reddit.com/r/Alienware/comments/px2b04/fyi_alienware_x17_windows_11_disable_virtual/, if you have installed Windows Subsystem for Linux, it also enables "Virtual Machine Platform".  It is this "Virtual Machine Platform" (VPM) that stops the overclocking in AWCC.  I turned off the VPM and voila I have overclocking again.  Sadly, WSL no longer works.  As I don't need to overclocking, I will re-enable VPM (I just hate seeing this reporting errors)
Secondly, regarding AWCC service.  I don't know _why_ but this service is nearly always "Disabled" on boot.  I have to manually set it to Automatic and then start it for AWCC to function.  I have run the "AWCC repair" and the "Alienware Command Center Package Manager" repairs to no avail...  Not particularly happy but at least I can start it and my AW768 special keys work.  Interestingly, in Windows Device Manager, I see 2x AWCC Drivers.  One with the warning icon.  I have used Windows diagnostics to "fix" it but that did not work either

2 Jasper
2 Jasper
2211

Ok to fix this issue turn off memory integrity in windows security. With that turned on it will not let you overclock your Alienware. 

2 Bronze
2 Bronze
2149

I got a simple solution for this problem just go to your windows security section then go to Device Security > Core Isolation > Core isolation details then there turn of the memory Intergrity and just restart you laptop done.  image_2022-09-01_233550889.png

 

1503

Thank for the solution, it works well.

1275

This worked for me. Thank you for the help. All the other fixes didn't work. Everyone who thinks what he says doesn't work. It does. Thanks again, man.

Latest Solutions
Top Contributor