Windows General

Last reply by 01-23-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze
159545

Power Icon Notification Area Greyed Out

I'm using Windows 7 64bit on a Vostro 430 desktop computer. With my laptop, there is a power notification icon the system tray I can click to change power plan.  On this desktop, the notification icon does not appear, and the option to turn it on is greyed out.

Is there any way to turn this option on? I change power plans regularly depending on what I'm doing. Downloading large files for instance requires the computer to not sleep, whilst watching movies, I generally like the brightness turned up.

 

Replies (8)
2 Bronze
2 Bronze
3009

On Microsoft Windows Forums > Windows 7 Forums > Performance and Maintenance  a question was asked: power icon from the task bar is missing.

http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/e7f180ef-81e3-40da-8703-64aced... 

The answer states that Check boxes may be disabled and greyed out probably due to third party drivers that want to show manufacturer's icon instead.

They suggest you go to http://support.microsoft.com/kb/945011 Most Microsoft articles get moved on a daily schedule to prevent anyone finding an answer, but with a little luck you might find it.

6 Indium
3009

Power Options are usually meant only for laptops, where you want to save battery power.

You can find some options in the Control Panel, but most are not available because you don't need them.

XPS M1530, Win 10 CU Pro 32-bit
Inspiron E1705, Win 10 CU Pro 32-bit
Dimension 9100, Win 10 AU Pro 32 bit
Inspiron 660, Win 10 CU 64 bit
Inspiron 3668, Win 10 CU 64 bit
Asus T100 Tablet, Windows 10 CU 32 bit

2 Bronze
2 Bronze
3009

Surely a desktop should have all the software options of a laptop, even if they aren't particularly needed? I find that even on my desktop, I am missing Windows Mobility Centre and the ability to quickly change power options. 

Anyway, thanks for the answers, I'll guess I'll just have to do it the manual way from now on.

6 Indium
3009

Desktops usually do not have the hardware connections needed to support all the possible power configurations of a laptop. I (and many others) have had mucho problems trying to run even sleep and hibernate smoothly  on desktops, This not just with Dell but other brands. Most functions are designed to reduce power drain during battery operation. You still have screen shut off and sleep mode/

XPS M1530, Win 10 CU Pro 32-bit
Inspiron E1705, Win 10 CU Pro 32-bit
Dimension 9100, Win 10 AU Pro 32 bit
Inspiron 660, Win 10 CU 64 bit
Inspiron 3668, Win 10 CU 64 bit
Asus T100 Tablet, Windows 10 CU 32 bit

2 Bronze
2 Bronze
3009

I hope I can revive this thread so late after the last post - I am in the same situation.

I use my XPS 8100 Desktop (W7-64) to run audio production software and want to be able to switch to my "Disks On" power profile without having to go into the Control Panel.  I used to be able to do this on my old XP machine via the Power icon in the system tray but on this one the option to enable it is greyed out.

I have also discovered that this may have been disabled by the manufacturer and I have read the above discussion.  I understand the argument that power-saving options are not as important to desktop users but we also get electricity bills!  I want to normally run under the Dell default setting but change to "Disks On" when needed. 

Can someone confirm whether this is a Dell setting and describe how to undo it?

Thanks and regards,
Swatcher

2 Bronze
2 Bronze
3009

Swatcher - I'm yet to try this solution, but others on the Microsoft forum have verified it worked for them. It's been a long time since this thread was started so you may have fixed the issue already.

http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/power-icon-from-the-task-bar-...

Please perform the following steps:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
 

http://support.microsoft.com/kb/322756/ - How to back up and restore the registry in Windows
  1. Click Start.
    In the Start Search field, type regedit.exe and then press Enter.
    If you are prompted for an administrator password or for confirmation, type the password, or clickAllow.
  2. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
  3. In the Details pane, click the IconStreams registry entry.
  4. On the Edit menu, click Delete, and then click Yes.
  5. In the Details pane, click the PastIconsStream registry entry.
  6. On the Edit menu, click Delete, and then click Yes.
  7. Exit Registry Editor.
  8. Restart the Explorer.exe process. To do these, follow these steps:
    1. Press CTRL+SHIFT+ESC.
    2. On the Processes tab in Task Manager, click the explorer.exe process, and then clickEnd Process two times.
    3. On the File menu, click New Tasks (Run), type explorer, and then click OK.
    4. Exit Task Manager.
  9. Once Explorer.exe has restarted, right click on the clock and choose "Customize Notification Icons".
  10. Ensure that Power is set to "Show icon and notifications".
  11. Click on "Turn system icons on or off"
  12. Ensure that Power is set to "On".
  13. Click on OK and close the Control Panel.

Hope that helps, have a great day!

2 Bronze
2 Bronze
218

I have stuck with the same problem: one day power icon just disappeared from tray and no one solution worked. Luckily, with time I have found a solution. In Windows registry check the “HideSCAPower” parameter in two paths:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

They both must be either does not exist or set to zero values.

In my case they both existed, but the last one was set to one. Most probably it was set during installation of any software, but I dunno... it is an old diagnostic laptop with a ton of strange vendors' software.

3 Argentum
48

Right-click on an empty space in your taskbar, then select Taskbar settings. This is going to open up the appropriate Settings app page. Scroll down until you see the Notification area section. Here, click on the “Turn system icons on or off” link.

 

Regards,

Will

Latest Solutions
Top Contributor