Windows General

Last reply by 01-20-2018 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Reconstructing Latitude E6410 recovery partitions

When I start "Dell Backup and Recovery Manager" in Win7x64 I get an error message that Windows-Recovcery is not installed and it's required for Dell Backup and Recovery Manager.

I got this error the first time after I tried to install Win7x64 from the DVD included with my Latitude E6410. The recovery-partition was gone after the installation. Thank god I had a backup of the file factory.wim (= factory image) and also a bootable USB-stick which I had created with backup and recovery manager before. So tried to reconstruct the two Dell recovery partitions and created them with Acronis Disc Director. I was able to recover Windows7 from the bootable USB-stick. But I'm not able to reconstruct the recovery partitions  for "Dell Backup and Recovery Manager".

Now I have the following volumes:

1: S: 750MB SYSTEM (Boot and WinRE), NTFS ID=DE, active

2: R: 10GB RECOVERY (Dell Factory-Image), NTFS ID=27

3: C: 120GB OS (Win7x64), NTFS ID=7

4: D: 334GB DATA (files I create), NTFS ID=7


The boot.wim-file from the USB-stick, I copied to S:\recovery\windowsre\winre.wim

The factory.wim file, I copied to R:\Dell\Image\Factory.wim. In this directory there's also the catalog.ini.

The ResSys.ini is in R:\ResSys.ini.


My BCD-file from S:\boot\bcd (where bcd is the file, not a directory) contains the following lines:

Windows Boot Manager
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=\Device\HarddiskVolume1
description             Windows Boot Manager
locale                  de-DE
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {aaf6f214-1228-11e0-83ea-b8a9be702cbb}
resumeobject            {aaf6f213-1228-11e0-83ea-b8a9be702cbb}
displayorder            {aaf6f214-1228-11e0-83ea-b8a9be702cbb}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 30

Windows Boot Loader
identifier              {aaf6f214-1228-11e0-83ea-b8a9be702cbb}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  de-DE
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence        {5f0663a9-f7ea-11df-901f-5c260a2027cb}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {aaf6f213-1228-11e0-83ea-b8a9be702cbb}
nx                      OptIn


When I boot my system and press F8, I choose Windows Repair Mode, Windows boots normaly. No repair window appears.

The only way to get to the repair screen after booting is my USB-stick.

Does anybody know what's wrong here?

Replies (10)
3 Zinc

Hello Onkelhim

The 1: S: ID=DE doesn't look correct. DE is usually OEM by dell for the Diagnostics. DE will

make this partition hidden, maybe not bad but Windows RE must be one of the following types:

MBR disks - type 0x7 or type 0x27, If type 0x27, it must be at the beginning of the disk.

The 2: R: ID=27 This makes the Recovery hidden to the system and it can't see the factory.wim

file. Type 27 should be at beginning of the drive.

All of this might not fix your problems, but it's a starting place.

Hope this helps and good luck.


3 Zinc

My mistake, type 27 doesn't make the partition hidden. Type 17 does.

Forget about my remarks on that part.


2 Bronze
2 Bronze

Thank you, Tom,

I changed the type of partition 1 and 2 to 07 again. This type I already had, when I copied the files on these drives. Now I can see them in Windows Explorer again.

So I tried pressing F8 during boot. The menu appeared and I selected repair mode, but Windows booted normally from partition 3 (C:).

In Windows I started "Dell Backup and Recovery Manager". The error message that WinRe is not installed appeared again.

I'm not really sure, but I remember partition 1 was type DE in factory default.


On some websites I read about Reagentc.exe. Do I have to use it to get the BCD connected to my Windows Installation again?

I don't know what the bootmanager does with entries like identifier, inherit etc. Do I have to make any changes here?

identifier              {aaf6f214-1228-11e0-83ea-b8a9be702cbb}

inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}

recoverysequence        {5f0663a9-f7ea-11df-901f-5c260a2027cb}

resumeobject            {aaf6f213-1228-11e0-83ea-b8a9be702cbb}


Thanks Matthias

3 Zinc


The Reagentc.exe file is used to set the path of WinRE or OS.

Make sure your drives have correct letter assigned.

R: for system

C: for OS

D: for recovery

usually how it's setup.

Just went back to your first post, you have S: for system and R: recovery which is OK.

Run Reagentc.exe as

{c:\windows\system32\reagentc.exe /setreimage /path S:\recovery\windowsre /target c:\windows}

no brackets, make sure the windowsre is in a directory called recovery on S:\ drive.

this should set the path to the winre.wim.

Again run reagentc.exe to set the path to the image file as

{c:\windows\system32\reagentc.exe /setosimage /path R:\dell\image /target c:\windows}

no brackets.

Hope this helps


2 Bronze
2 Bronze

Hi Tom,

I tried as you described. In the first step I still get an error message.

The winre.wim file is placed in S:\recovery\windowsre

When I start reagentc with this command

c:\windows\system32\reagentc.exe /setreimage /path S:\recovery\windowsre /target c:\windows

I get the following error:

failed process: b7
The file can not be created if it already exists.

It doesn't say which file already exists. Do you know where the information is stored?


Setting the path to the factory.wim was completed without any problems:

Directory set to: \\?GLOBALROOT\device\harddisk0\partition2\dell\image

REAGENT.EXE Operation completed successfully



3 Zinc


Question do you have winRE.wim in that directory, or is the image already mounted?

You might try moving it to S:\recovery and see what happens.

Also might require a boot to set the path before it will work.

Just keep trying.


2 Bronze
2 Bronze


the winre.wim is already in the directory.

Now tried the following an was sucessful :)

reagentc.exe /disable

reagentc.exe /setreimage /path S:\recovery\windowsre /target c:\windows

reagentc.exe /enable

Now the Dell Backup an Recover Manager starts without any errors and with F8 at boot I can get to repair mode.


Many thanks for you help.


3 Zinc

Hello Matthias

Glad you made it worked and thanks for letting us know what you did that worked.

Now I learned something new.

Good luck and Happy New Year.


2 Bronze
2 Bronze

Hello Mathias,

I know this is an old thread, but this is the most related info that I can use in regard to my problem.

I've the same problem as you had, and follow steps you were follow here, and still get the problem with

setting path of winre to recovery\windowsre\

DBRM still giving the same error

Reagentc  /disable error

Operation Failed: 2

The system cannot find the file specified

Reagentc  /setreimage /path S:\recovery\windowsre /target c:\windows

failed process: b7

The file can not be created if it already exists.

Reagentc /enable

Operation successful

Reagentc /info

Windows RE enable : 1

Windows RE staged : 0

Setup enabled            : 1

WinRE.WIM directory : \\?\GLOBALROOT\device\harddisk0\partition1\recovery\windowsre

Recovery Environment : \\?\GLOBALROOT\device\harddisk0\partition1\recovery\windowsre

BCD ID                            : 3fa5486f-4324-11e0-9225-f04da2b958fb

Setup Files                     : \\?\GLOBALROOT\device\harddisk0\partition4\dell\image

Recovery Operation      : 4

Operation Parameter   :

Boot Key Scan Code      0x0

It looks the path already correctly setup, but "Repair Your Computer" on F8 still start windows OS  and not to recovery options (WinRE boot ?), DBRM also still cannot function.

Another things is, I use winre.wim from DVD boot and not from USB Flashdisk as you had

and if I look at ResSys.ini file, it contains :


1=Recovery - 20110520154658

[Recovery - 20110520154658]









Does it have some info that need to be changed in regard to the problem?

Can I have the info of your ResSys.ini file and Reagenc /info result?



Latest Solutions
Top Contributor