Windows General

Last reply by 02-11-2020 Unsolved
Start a Discussion
Not applicable

Restore from dell recovery partition with Imagex [Solved]


This is the scenario that happened to me. After couple of hours I managed to overcome the problem, but it took too much time. So I thought I share my scenario and things I did, as on the way to success I met several issues that are commonly known, at least according to questions can be found on forums.

For those who need urgent help, first let me present step by step solution that worked for me:

0. If you're in the same situation and you have to move your recover partition to a new drive first, you can easily do this using this free tool: Paragon Backup & Recovery. Works from Windows level.
1. Download Imagex.exe tool from this link: or by googling for 'KB2525084-v2' hotfix. Choose x86 for 32bit procs or amd64 if you have 64bits one - this is very important.
2. Copy the Imagex.exe file to a pen-drive. Mine was bootable, but I'm not sure if it has to be...
3. Format partition designated for the system. From now on let's assume it is C:
4. Boot the machine from windows installation disk or any other way you prefer to access your pen-drive in DOS
5. Changed dir to the one containing Imagex on your stick
6. Run this command: "imagex /apply d:\dell\image\factory.wim 1 c:\" - where D is your partition recovery.
7. Reboot pc. If system starts, that's great. If you see "Bootmgr is missing" message - keep reading
8. Make sure C: partition is the active one.
9. I'm not advanced in bootsectors etc. and probably you may have different case and some of the below commands are not needed, but they did the job for me. I was restarting pc after each point and after C. it was working.
A. bootrec /rebuildbcd
bootrec /fixMbr
bootrec /fixBoot
B. C:\boot\bootsect /nt60 C: /force
C. bcdboot c:\windows /s c:
10. Hopefully, enjoy fresh system :)

For those who like reading - same solution but with more details:

If you have a recovery partition without Tools folder with executables provided by Dell to restore the system, you do a quick googling and you know that all you need is:

imagex /apply d:\dell\image\factory.wim 1 c:\

where D is your partition recovery and C partition designated to be the system one. [Imagex] is a tool you can get with Windows Automated Installation Kit as everyone says but the better way is to ask Microsoft to send you link to it so this way you will need to download 0,5MB instead of 1,5GB and burn or install nothing. I've requested it here:

but if this link is not working for you try to google this:


that's the name of the hot-fix you will get a link to. Once you get it unzip and then extract the imagex.exe file from .cab file. Now, you can start restoring your recovery with command

imagex /apply d:\dell\image\factory.wim 1 c:\

from Windows level, if it's working, run cmd.exe with administrator priv. navigate to folder containing Imagex.exe, paste the command and go. If you're lucky it will work and you're happy. It won't for me. Firstly because I was running the command on Imagex.exe that I got from WAIK/Tools/x86 dir. Why did I do so knowing that I have x64? Cause Internet told me that, and other options I had were ia64 which is AFAIK for Itanium processors and amd64 which is likely for AMD processors so these looked like no options for my i7 processor.
So what I got running above command on x86 imagex.exe was the ERROR something like:

[ERROR] C:\Windows\System32\drivers\1028_Dell*********.mrk <Error = 5>

Error restoring image.

Access is denied.

Googling, googling, checking some possible solutions with permissions etc. and got nothing.

So I gave a try the same command but using the command line you can access if you boot a pc with an installation disk, then choose [Repair system] option. Guess what, it did not even started. Message:

The subsystem needed to support the image type is not present....

... or something like that. Back to Google and no solution found again.

Got back to Windows command line and I thought that why not to give a try this imagex.exe from amd64...? So I did and it worked. The restoring started and although I had a feeling that it not gonna reach 100% I hoped it would.... but it didn't. It stopped at about 20% of the way with a message:

cannot copy bla_bla_blaaaa_AMD_blablaaaalba_AMD.....

"OK, of course it cannot do something about the AMD couse I do not have this processor, so the windows on recovery something that imagex designated for amd64 wants...." - first quick thought in my head and I believed that.

Ok, so then I started googling for Imagex.exe for x64 and I found a link for this hotfix I've mentioned at the very beging. Great, so now I had the tool for x64 and what's more it's a hotfix. Enthusiasm was back in house. Download, extract, run and it's working! ....till the 20%, again with a message about the AMD...... Wait a minute..... so amd64 imagex was ok too probably.... and probably it's the same as what I got from MS site.... Never mind. I tried to delete the ....AMD.... files from Windows dir, but i couldn't so I formatted the C partition. Then finally, running the imagex.... command worked in 100%. But after restarting the machine another problem:

Bootmgr is missing

If you google on that one, you'll be probably advised to do this:

bootrec /rebuildbcd
bootrec /fixMbr
bootrec /fixBoot

It made a difference (from now on I was able to see Windows installation in 'Repair' window) but it did not solve the problem. So next I gave a try to this one:

C:\boot\bootsect /nt60 C: /force

I could remember that one helped already in the past, but not this time. Still problem was not solved. So next I started playing with bcdedit.exe tool. Thanks to it I noticed that my DCD doesn't look like the examples from the Internet, so I was just about to start creating it from scratch with this tutorial:

when I decided to do a quick try to this command:

bcdboot c:\windows /s c:

which I have found somewhere else. After executing this command I checked the BCD again using bcdedit.exe and then it looked promising. Restarted machine and finally it was working. I did restore the system from recovery :)

Hope that helps,
Replies (6)
2 Bronze
2 Bronze

More than one year later, but today your post was very useful for me, you don´t have idea how I appreciate your post!   By the way, after applying the image at 100%, restarting was a expected problem but in this case I only selected the Startup Repair option from the Windows 7 disk repair menu and works fine. :)

Thanks a lot!


2 Bronze
2 Bronze

wish i had seen this earlier, I fortunately had a copy of my Recovery partition so i was able to use my dell image to recoveryImage, using Ximage after lots of looking about, i failed to make any backup cd's just my recovery partition. put my drive to something like it was once upon a time... now i have to try to install some windows enviroment to rebuild my recovery partition. why cant dell just offer you a software solution that restores your partitions and all boot files so you can back the disk to its original state. if the recovery partition fails.??? 

7 Plutonium

why cant dell just offer you a software solution that restores your partitions and all boot files so you can back the disk to its original state. if the recovery partition fails.??? 

Because of Microsoft, Microsoft won't let Dell or other OEMs provide download links to Windows installation .isos and hence factory images.

Dr Philip Yip
Tech Enthusiast and Author of the Unofficial Dell Windows Reinstallation Guide

Windows FAQs and OEM Downloads

#IDoNotWorkFor Dell
2 Bronze
2 Bronze

If you have a Factory1.wim file that means you also have a Factory.wim file.  This means that if you run imagex and only specify Factory1.wim, that part of the image will be applied but the OS will not run until ALL parts of the created image are applied. 

There are 2 ways to do this imagex/apply C:\dell\image\Factory*.wim D:, D: being the target.  The Factory*.wim tells imagex to apply all images to D:.  Spanned image files are coded so the program knows how many .wim files it has to process to successfully complete applying the image to the target drive.

The other method is to use Hirens Boot Disk, boot and browse to a program Gimagex, the graphical interface program where you can use a mouse to browse and select the source and target of the Image.  Images that are spanned (about 4GB) are usually created to fit each spanned image on a DVD single layer.  If you create an image using Gimagex, you can save the image in one file as large as it takes. Using Gimagex is nice because you don't have to type any DOS commands and screw it up by adding or not leaving a space in the command.

On Dells sometimes the image shows up on C and the OS resides on D, after applying the image when you reboot your computer, C will be hidden and D will be automatically changed to C.......I know its confusing but that's the way it is....



Easy to say but every time you get a new computer you should create an image of all partitions on the hard drive  to an external hard drive so these people don't hold you hostage.  Then when it hits the fan you can recover easily. Every few months make another backup image, it will contain all of your programs installed up to that date.

Get carbonite,, so that your docs, pics etc are saved in real time. You can download these files after you reapply your latest image.

Its easy to do, and the more you do it the easier it gets to understand what you are doing.........


At least now you can go to this website and create a bootable USB drive with your operating system on it to reinstall the windows it came with.

All you need to do is enter your SERVICE TAG NUMBER...............enjoy

Latest Solutions
Top Contributor