Wyse ThinOS

Last reply by 03-23-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

ThinOS 9.2/3 - Belgium eID - Smart Card redirection


We are currently using Dell Wyse Thin OS.

We tested versions 9.1 9.2 9.3.

We have 3040 / 5070 / 5470 Mobile & AIO models.

We started with the Wyse Management Suite console version 3.x. Currently we have version 4.0.

We use for the VDI part, VMware Horizon 8 (2206).

In Belgium, we have an identity card which requires a driver: https://eid.belgium.be/en

We noticed that Dell Thin OS does not have this driver and therefore, when we use VMware Horizon Agent (Smart Card Redirection Features), it does not work because the eID card cannot be read by the Thin OS (local).

So we tested USB redirection. This worked during our tests in version 9.1.

Since the latest ThinOS updates? the Smart Card no longer goes up in our Horizon session.

We configured the GPO part of Horizon with this procedure: https://i0.wp.com/www.ituda.com/wp-content/uploads/2016/01/USBSmartCardRedirection.jpg?w=1246&ssl=1

For the USB redirection part in ThinOS, we have configured this: https://i.ibb.co/RQSy6dN/Sans-titre.jpg

Could you help us in configuring USB redirection?

Are we doing something wrong?

This is very blocking for us and in our choice of Thin Clients for the future.

Thank you for your help.

Replies (10)
2 Bronze
2 Bronze

If you're using PCoIP, have a look at my post from yesterday:


Hopefully this will help.


Hi xiDannYo,

I see your post yesteday but... it's Blast in my case.


Have you tried: 

VMware View Agent Configuration/View USB Configuration/Client Downloadable only Settings > 'Allow Smart Cards' on 'Default Client Setting' rather then Override? ours is on Default and it works on Blast too.


I try tomorrow and i come back to you.

2 Bronze
2 Bronze


I reconfigure and retry today (factory reset too) without success...

My configuration :







For 'Include Device Family' we have left 'Not Configured' and it still works.

There are two policies where we've enabled smart cards:
VMware Horizon Client Configuration > View USB Configuration > Alllow Smart Cards (Enabled)
VMware View Agent Configuration > View USB Configuration > Allow Smart Cards (Enabled)

2 Bronze
2 Bronze

I receive a guy from Dell BeNeLux - Ireland today for ThinOS.

He recommand to rollback to 9.1.6*.

I try that tomorrow and i come back to you.

2 Bronze
2 Bronze


with ThinOS 9.1.6x and this configuration :



SmartCard is read on the VDI.

2 Bronze
2 Bronze

I had the same problem, for me the trick was to activate the Smartcard-redirection on the Horizon-Agent on the master image.



Latest Solutions
Top Contributor