XPS Desktops

Last reply by 12-01-2022 Solved
Start a Discussion
3 Argentum
1606

XPS 8930, slow shut down

XPS 8930

Hi All,

My XPS 8930 started to shut down very slowly (1.5 - 2.0 min) at the end of each day, about 5-10 days ago. (Fast boot up, about 21 seconds from the time the Dell logo shows.)

I checked for updates and updated 3 "Urgent" updates, including Bios. But the problem persists.

I have a pretty standard configuration: Win 10 Pro 21H2 (build 19044.1889), 32GB RAM, MS Office 2021 and other standard software, etc.

Would greatly appreciate your advice.

JF

Solutions (3)

Accepted Solutions
10 Diamond
939

Have you tried rebooting your router and modem, if you have both?

Are you using WiFi or Ethernet?

There have been a couple of recent "Intel Corporation - Extension" updates (most recently - v3.1222.608.4, ‎on 8/‎26/‎2022 here) that were pushed by Windows Update (look in WU update history), that are actually updates for Killer Ethernet on the XPS 8930. (Intel bought Killer a while back.)

This last update didn't actually update the Ethernet driver (v9.0.0.50), and supposedly only fixed a bug in the Killer Control Center app. I don't use KCC, so don't know if this latest update could be a problem.

Also got "Intel Corporation - SoftwareComponent - 3.1222.608.4" update (8-31-22) which has the same number as the "Extension". No idea what this one is.

I use Killer Ethernet without a router on my XPS 8930 with FiOS service, and haven't noticed any specific access delays. But, I did notice this last Extension re-enabled all the unnecessary Killer and xTend services listed in services.msc which I had previously disabled. So you may want to disable those, if they're enabled, and see if that helps. 

I also disabled the Killer Intelligence Center app on the Startup tab in Task Manager, because I don't want/need that one either. So that's another thing to look at.

Don't know if any recent Intel updates are for Killer WiFi because I have Qualcomm WiFi in my XPS 8930. So if you're using Killer WiFi, I can't help there...

Ron

  Forum Member since 2004
  I am not a Dell employee

View solution in original post

10 Diamond
725

@Josephus Flavius  Glad you got it sorted!

I beat you on boot time! It's only 12 sec here according to Task Manager, and I timed ~10-15 sec for shutdowns.

I also have Logitech Options on my PC and had to configure my firewall to block Options from accessing the net, which it does constantly, even though I set Options not to look for updates automatically.  Wouldn't be surprised if that was your culprit.

I hate when updates change the user's settings back to defaults without warning. So I make a habit to review all my settings after any major update, especially after a BIOS update. BIOS updates always re-set all BIOS settings to defaults, including allowing future BIOS updates via Windows Update (UEFI Capsule Update setting). I want to control when/if BIOS is updated, and I will do it via the F12 menu. 

Ron

  Forum Member since 2004
  I am not a Dell employee

View solution in original post

3 Argentum
355

Fixed! The gigabit switch, installed between the Fios Extender and the PC, tricks the Extender to stay on continuously.

Thanks again for all your help, @RoHe !

View solution in original post

Replies (37)
8 Platinum
759

The Windows option "Fast Startup" is nice, but it tends to also INCREASE shut-down time. However, 1-2 minutes seems incorrect. 

If your machine boots from a C-drive that is a NVMe-SSD, you do not really need this option Enabled anyway.

 


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
752

Thank you very much, Tesla1856!

Yes, this desktop is set for Fast Startup and it is an SSD C drive (not sure of the exact type). But no startup setting changes were made in a couple of years or more, and this slow shutdown is a very recent change.

Just in case it helps, I also noticed in the past few days a slower finding of the internet after booting or when waking from sleep. (Wired LAN connection via the same type of FIOS router as before, at a new location in the same neighborhood.) FIOS is otherwise working well, including a fast wi-fi connection. 

The desktop is functioning as before, except for the slow shutdown and the slower finding of the internet.

Thank you again,

JF

 

 

 

10 Diamond
748

You could try this:

  1. At desktop, open a CMD prompt window, Run as administrator

  2. At the prompt, type in: DISM.exe /Online /Cleanup-image /Restorehealth and press Enter, Be sure to include a space in front of each / and note any error messages when that's done.

  3. Assuming no "unfixed" errors in #2, at the CMD prompt, type in: sfc /scannow and press Enter. Be sure to include a space in front of the / and note any errors when that's done.

  4. Assuming no "unfixed" errors in #3, reboot and see if that helps...

 

Ron

  Forum Member since 2004
  I am not a Dell employee

743


@Josephus Flavius wrote:

 

1. it is an SSD C drive , Wired LAN connection 

2. Fast Startup , or when waking from Sleep. 

3. I also noticed in the past few days a slower finding of the internet after booting (Wired LAN connection via the same type of FIOS router as before, at a new location in the same neighborhood.) FIOS is otherwise working well, including a fast wi-fi connection. 

 


1. Both nice ... good work.

2. Maybe try disabling both of those and also Hibernation. Sometimes, you have to enter a power config command to get it to start obeying new configs.

3. Separate issue. Can be looked-at/worked-on later. There is an ipconfig command to reset it. Check your Reliability History Report.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
730

Thanks, Ron. Came without any unfixed errors.

Shutdown is now 53 seconds. Better, but still seems longer than it used to be only a short while ago -- like 5-10 days ago.

Glad your advice helped, like it did several times in the past.

Many thanks,

JF

708


@Josephus Flavius wrote:

Shutdown is now 53 seconds. Better, but still seems longer 

That's because you have Fast-Startup on, and it has to write the the current Hibernation file. (Which is not really needed with a nice/fast NVMe-SSD Boot Drive).

Next, the kernel configures core system functions, enumerates the devices attached to the computer, and loads drivers for them. In contrast, a Fast Startup simply loads the hibernation file (Hiberfil. sys) into memory. 

https://docs.microsoft.com/en-us/windows-hardware/drivers/kernel/distinguishing-fast-startup-from-wa...


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
700

I'm sure you're correct...

Could you please remind me where to change boot settings for the Fast-Startup? I looked for them via both F2 and F12 menus but didn't see anything indicating I have Fast-Startup on, though I believe I do.

Thank you again!

JF

676

Just to clarify, I have Windows 10 Pro, Ver 21H2, OS build 19044.1889

I know the place of setting Fast Startup is different, depending on the version, and I'm still unable to find it.

Thank you again,

JF

 

10 Diamond
669

Fast Startup is a Windows setting not a BIOS setting:

  1. Boot to desktop
  2. Open: Windows Power & Sleep screen
  3. Click: Additional power settings
  4. Click: Change what power buttons do
  5. Click: Change settings that are currently unavailable
  6. UNcheck: Turn on fast startup
  7. Click: Save changes
  8. Do a full shutdown, not just a restart
  9. Time the next shutdown, and next boot time after that shutdown to see which is more acceptable for you, faster shutdowns or longer boot times

BTW: are you leaving any apps open (possibly in background) now that are slowing the shutdowns?

FWIW: I'll time shutdown on my XPS 8930 (Win 10 Pro, 21H2) with Fast Startup enabled later today, assuming I remember...!

Ron

  Forum Member since 2004
  I am not a Dell employee

Latest Solutions
Top Contributor