XPS Desktops

Last reply by 10-07-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
224

XPS 8940, BIOS 2.9.0 update failure

XPS 8940

Problem and resolution (not totally solved): recent update from firmware v2.8.0 (2Aug22) to 2.9.0 (6Sep22) initially seemed to work. Installation flagged as Successful in Windows Update (win11 Home), but v2.8.0 indicated as current ver. in msinfo32. Device Manager indicated driver Event ID 412 vs. Event ID 410 (typical), indicating a reboot was needed. Since I had rebooted multiple times over several weeks, rebooting was not the issue. In working to resolve I found the DELL logo missing on POST and an inability to enter bios setup by any of the traditional methods. I resorted to this forum and others for clues, but found few. The closest instance (this forum) involved one where the monitor HDMI connection was faulty. That was not my problem. But .. an earlier problem had me switch from the NVIDIA GPU to the onboard Intel HDMI. So, I tried switching video outputs. Switching back to the NVIDIA GPU resolved the problem. I was now able to see the DELL boot logo on POST. So, after backing critical files to NAS, I retried the v2.9.0 update directly from the downloaded .exe (vs. Support Assistant). I was now once again able to see the firmware update and installation progress bars and get confirmation of a successful bios update. Why I could not achieve this with the onboard graphics remains a mystery.

Replies (4)
8 Platinum
217

Glad you got it resolved.

But to maybe clear some confusion ... any references to BIOS/Firmware updates in Windows-Update is referring to the copy it downloaded (and tried to install) from Windows-Update itself.

In the XPS-8940 BIOS, if you Disable "UEFI Capsule Updates" ... that should prevent or limited that from happening ... and you can just get them from Dell directly.

As for the video-card thing ... if you have a discrete Nvidia card ... I would recommend connecting the monitor(s) to it directly always. 

 


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
155

Thanks for the reply!

The backstory on why I wasn't using the NVIDIA is this: so far, it appears than whenever I'm using the NVIDIA graphics card I'm subject to random freezing of my screen, mouse, and keyboard. The is no input response and the only recourse is a cold restart. I have (so far) never seen this behavior using the onboard graphics. Because I can be in the middle of something critical, I've been loathe to use the NVIDIA.

Last week I updated the NVIDIA driver and GeForce Experience (no alert from Windows or NVIDIA of the available update, BTW), but still had one "event" before reverting to the onboard graphics. I have tried all the trouble shooting and remedies I can think of or find hints to on the forums. The Event View logs gives no indication of a precursor. The only possibility I haven't followed yet is a marginal power supply. I have a (near) twin system with Win 11 Pro and no GPU card (instead, the same Intel onboard graphics as its sister). I've never had that system freeze.

149


@ORflyboy wrote:

The only possibility I haven't followed yet is a marginal power supply.


Welcome to the "Lock Up Club"

I too thought it might have been the PSU. Can't be the A/C line as the XPS is on a UPS that is a transformer PFC type, so it handles and transient.

Next I asked a few which PSU they have. I've got a LiteOn, but other ones were shipped with the 8940, however others have the problem on other PSU's, so I have ruled that out.

I've had Motherboards and Nvidia cards replaced, so I'd rule them out.

No one, not one, has figured out why and has a sure fire fix.

If you use the Intel HD adapter that it will not fail. Don't even need to remove the Nvidia card,  just disable it in Device Manager.

It would be 'interesting' if you moved the Nvidia card to the other XPS though. However, if it still failed it might not be real proof, but if it didn't, it would be proof the problem is not, or not only the Nvidia card.

A few of us on BIOS V2.9.0 have had long runs without a lock up, but it still happens. Best I got was 31 days, and then 2 in 3 days. Unknown why and it is purely random. I was under 22H1 if W11 and had 8 days after those 2, but I installed 2H22 of W11. It had a problem with the Nvidia card (resolved itself though) and then 2 days later the latest Nvidia Drivers I was loading locked up during completion of the driver/ Since then, 5 days without a lock up.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

3 Argentum
111

Press Ctrl key + Esc key until the BIOS Recovery screen appears. Release the Ctrl key + Esc key. In the BIOS Recovery screen, choose Reset NVRAM and press Enter.

Latest Solutions
Top Contributor