XPS Desktops

Last reply by 06-26-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS 8940, Windows 11, NVMe firmware error

Hi all,

In the Device Manager under "Firmware" there is an error with NVMe firmware 36.30.80.29.

Properties says "This device cannot start. (Code 10)" and that the firmware update resource is invalid or corrupt.".

I can't find any problems using the computer. I have already tried uninstalling and reinstalling the driver but the error remains. Dell SupportAssist finds no problems.

Does anyone have a similar error or a solution?

Thanks!

devicemanager.jpg

Replies (28)
7 Gold

This not a driver issue but a firmware update issue. On the support page here, you will find a number of firmware updates depending on the make and model of your NVMe SSD.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with GIGABYTE B560M DS3H AC budget build with an i3 10100
Real work on a Latitude E5430

Thanks @JOcean for your reply but there is no available firmware for my service tag.

Device Manager indicates Dell's Samsung PM9A1 and my SanDisk SDSSDH3 2T00 which is up to date.

When ignoring service tag there is a firmware for Samsung PM9A1 (v3630.8229 Dec 2021) but it can't be installed. There would be no drive.

I Had the same problem.  The issue was that the driver was corrupted.  The below link fixed it for me.

Samsung PM9A1 PCIe Gen3 NVMe Solid State Drive Firmware Update | Driver Details | Dell US

 

 

Unfortunately, this driver is already installed. A new installation does not help here.

2 Bronze
2 Bronze

Hello and Unbelievable. I have the exact same issue! Just happened last week on my 3 month old Dell XPS 8940, been looking for someone else who has this issue since. I have no clue how to fix this. Same deal, all works well but it is flagged identically to yours in device manager. Please help

I actually found the firmware update on https://www.catalog.update.microsoft.com/Search.aspx?q=dell%20firmware%20update

it is under the DELL Inc. firmware 36.30.80.29 listing, I have yet to install the driverpackage *.cab

2 Iron

I have had the same problem in the past after updating bios. Solution for me was to power off the machine and take the battery away. Afterwards the error has disappeared.

@uwe-dembski Do you mean the bios mainboard battery?

@DELLSPACER The installation fails for me.

2 Bronze
2 Bronze

I'm also seeing this error, though I may have a different SSD than you as the NVMe Firmware entry on my system is v61.52.00.12. That is the latest version available from Dell for the WDC SN810 SSD, released on 4/19/22.  

Top Contributor
Latest Solutions