XPS Desktops

Last reply by 07-20-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1043

XPS 8940, does yours freeze randomly?

Please list your XPS 8940 configuration if you are experiencing random freezes (lock ups). Dell replaced the motherboard but it's still doing it.

Mine =

Windows 11 Home
11th Gen Intel Core i7- 11700 processor(8-Core, 16M Cache, 2.5GHz to 4.9GHz)
32GB memory (2x16GB)

Nvidia GeForce RTX 3060 Ti 8GB GDDR6 (LHR)
1TB M.2 PCIe SSD + 1TB SATA 7200 RPM HDD
BDRE Drive (Reads and Writes t o Blu-Ray disks
Killer Wi-Fi 6 AX1650i (2x 2) 802.11ax Wireless and Bluetooth 5.1
500W power supply

Replies (26)
2 Bronze
2 Bronze
644

Hello, have you try to disbale fast startup ?

2 Bronze
2 Bronze
640

FWIW my 8940 was delivered in October 2020 with the motherboard 0KV3RP and has never experienced a lockup. It has had various NVidia drivers and every BIOS update with only one minor problem (posted about elsewhere on this board). So maybe the root cause of the freezing relates to changes made between the first and subsequent issues of the board.

Also FWIW I came across 200+ posts on a forum of a competing but broadly comparable product describing what seems to be an identical freezing problem starting in April 2021. The manufacturer issued a patch exactly one year later. From skimming through their posts it seems the cause of the problem was the erroneous installation of an NVidia driver for a non-present component - NVidia USB 3.10 Extensible Host Controller. This item also shows up in Device Manager  on my machine. I've no idea whether it is physically present or not; either way it has never been an issue.

bob

 

2 Jasper
2 Jasper
583

There are multiple threads regarding this topic and most seem to point to an issue with the BIOS.  Any BIOS greater than 2.3.0 seems to have random lockups (freezes).  My system is similar to yours (suenrod) with the exception that I'm still on Windows 10, RTX 2060 and no Blu-Ray drive.  My motherboard is 0K3CM7.  It also appears to primarily be those machines with NVidia GPUs as well.

I have tried multiple versions of the BIOS and have always ended going back to v2.3.0, since that is the only one that doesn't exhibit the freezing.

Now the additional part that (xrms3) mentions that a competing vendor had some similar issues and related to an issue with a NVidia driver seems to be new and I hope DELL is taking a serious look at that.  That same driver also shows up in my system along with the Intel version of the same.  Again, don't know if that component is present or "required", but could help DELL figure this issue out.  Here is what I have for USB controllers.

bdtnr_0-1656691423265.png

It might be an interesting experiment to remove (uninstall) that NVidia USB controller and try the latest BIOS and see what happens.  

579

@bdtnr @xrms3 @suenrod 

First, I too have a similar configuration... smaller SSD, standard CD, less RAM, and RTX2060.

The possible motherboards in an 8940:

KV3RP Foxconn 02012PQ00-600-G, Released July 9, 2020
2W4W1 Foxconn 02012TA00-600-G, Released December 1, 2020, Brazil only
F1H92 Foxconn 02012YJ00-600-G, Released March 15, 2021, Brazil only
427JK Foxconn 02012VY00-600-G, Released March 15, 2021
K3CM7 Foxconn ??, Released July 14, 2021

I have the 427JK. I was sent a KV3RP, but when installed the XPS wouldn't even power up. They insist I try the K3CM7 and I told them if fails the same way for others. Still want me to try it.

I too have the USB devices:

u.jpg

I am SURE they can be used. They are for the MONITOR probably to go along with the Video drive. My Dell S3221SQ does have USB ports on it. Suspect it is loaded on all Nvidia drivers.

Let us also be clear. If the was any other h/w or s/w causing the problem, going back to the BIOS V2.3.0 with not other changes SHOULD not solve the problem. Note that Linux users have the same problem, so you can surely rule out Window 10/11 as well.

The Freezing started with the release of V2.4.0 in late Jan. 2022. So far, owners of  XPS''s with all the US motherboards have reported the SAME problem. A freeze with no indication why and only way to recover is to power off and on.

This more of a lock-up as the OS stops, even the clock. Whatever is causing the fail doesn't even get a chance to write to the event log or create a dump.

I'd be interesting in a LINK to a competing product with this problem though, please post it.

 

Thanks,

Irv S.

2 Bronze
2 Bronze
574

@ispalten- here is the link. I'd be surprised if the 8940 problem is identical but you never know!

https://forums.lenovo.com/t5/Gaming-Desktops/Lenovo-Legion-T5-28IMB05-constantly-gets-severe-freezes...

bob

 

566

@xrms3 

Bob, thanks for the link. That is one large one, 21 pages...

Got to read it, a lot of differing responses...

Yes, the problem appears to be the same result.

Page one states removed the Nvidia GeForce Experience, () and others that say it worked, then, one came back it didn't ().

Then it got to be the Nvidia Audio driver (), another said the CPU was the problem (). Then on it was claimed to be drivers again.

That followed on that the PhyX driver was part of the problem and you had install Lenovo drivers only...

Some messages about changing CPU working or not (

Then (

 

Not sure what is going on, but from the official Readme I see this,

================

Downloading file
1. Unzip the tool file,you will see three files.
such as:devcon,Repair bsod instruction,Readme
2. Run the Repair bsod instruction file as administrator.
3. Check the Device Manager>> Universal Serial Bus controllers >>NVIDA USB 3.10 eXtensible Host Controller. -1.1(Microsoft)
4. If successful, the NVIDA USB 3.10 eXtensible Host Controller device will have a downward arrow in front of it.
5.Finally, you need to restart the OS for it to take effect.

================

That seems to do the same as DISABLING the device with Device Manager which was suggested way before and didn't work, at least for everyone.

No matter what, IF it is the driver, ANY Nvidia Driver, then why did BIOS V2.3.0 work (for most of us at least) and V2.4.0 start the problem?

Think about that, how would you explain that not being the cause vs. the Nvidia drivers?

How about users running Linux are seeing the same problem?

Smells of a h/w problem, and BIOS is considered to me at least part of the h/w.

Of course, with it happening on all 3 US Motherboards, it isn't the chipsets that are the problem.

I think the REAL problem is that I don't think Dell has been able to reproduce the problem? I'm also sure the problem only exists with Nvidia cards in the XPS and being the active display card in use.

As for Lenovo, the problem at one point was pinned on the Nvidia released drivers, not the tested released Lenovo drivers. Well, on the XPS any and all drivers, and that includes the Studio and Game Ready (Dell only issues Game Ready drivers) have proven to fail, so it doesn't seem to matter which supplier you use.

Another data point to consider. Besides BIOS V2.4.0 introducing the problem, subsequent BIOS releases have changed the frequency of the lock-ups. Each release appears to have it happen less often than the one before. Therefore one could infer Dell is making some changes in hopes of fixing the problem and they just have not completely corrected the code.

 

Thanks,

Irv S.

2 Bronze
2 Bronze
528

Update,

Since July 30 when "Intel Corporation - Extension - 18.7.1.1003" installed, it has not crashed. 2 days and nights and counting. I was having a few freezes a day before.

I'm fully updated. Even the bios is 2.7.

Fingers crossed!!

523

Sue, how did you determine this was installed (I assume June 30th)?

That is my Google search is right is a 6 month old file that should have been installed in Jan.?

u.jpg

I can't even locate it in Device Manager it seems either (at least not clearly marked like you posted it)?

I only had one file (PowerShell v7.2.5 (x64)) installed by MS Update on the 29th, and before that it was 6/25, nothing on 6/30?

The Intel Driver and Support Assist (https://www.intel.com/content/www/us/en/support/intel-driver-support-assistant.html) shows that I am up to date.

If that is correct, are you sure you actually have a SCSI drive? A SCSI controller too? Most of the drives will be SATA, not SCSI (different controller and cables).

Now, concerning BIOS V2.7.0, I can go a week without the freeze... better than any BIOS 2.4.0 and after, but it still happens, every 5 days or later to me.

What BIOS were you on before? V2.4.0? Did you try V2.3.0?

Thanks,

Irv S.

491

Irv,

The update shows in "update history" under drivers.

suenrod_1-1656886997879.png

 

My XPS8940 uses SATA. I don't know why a SCSI driver affected anything but I'm now 3 days and nights without freezes since it installed. I was having a minimum of 3 per day prior.

I tried running the older BIOS (2.3, I think). It helped a lot but I would still freeze a few times a week.

-Rod

Latest Solutions
Top Contributor