XPS Desktops

Last reply by 10-11-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1607

XPS 8940 lock up issue, happens with every Bios > 2.3.0

XPS 8940

Greetings,

im having the same issue as many others in the forum. Once i updated my Bios to anything > 2.3.0 it locks up while idle.
This happens i.E. when the PC is on over night while nothing GPU or CPU exhaustive is running. (i.E. no games just browser etc.)

The weird thing is the fans start spinning like crazy and the keyboard is responsive but the screen is frozen and i have no choice but to power it down and reboot.

In the newest BIOS 2.9.0 the issue was even worse than that. At least once every 24 hours the PC would simply lock.
If something loadheavy like a game is running it wont lock up.

I already disabled the Windows 10 Quick Boot. Checked in Bios that the start is loading ALL Drivers etc. instead of the minimal load and checked via GPU and CPU Temp the temp. Furthermore i made serveral system checks which also lead to nothing.

At one point i even replaced the whole ram to make sure this isnt the issue and checked the Memory and the GPU for errors. => None occured.

Temperature is NOT the issue here, as i had previously many Alienware and Dell PCs and Laptops.

As others pointed out the issue seems to lie within the BIOS changes from 2.3.0 to 2.4.0 the NVIDIA GPU and the low system load.

Changing it to 2.3.0 effectivly prevented the locking for 2 consecutive days now. Sad thing i had to stop the service that updates windows to downgrade properly as the windows updates will immediatly upgrade to 2.8.0 on reboot.

In general this is a fairly known issue and im really wondering how this isnt fixed in 2.9.0 but became worse.

Can anyone @ Dell check the issue here? Either the processor locks up totally due to an issue with some cstates or something else. But as far as i see this the issue isnt solved currently: 08.09.2022

Replies (39)
2 Bronze
2 Bronze
805

Okay i will now try the solution someone has posted on the forums:
Under the bluetooth devices there is a particular NVIDIA device.
As @bdtnr pointed out in the thread https://www.dell.com/community/XPS-Desktops/XPS-8940-does-yours-freeze-randomly/td-p/8226583 this device shouldnt be there and could interfere with the system.

I have now deinstalled and removed the device. Upgraded to 2.9.0.
Well see how that works out.

ark628_0-1662634864897.png

 

4 Beryllium
788

Since this is the first time you've posted about this problem, I'd like to get some more info and add my comments to this.

  • I have had this problem since BIOS V2.4.0, and it continues with each succeeding BIOS release. While going back to V2.3.0 did at one time guarantee stability, at some point it no longer did, probably due to a change in the Intel Management Engine component of the BIOS that can not be back-leveled it seems.
  • Although you didn't give the spec's of your XPS (CPU, PSU wattage, Nvidia Card model, RAM, etc.) you do seem to suffer a slightly different scenario, only when idle and fans speed up. It seems that although others have the same idle state lock up, they do not have fans speeding up and also have it happen randomly when using the PC, opening or closing windows or icons, typing, etc.
  • The references page is showing USB devices, not Bluetooth, just mentioning for clarification for others.
  • That user referenced mentions "200+ posts on a forum of a competing but broadly comparable product describing what seems to be an identical freezing problem starting in April 2021" which is well before BIOS V2.4.0 came out in Jan. 2022, well after the users references (which I can discover either).
  • One reason it isn't fixed, Dell has NOT been able to recreate the problems. Not everyone with an Nvidia card on an 8940 has this problem. Do you know how to recreate it? Are you 100% sure that some change or add program or h/w is not contributing to the issue?
  • Are you willing to work with Support by exchanging your XPS as is so they can recreate your 'idle' state failure?
  • By the way, at this point in time I have been on V2.9.0 for 24 days without a failure, and I did FAIL on it on 8/15 before. It is totally unreliable as to when one will fail, and each BIOS since V2.4.0 has been like that, each though taking longer between fails.
  • Although I have all the Nvidia USB controller s/w enabled, I do use the USB 3.0 and 3.1 controllers via my Monitor connected to the NVidia card via an HDMI cable. I don't use the Type-C on but it is still enabled. Considering the date of the reference in 2021, well before my XPS was delivered, I consider that all a non-issue.
  • Many suggestions have been made as to the cause and 'fix' here. None has panned out so far.

Let us know how it works for you.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

4 Beryllium
788


@ark628 wrote:


Changing it to 2.3.0 effectivly prevented the locking for 2 consecutive days now. Sad thing i had to stop the service that updates windows to downgrade properly as the windows updates will immediatly upgrade to 2.8.0 on reboot.

 No,, you don't need to do that. Re-enable Windows Update, and then OPEN the BIOS when booting (F2) and go to the Security and the UEFI Capsule Firmware Updates setting and DISABLE it.

That should stop all CAPSULE UPDATES from being installed. Yes, so say it does anyway, but I'm not 100% sure of that? The BIOS System Log doesn't match what Windows Update states when it installs the new BIOS. Suspect this is due to how Windows Update Drivers are installed via Windows and using the Registry to do that, that or when it does go to install it discovers you either have denied it via BIOS setting or in some case, it is trying to install what you already have and doesn't do it.

 

 


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

732

So far i have enabled Updates again and reupdated to 2.9.0
Afterwards i deleted said driver.
Sorry for the missing info on the system i thought that while
selecting the servicetag it would mention the configuration of the system aswell.

The PSU is the Dell one that got shipped (500 Watt if im correct)
Only thing i have exchanged is the RAM for Crosair RAM 3200 Mhz 16 GB x 2
The NVIDIA Card is a 3060 GTX driver game ready 31.0.15.1640
CPU is the i9-11900K with 3,5 GHz driver 10.0.19041.1865
drive is M2 NVMe PM9A1 Samsung 1 TB driver 10.0.19041.1865
Keyboard Razer Black Widow
Mouse Razer 8k Viper
Headset Razer Kraken V3
Monitor Dell 25 Gaming Monitor Dell S2522HG
The keyboard is mounted on the Monitors USB.

I also sometimes experienced(not recently) an issue where the keyboard doesnt work properly.
i.E. you pressed F then the keyboard would write an F and after a Second continue to write Fs as if
you hadnt released the key. This might have been due to the daisy chain (keyboard is connected via monitor)
and the drivers that where installed.

For the question i honestly dont understand why at one point Dell dindt ask a user to
exchange his PC for a working one while they have one machine with the issue to work on.
At this point we wouldve done something similar to tackle the issue.
In general if it would be due to a programm failing there should be
some logs in windows i.E. crashlogs dumps etc. Since it is only happening when nothing
load heavy runs on the GPU or CPU i assumed the powerstates and c states where contributing to the issue.
Also a drop in the Power of the CPU i also doubt it is. Otherwise it shouldnt happen when there
is no load. Quite the opposite.

For some people changing the power mode and the quick start worked not for me.
Since the NVIDIA driver were always in focus of this incidents it seems plausible that the
driver of eXtensible Host Controller can be part of the issue. wondering why this is installed anyways?


While i understand that unreproducible issues are hard to tackle at some point i think
a gigant like dell should have some ways to force the issue getting solved.
Also since they know exactly what changed from 2.3.0 to higher releases i would guess its
easier to find a solution. Also it is super weird that there is zero in the windows logs.

From the programms ive installed all are also on my laptop including nothing to obscure like
Steam Discord Python. Nothing out of the usual.

i now returned to 2.9.0 and deleted that nvidia 3.10 something device
gone to bios activated all C states again activated the Power Mode for the CPU again.
PC ran the whole night with no load and didnt hang which is a good sign.
Funny is tough that the device manager shows under firmware now 2.8.0
altough the dell update and bios say its 2.9.0 this might be because 2.8.0 was the
latest update in the windows updates as 2.9.0 hasnt landed there yet.

Also i wanted to note that the fans ONLY are loud when the machine locks up.
You can immediatly hear this. I also experienced some freezes while sitting in discord.
The screen freezes first fans kick high and audio starts to lag and then everything is frozen.
This takes around 5 seconds.

2.3.0 has decreased that issue. Now i am trying to check if 2.9.0 has no issues IF the driver for the
NVIDIA USB 3.10 eXtensible Host Controller is the culprit. Since yet i have one night without lockups.
Which is more than i previously got using 2.9.0. or 2.8.0. promising.

 

Thank you for the explanation how to properly delay the FW update by the PC.
I think i will continue this experiment with 2.9.0 and the deleted driver and if this works the Driver is part of the issue.

I will keep you updated how it works. Letting the PC run this week to see if the lockups are away.

Best Regards,

Vincent

 

 

717

Hi Vincent,

First, I do NOT work for Dell, and I am a user like you, who hit the problem in Jan. with the release of BIOS V2.4.0. I will always take a BIOS update as there are security fixes and one can't be too careful.

Comments in order of your post:

  • If your XPS is the S.E., you do have the 500w PSU, although there have been reports of the same lock up on Std. XPS's with the 350w PSU. I do not think it is a 'wattage' problem but spikes or noise could play into it. My XPS is on a UPS so the input voltage is constant and pure (PFC style UPS).
  • I too replaced my single Dell 16GB DIMM that was Single Rank with 2x16GB Dual Rank DIMMs. Theory at one point here that it was the Single Rank DIMM that caused the problem, nope, got it on the DUAL rank DIMM as well.
  • I'm using a Logitech mouse and keyboard, wireless, via dongle connected to front USB port on the XPS. At one point I thought the USB port could be a problem so I switched over to the 'cheap' mouse and keyboard that came with the XPS and connected them in the back. Still had the lock up, so if nothing else, it wasn't the Logitech devices.
  • I have not experienced the 'stuck key' nor any other keyboard problems.
  • I do have a Web Cam that connects to the USB port on the monitor which is connected via HDMI to the Nvidia Card. I have had lock ups with Zoom at least once. I do not think it is the USB drivers.
  • Dell DID ask, at least I was. Problem was the 'requirements'. First I would not be guaranteed a NEW XPS, only one that was configured at least as well as my purchase, that is same amount of RAM or more, same Nvidia card or better, same disks or better, etc. No guarantee it would be new. Could be a later 8950 model. However, I could NOT remove ANYTHING, app customization and programs are to be left on the unit. I didn't want to give up my personal data so I declined, and as I understand it, many others did too. I read that to mean Dell has not reproduced the problem. Understandable as not everyone with an Nvidia card has the problem.
  • No Event Viewer/logs because the OS stopped working, i.e. the lock up. Could have happened before the OS got the error or as it was trying to post the error. A few people have gotten errors, and in the case of one Linux user and error pointing to the Video card, but when some do get an error it is for BSOD's, not a lock up (some call it a freeze, which to me means a momentary loss of use, while a lock up is total loss requiring a reboot).
  • There have been many theories put forward, but in all cases so far, they proved futile. Reason being, no one knows how to produce the fail, and as BIOS versions were released, time to failure took longer. Where V2.4.0 was a day or less, and sometimes multiple times a day, V2.5.1 could last a week or a little less. V2.9.0 I had one in 4 days, and now have not had one since the last one on 8/15. Yes, things have changed, a program here or there added or removed. Windows Update doing its thing, and some programs 'calling home' and updating in the background (like McAfee for instance).
  • The USB drive is installed with the Nvidia driver. Nvidia does some loading of items you may not need. Doesn't mean it is the cause (extra loaded stuff). People have deleted the Nvidia Control Panel and GEForce Experience too, but I kept them and have them on now. Paranoid, get this program, https://www.techpowerup.com/download/techpowerup-nvcleanstall/ as it will remove a lot of stuff Nvidia install for you. No, I've not tried it. Reason being when I went back from BIOS V2.4.0 to V2.3.0 with no other changes I never had the fail, so therefore it was not due to Nvidia, at least alone. I also wouldn't expect something that I do not use to cause a problem. It has to be something loaded in RAM and running or h/w that produced an interrupt that would cause the problem. Even though you have the Nvidia card you still have the Intel HD750 video card loaded. Same here, it is inactive, just like the USB driver as nothing is attached to it. I assume you meant the Type-C controller though., As I mentioned, that referenced mention of that happened well before BIOS V2.4.0 came out and could have been a true problem with the Nvidis driver at that time, since fixed.
  • Yes, DM will still show it. Mine shows 2.7.0. Why, because it is in your Driver Store. There is a program to see all these on the drives, https://github.com/lostindark/DriverStoreExplorer/releases and it shows for me I have V2.4.0, 2.7.0, and 2.8.0 as well as a Dell supplied Nvidia one. The only way to tell for sure is to run MSINFO32.EXE or go into the BIOS on boot (F2) and check.
  • Your fan experience is NOT the norm for the Lock up, that is all I can say, and may be indicative of a different error.
  • Like I said, V2.9.0 is unpredictable. 4 days before a lock up and now since then it has not happened? Other versions after V2.4.0 had similar variances, just not as long.
  • When going backward in BIOS, part of the old one does not install, the Intel Management engine. I suspect that is why going back to V2.3.0 doesn't solve the problem for me now. I know another user went back to V2.2.0 which was stable for him and after a period of time it still locked up. Intel owns that code and supplies it to Dell I assume. Changes are made to that code, and a mismatch between the BIOS code and Intel code could cause a problem too. That could explain why going up vs. down in BIOS versions works better.
  • If you are interested in exchanging your XPS DM me (under the above conditions) and I'll pass that on to Dell but no guarantee they'd do it.

Oh, one last point. Some say that even with Capsule Update turned off in BIOS it still is installed. I've seen that too, but could not confirm it happened. You will see Windows Update state in the Driver Log for Updates it did install a Dell BIOS V0.2.x.0 but I don't think it did? Even Reliability Manager will show that. However, the process Windows Update uses for Drivers is to make it happen on the next reboot. Just like if you manually installed the update via Windows. In that case of a Window install you see the BOOT screen showing the loading of the BIOS. When Windows Update does it that does not happen. I suspect that is because WU just queues it up for install on the next boot, but when it gets run the BIOS setting for Capsule Update is checked and if off it doesn't happen. ONLY true way to know,, look at the System Log in the BIOS. 

Oh, I don't know what time frame is long enough to declare it fixed by doing 'X'? Time between failures is not a constant.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

703

Hi,

 

didnt assumed that you work for Dell but you seem very deep dived into this topic which is quite a good thing for me.

TBH i ignored the issue the longest time since it started shortly after my Master Thesis and i had no time and the lockups are only around once every few days at that time.

Im also unsure how many days it will take but tbh i dont care i will monitor it my PC is always ON anyways. I had no lockup since i removed that NVIDIA Driver mentioned above.
Games still work without any issue as before and i had the PC Idle for two nights without lockup (previously when on 2.9.0 i had it once every around 16 hours for a week)

I of course understand that finding the solution to an issue which is almost invisible is a delicate thing as i myself also work in support. Since im not too much into hardware stuff i cannot say it for sure but i think most of the symptoms have commons.

The thing with the fans was really something i noticed. So no doubt it will increase the fans rpm(5000+) when locking up.(shouldve done videos on that)

I think ill continuously monitor it and report in the forum wheather it locks up again or not.
Of course this cannot prove the absence of the issue because its the "Halteproblem" all over again...

It would be super interesting to see what causes it. Because as different as the lockouts and freezes are they have some things in common making me belief that lots of those cases have the same root cause.
Also makes sense that the system fails before being able to write a log. Guess im tooo used that the log will show everything until you kill the PC.

Since my warranty has run out and i had not very good experiences in some cases in the past with the Support at Dell i think i pass for the exchange of the PC. Of course it would be easy to backup everything and setup a new machine, but the conditions on it are a little to annoying (of course Support at dell does only communicate the conditions and they arent to blame for it.)

Im also not too much a fan of preventing updates especially when its something so based as a Bios update. Therefore i will search if i can find a solution for the issue i now call "XPS 8940 Lockup with fans spinning 5000+RPM when idle."

Currently it seems promising but it could also be just a cluster where the error doesnt occure by sheer luck.

 

Best Regards,

 

Vincent

2 Bronze
2 Bronze
655

Still had no lockup since the last post PC running 24/7.

This seem to work

2 Bronze
2 Bronze
637

Hi all, just a quick post to touch base. I'm having similar lockups. Nothing much different than others here: XPS 8940, 2 x 16 GB RAM, not sure of all my other specs I'll post asap. Sorry we just had our 2nd kid, 5 months old now barely starting to get a normal life back (sleep, etc) so pardon in advance I'll try my best to stay in the loop. I also had the occasional fan whoooshing like 100,000 RPM like a hairblower   But that hasn't happened for a while.  

The ONE thing I might be able to contribute:    I did take notes in an app of each crash instance I have (since 2 months roughly) and I just noticed that for each there is an entry in my event log. I don't know if that'll help. But it just seems to record the fact that I hard rebooted, so maybe not that useful ?  I'll try to post more detailed info tomorrow!

 

2 Bronze
2 Bronze
637

One pattern I've noticed: the lockups often happened when resuming from sleep after a short time idle (for example went to grab a coffee, back after maybe 10-20 minutes then freezes when waking things up. Nothing works, not even mouse / keyb. Another perhaps is when switching virtual desktops (using the Win + Left or Right arrow shortcut). PC isn't running so intensely, just a bunch of browser windows + a stock trading software (uses ressources but not that much). 

Latest Solutions
Top Contributor