XPS Desktops

Last reply by 10-13-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1421

XPS 8940, random freezing, potential fix?

Hi all. First time here, please be gentle.

Like many of you here, my XPS 8940 has been having random freezes while idling or under very basic use (in my case, Word, Excel, YouTubing on Firefox, or just simply File Explorer). Forced shutdown by pushing on the power button was needed.

I first noticed this issue back in March/April, and I tried the bios downgrade which made the issue less frequent. However, the issue slowly returned so I put in a ticket with Dell support. For reference, my system config is as follows:

Spoiler
OS Name Microsoft Windows 11 Home
Processor 11th Gen Intel(R) Core(TM) i7-11700 @ 2.50GHz, 2501 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date Dell Inc. 2.9.0, 13/07/2022
BaseBoard Product 0427JK
BaseBoard Version A00
Installed Physical Memory (RAM) 16.0 GB
NVMe OM3PDP3-AD NVMe KDI 512GB
NVIDIA GeForce RTX 3060 Ti

After some basic software updates and windows reinstalls, Dell progressively replaced my pc parts.

First it was the mobo and graphics - no dice. Then the SSD (with windows installed) - no dice again.

At this point, the freezes were almost daily (sometimes multiple times a day).

Dell Support suggested that I disable the NVIDIA drivers in device manager. This actually worked - no more freezes (which was tested for a week). Although this made gaming impossible. So not a real solution. Drivers enabled again, and the daily freezes returned.

Finally, Dell Support mentioned that their senior technician suspects it's the CPU(!?). So a new CPU was dispatched and installed last week (they also sent and replaced the graphics card as well, just in case).

And it's been 1 week without freezing. Don't want to jinx myself, but I do feel like my problem has been resolved - after 4 months of working with Dell Support.

Obviously YMMW. But maybe this is of interest to some.

Cheers.

Replies (25)
4 Beryllium
791


@Komar1 wrote:

Finally, Dell Support mentioned that their senior technician suspects it's the CPU(!?). So a new CPU was dispatched and installed last week (they also sent and replaced the graphics card as well, just in case).

OK, I don't want to totally dismiss your 'potential fix' but this one is really strange? Problems have been reported with i7, i9, and even K and F versions of the CPU. I can see one version, a single batch bad, but not all makes and models?

The Nvidia card, that too, many models with the problem.

Why would users that were running fine under BIOS V2.3.0 all of a sudden have a CPU problem when BIOS V2.4.0 was applied?

You didn't mention the BIOS version you  are on now, nor what you had before. If you are on V2.9.0, well, I'm on day 24 of no lock-ups after I did have one on V2.9.0. Unlike BIOS version 2.4.0, each BIOS after that appears to take longer between lock ups.

It is apparent that Dell is grappling with the problem that they have not recreated or debugged. Next thought is something they didn't do before... this one, I'd accept the Graphic card being replaced more the solution than the CPU, and even that one has not proven to fix it.

Good luck, hope it works for you though.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

781

As I mentioned in my config, the bios is 2.9.0 but before the CPU was replaced I had daily freezes.

Previously tried the 2.3.0 downgrade, which helped a bit but the problem returned. After I put in a support ticket, Dell support always made me update the bios as part of their troubleshooting.

I did think the graphics card was a problem, but it was already replaced once and that didn't help. The CPU solution was Dell's idea, and it was replaced under warranty for me.

775

Sorry, I couldn't see the ''Solution', it didn't open up before, had to be approved for viewing I guess?

You didn't state what BIOS you were on before the BIOS was updated (you did mention in the Config I can now see you are on it)?

Like I said, I'm on V2.9.0 and it seems OK, but I had locked up on it once before after only 4 days, over 3 weeks without a lock up. I do not consider if fixed though. Since in my case NO CHANGES to h/w were made, and if there was s/w changed, that might have something to do with it, it would have come in via Windows Update OR in the latest Nvidia Game Ready driver (V516.64 that was released on 8/9/2022) that I did Installed just before my last lock up on V2.9.0. Since I had the lock up using that driver, it is possible that it had nothing to do with why I have not locked up since.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

773

Before 2.9.0 I was on 2.8.0 and it still froze. Same with 2.7.0 and 2.6.0 and 2.5.1

Full disclosure though, my PC is on for about 16 hours a day so it may be more likely to experience a freeze. Funnily enough, it never froze while I was gaming. It was always something mundane like word or excel.

3 Silver
763

Don't know when you purchased your 8940, but mine was in July 2021.  I noticed that my 11th Gen i7 CPU is slightly different than yours.  Per my System Information:

11th Gen Intel(R) Core(TM) i7-11700 @ 2.50GHz, 2496 Mhz, 8 Core(s), 16 Logical Processor(s)

My GPU is an Nvidia RTX 2060 Super, 8GB,  the MoBo is 0K3CM7 / version A00, and am running BIOS 2.9.0  and Windows Home 10.  Note that I replaced rear stock fan with Noctua NF-A9 92mm fan, replaced stock CPU fan with a Vetroo 5,  and added Dell VRM heatsink, using HWinfo64 to monitor CPU/GPU

I have not had these lockup/freezing issues experienced by others here, albeit I do not run my PC for 16 continuous hours per day.   Typically, I may run it for 4 to 6 hour intervals. 

 

 

 

2 Bronze
2 Bronze
689

Dell 8940, 11th Gen i7--same GD thing here...basically ever since I've had the computer and updated to W11. Active window functions normally but everything in the background will be unresponsive, including the taskbar. Happening more than a dozen times/day and seems to be especially prevalent after updates. The only way I can 'unlock' the background is by opening task manager and then cancelling. Then it will mysteriously get less frequent for a while. Still can't find a solution and it's annoying asf. It's far more likely to lockup when sitting idle, but regularly happens when I'm working too..

687

I'm sure that is quite an annoyance. However, the problem is a little different to mine.

My screen would go black, and the pc would not respond to anything at all. The only way to proceed was to press the power button.

Having said that, after the cpu was replaced I have not run into this problem (2 weeks now).

664

@Komar1 

Your problem appears to have been the CPU, not the other main problems in a few threads here about those of us that have Nvidia Cards and after installing BIOS V..2.4.0 or later, the XPS will LOCK UP, that is NOTHING will work... Clock stops, mouse will not move. It can happen at any time, browsing, using a programs, typing into a program or browser, During when the screen saver is up it will stop. During Sleep and you can't wake the PC up... solid hard lock up some call a freeze. Any configuration of an XPS as long as it has an Nvidia card in it has been reported here in various threads. The only KNOWN work-around has been to go back to BIOS V2.3.0, but now, with the later BIOS versions installed, even that doesn't work.

The only recovery for those of us with the problem is to power off and back on. Event Viewer will show and error 41 (improper Windows Shutdown) when this happens. No other errors are reported or seen.

NOTE, that NOT ALL Nvidia XPS's have reported this problem, some obviously work fine. Even a report in here from a user that bought 2 'identical' XPS's and it happens only on one of them. Your problem as you reported it, is not the same as others. It is not a 'known' fix for others.

@Douluo 

You too have a completely different problem. Suspect either a corrupted install or damaged system files. Suggest you follow the steps here, https://www.howtogeek.com/222532/how-to-repair-corrupted-windows-system-files-with-the-sfc-and-dism-...  and you might even need to do a System Repair or clean re-install (will lose all your data). Don't want to do more than SFC and DISM and found no errors, if still under warranty, contact Dell Support. Not under warranty, contact them and see how much they want, or you could open a NEW THREAD/SUBJECT here with a Subject that matches your problem, one that is more about what you problem is, like "8940, Background tasks unresponsive at times', and maybe someone who has or had the problem will see it. I did search the Community and I did not find anything like that though. I really think you've got a corrupted W11 install/upgrade. Your only way to fix this could be a CLEAN INSTALL (see https://www.tomshardware.com/how-to/clean-install-windows-11 for steps) but be aware, this is a complete WIPE of the C: drive. You will need to possibly find your programs and re-install them, and even some drivers you need from DELL. This is not a simple task to perform if you don't know how to restore the XPS to its prior state. All DELL installed apps (dell Update, Dell Support Assist; etc.) you will need to get and install again from the Support D/L page and maybe others as well.

Making a BACKUP will not usually help. Re-installing the complete back-up will put you right back where you were.

The reason I'd contact Dell before undertaking this restore/replace path.


===================================

I am a Dell TechExpert. I am not a Dell employee. I enjoy using my free time to help the community. If you find my posts useful, you can thank me by clicking on Kudos!

Thanks,

Irv S.

661

That is exactly the issue my pc had. My screen would go completely black. doesn't respond to anything. Had to shut down manually using the power button. Like I said before, bios 2.3.0 worked for a little while, but eventually the problem returned.

I doubt it was purely a CPU issue, since as I mentioned that disabling the NVIDIA drivers would temporarily solve the problem. I used the pc for a whole week with the NVIDIA drivers disabled, and there was not a single freeze, but when I re-enabled it again it returned to a daily freeze.

Latest Solutions
Top Contributor