XPS Desktops

Last reply by 07-06-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
580

XPS 8940, replacement motherboard, slow boot

A Dell service tech just replaced my XPS 8940 motherboard today.

I upgraded all of the drivers.

Boot time has increased from ~15 seconds to ~1 minute.

I'm figuring it's a bios setting but I don't know.

He did change the hard drive bios setting from ACHI to RAID. I'm not using RAID. When on ACHI the boot fails.

Last BIOS time is 6.1 seconds.

Any suggestions?

Solution (1)

Accepted Solutions
301

I thought it should be AHCI since I didn't order it with RAID but I think I found the problem.

SATA 2 & 3 were enabled in bios but they are not installed. I think it was having to time out on those.

I couldn't get your bcdedit /deletevalue {current} safeboot command to work until I removed (current)

ooops I just realized it's {current} not (current)

It seemed to work though. Any reason I should re-run it as {current}?

 

Thanks.

View solution in original post

Replies (20)
8 Platinum
358

Does machine still pass ePSA Diagnostics ? (on F12 boot menu)

Have you tried removing all peripherals except for monitor, wired keyboard and wired mouse?

If so, sounds like you might need to report it and see about having them come back and repair your computer properly.

Not sure about 6-seconds, and RAID/AHCI is not a setting to be casually messing with, but ...

XPS-8940 is UEFI-based. Correct ... when booting from a SSD (especially a NVMe-SSD) the boot time should around 20 seconds (to usable desktop).

That's 10 seconds to login-in screen, and then another 10 seconds to finish loading Windows (and Processes) after password is entered.

 


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
339

I need to revise my complaint. Shutdown takes ~80 seconds and boot takes ~45 seconds.

I ran the bios diagnostics last night with zero errors. All peripherals are disconnected. The only things connected are the monitor, keyboard, and mouse.

188


@suenrod wrote:

I need to revise my complaint. Shutdown takes ~80 seconds and boot takes ~45 seconds.

I ran the bios diagnostics last night with zero errors. All peripherals are disconnected. The only things connected are the monitor, keyboard, and mouse.


When you have "Fast Startup" enabled, I've found that it increases Shut-Down time.

And since most of my machines are booting from NVMe-SSD, they boot way-fast on their own. In that case, I can leave Fast-Startup disabled ... boot is still as fast and shut-down time is not extended.

Not sure how you got into the whole RAID/AHCI procedures. Not something you should be changing unless you are willing to clean-install Windows.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
331

Another revision.

Booting from a power off condition is ~25 seconds.

Rebooting is ~100 seconds. It seems like the shutdown before the reboot is eating up the time.

Nothing but Windows is running.

 

328

it is probably Windows 10 getting more cumbersome trying to update.  you can try a clean install of Windows 10 on the same hdd (which will erase all data) or a test hdd, then disable auto update in group policy which may prevent OS from auto downloading and updating every time you boot it.  


309

I'm using W11 and did a full reinstall ~2 weeks ago.

10 Diamond
320

You have to reconfigure Windows to use AHCI before BIOS is changed from RAID to AHCI. So with BIOS set to RAID:

  1. Boot to desktop and open a Cmd prompt window, run as administrator

  2. Copy-paste this command, which will start Windows in Safe Mode the next time you reboot:
    bcdedit /set {current} safeboot minimal and press Enter

  3. Restart the computer and tap F2 to enter BIOS setup

  4. Change SATA operation mode from RAID to AHCI

  5. Save the change and exit Setup and Windows will automatically boot in Safe Mode

  6. Open a Cmd prompt window again, as in step #1

  7. Copy-paste this command, which will start Windows in Normal Mode the next time you reboot:
    bcdedit /deletevalue {current} safeboot and press Enter

  8. Reboot and Windows will automatically start with AHCI enabled

EDIT: You can't compare cold boot times with Restart boot times from inside Windows.  When you cold boot, Windows uses the Fast Startup file saved on the boot drive to load things quickly. When you Restart from inside Windows, the Fast Startup file isn't used so it takes longer to get back to the desktop.

A Restart from inside Windows assumes there's been a problem somewhere so it ignores all the settings etc saved in the Fast Startup file, and has to load and configure everything all over again.  Next time you shut down normally, Windows creates and saves a new Fast Startup file on the boot drive so the next cold boot will be fast.

Ron

   Forum Member since 2004
   I'm not a Dell employee

302

I thought it should be AHCI since I didn't order it with RAID but I think I found the problem.

SATA 2 & 3 were enabled in bios but they are not installed. I think it was having to time out on those.

I couldn't get your bcdedit /deletevalue {current} safeboot command to work until I removed (current)

ooops I just realized it's {current} not (current)

It seemed to work though. Any reason I should re-run it as {current}?

 

Thanks.

10 Diamond
306

If PC only boots now when BIOS is set to RAID, that suggests BIOS was set to RAID when you did the clean Win 11 install.

Some SSDs don't work well when BIOS is set to RAID so that could contribute to your performance issues.  So you may want to try the instructions posted above to configure Win 11 to use AHCI.

Did you install all the Win 11 hardware drivers for your XPS 8940?

A clean Windows install doesn't change what I said about comparing cold and Restart boot times.

BTW: you may actually need to disable Fast Startup (temporarily) if there's a Windows update pending that can only be installed when Fast Startup is disabled during a cold boot. In this situation, the PC will try several times during each cold boot to install the update but eventually gives up, and that finally allows the PC boot to desktop.

It will try again at every boot until that update gets installed. So try disabling Fast Startup and see if that helps. But, don't worry at boot times until after you re-enable Fast Startup again and do at least two full shutdowns and cold boots (not just Restarts).

Ron

   Forum Member since 2004
   I'm not a Dell employee

Latest Solutions
Top Contributor