XPS Desktops

Last reply by 10-17-2022 Unsolved
Start a Discussion
2 Jasper
2 Jasper
2007

XPS 8950, can't update Windows 11 to version 22H2

Hi All,

I have an XPS 8950 that is about 9 1/2 months old.  It is based on a 12th gen core-i9, the 12900K.  The system device is a stock 2 TB NVMe m.2 SSD (Dell original).  The only mod(s) that I made were to install 2 SATA III hard disks (10TB and 14TB).

The computer came with Win 10 Home, updated it to Win 10 Pro and eventually to Win 11 Pro.  No problems.

PC Health Check indicates that all of the hardware is Win 11 compatible.

I ran hardware diagnostics and there is no problem.

The following is the error that I get when I attempt to update the O/S to version 22H2 (Win 11)

KillerPooh_0-1664246123863.png

Note that this error message says "Your PC has hardware that isn't ready for this version of Windows"

I followed all the links and nowhere is there an explanation of why this isn't working.

I have contacted Dell Tech Support and didn't get anywhere (No big surprise .. )

Has anyone with an XPS 8950/Core-i9 12900K been able to successfully install version 22H2 of Win 11?  Does anyone have a work-around?

TIA ..

sdf

Replies (22)
5 Rhenium
1348

There do seem to be a few things Microsoft has put up Blocks to stop the upgrades until the situation can be worked out.

You may be able to override the situation by using the install media to do an upgrade directly from your desktop by selecting the setup file on the Install media.  But you may still encounter the situation causing the original message.

I have two systems which give no indication there is an upgrade available.  I am hoping that may change in the near future.  If not, I will be using the process to update mine.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
1327

I should have mentioned the following:

a) The following was seen in Windows Update on my system:

KillerPooh_0-1664288223581.png

so I could not update via the usual Windows Update method

b) I used Windows11InstallationAssistant.exe (downloaded directly from Microsoft) to attempt the update .. I used Windows11InstallationAssistant to update my non Dell, Windows 11 compliant laptop and it worked.

 

10 Diamond
1301

Could also mean that Microsoft is "doling" out this update so that (a) their servers don't get overloaded, (b) to limit the number affected systems if something serious should suddenly pop up as it's being rolled out.

My XPS 8930 from 2019 running Win 10 21H2 has finally been offered Win 11 via Windows Update in the past week. This is very first time I've gotten that offer since Win 11 was originally released.  Don't want Win 11, so never attempted to download/update manually, even if I could easily get it that way.

Just Microsoft being Microsoft...

Ron

   Forum Member since 2004
   I'm not a Dell employee

1290

I'm sure that M$ is "doling" out the updates, but the problems I saw was subsequent to using the Windows11InstallationAssisstant which bypasses the update servers.  The current 22H2 update doesn't like something on my hardware.  I don't know whether the problem is specific to my setup or is a problem with the 8950 12th gen core i9 computer set.

Hardware: XPS 8950, core-i9 12900K, 32 GB, 2 TB NVMe SSD (M.2), 10 TB SATA HDD, 14TB SATA HDD, NVidia 1660 TI graphics.

10 Diamond
1276

@KillerPooh - Is BIOS set to RAID or AHCI? Just don't change that setting...

Ron

   Forum Member since 2004
   I'm not a Dell employee

2 Bronze
2 Bronze
1126

Io sono riuscito con l’aiuto di Microsoft ad installare la versione 22h2, ma non funzionano molte applicazioni ( anche Support Assist non parte!).

1120

I gave this link to someone in another forum.  I can't check myself but if you get a chance, you might see if the link gives you any additional info.  Third Party link, so of course, be careful.

https://www.diskpart.com/windows-11/upgrade-to-windows-11-22h2-0001.html#:~:text=Select%20%22NI22H2%...

 

Blocked.jpg

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
3 Zinc
1091

I have an 8950 with a 12700K, 32GB of ram and I added a 1Tb Firecuda 530 as the system drive, I am using the stock WD SN810 in the other NVMe slot and replaced the HDD with a Samsung SATA SSD. I switched the BIOS to AHCI from RAID. (Don't just switch the setting in the BIOS, there is a process that MUST be followed.) I have a RTX 3060Ti video card and added a SoundBlaster-Z series sound card. I also replaced the cooler but kept the stock fans. I successfully upgraded to Win 11 22H2 using the win 11 install assistant. So it is weird that yours is saying there is a hardware issue. I would be surprised if it is due to you having the 12900K but it is possible. Have you tried disconnecting the aftermarket HDDs one at a time to see if you still get the error? Also as RoHe has alluded to, have you changed anything in the BIOS?

1082

Hello all,

 

The problem is solved .. I had a printer that used the Universal Print Class Driver and per recent information from MicroSoft, a safeguard hold was placed on any system that had either that kind of printer or had a printer that used a Microsoft IPP Class Driver.

On 28 Sept 2022 (very late in the day), Microsoft pushed an updated 22H2 Win 11 image that doesn't have the aforementioned problems.

The real problem here is that when a safeguard hold is placed on a system and you attempt to install or update Win 11 via the Windows11InstallationAssistant, you don't get an error message until many minutes past the start of the installation, and the error message is vague at best.

Nonetheless, thanks for all assistance rendered.

Latest Solutions
Top Contributor