XPS Desktops

Last reply by 02-07-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS One 2710, cpu id blank in cmos

XPS One 2710

The computer is a XPs 2710 all in one Core I5. The processor type fields  is  in the bios (a14) are blank. When trying to   install any version of windows it comes up with BSOD. Error reads Thread exception not handled  What failed: ACPi.systion . Running  the onboard diagnostics show no errors. Attempting to boot in safe mode gives me the same results. Replacing the hard drive with one with an installation created on a duplicate machine results, in  an  attempts to run a system repair but again I get BSOD with the same message. I've  installed  other OS such as Linix (Ubuntu) and Dos  All install and run with no issues. I have tried several ways to try to re-flash the bios but have had no success since I can not establish a windows environment. Trying to re-flash using a USB drive fails since it refuses to see it as a boot device. Does any one have any suggestions how to resolve this issue?

Replies (3)
5 Rhenium

@danfromgan Have you tried replacing the CMOS battery on the motherboard?


Hi Vic thanks for your suggestion. BUT....yep the first thing I tried. Apparently the cause of this type of error is usually a bad driver or incompatible hardware All diagnostics finds no errors or problems . Linux installs and runs as it should. Even found the wireless network card (and we know that is one contentious points for some systems), and why does it not recognize the processor and still runs programs without issues (except for windows)? I even swapped the processor with one in a duplicate machine that runs window fine. I'm totally baffled.    I'm hoping some one in the forum may have some idea causing this bizarre issue.

10 Diamond

@danfromgan  - What version of Windows was running on this PC? Some versions of the XPS 2710 motherboard can get bricked by installing Win 10. (Lots of threads about that problem.)

When you removed the old motherboard battery, did you then press/hold the PC's power button (PC unplugged from power adapter) for ~30 sec before installing the fresh battery?  If you didn't do it that way, try clearing BIOS again.

How did you make the USB bootable to run the BIOS flash? Have you tried using an empty 2 GB USB, formatted FAT32, all of which can be done using Rufus (free).

Once USB is formatted and bootable, copy the BIOS .exe file onto that stick. Then plug it into PC with power fully off. Power on and tap F12 to look for a USB boot option. Assuming it boots, type in the exact name of the BIOS file, including .exe at the prompt, and press Enter.  NOTE: It may not run if the file on USB is same version as is already installed...


  Forum Member since 2004
  I am not a Dell employee

Latest Solutions
Top Contributor