Last reply by 02-02-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

WD19 Dock Ethernet port not powering on

I have a Dell WD19 dock with an Ethernet port. I use this dock with my XPS 15, but for the last few weeks I've been unable to get the Ethernet connection to work. All the other functions of the dock work fine.

The Ethernet adapter does not show up in the operating system (Windows or Linux), and when I plug a cable into it, neither the port on the dock nor the port on the switch light up. It's as if the dock is just not turning on the port.

Things I've tried:

  • Disconnecting and reconnecting the cable
  • Swapping in a known-good cable
  • Trying a different port on the switch
  • Installing the Realtek Ethernet drivers for the dock manually
  • Updating the dock's firmware to the latest version

Any ideas?

Replies (5)
5 Rhenium

Are you sure it's the docking stations fault?

I'd guess when the LAN cable is removed, the device is configured to enable WI-FI, when docked, this does not see a LAN port connected so you now have Ethernet and Wi-Fi connections, meaning packets go out of one connection and try to come back in the other way.

Try first checking/manually disabling Wi-Fi.

I've never heard of any device that refuses to work with a dock, most, if not all applications dont know if the client is wired or wireless let alone be able to detect a dock.


I'm pretty sure it's the dock. I used it with the Ethernet in the past, and the wired connection would always appear when I docked the laptop. Also, it used to cause the link light on the network switch to turn on, even when no laptop was docked to it. Now, there's no link light.

As a test, I disabled Wi-Fi and reconnected the dock, and nothing happened. FWIW, lshw on Linux shows the other features of the dock (USB hub/audio interfaces/display outputs), but not the Ethernet adapter. Windows also doesn't show the Ethernet adapter in device manager.

2 Bronze
2 Bronze

Me too - WD19TBS with a Precision 5570.  No sign of an Ethernet device on the docking station.  I even tried a second WD19TBS without success.  Connecting a Dell DA200 - USB-C to multi-ports including Ethernet to the docking stations - works.  But I'd really rather not...

2 Bronze
2 Bronze

Precision 5470 with WD19TBS -same issue. I have also attempted all the same troubleshooting steps. I do get link lights which is extra fun. I expect some "smart" software management package is making decisions somewhere.


Hard dock reset fixed it. Unplug dock and hold power button for 30 seconds. Then re-connect power and laptop and see if that does it.

Latest Solutions
Top Contributor