XPS

Last reply by 06-07-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9310 Disable Waves MaxxAudioPro *PERMANENTLY*

I want my audio inputs and outputs to be clean.  No effects, no EQ, no noise cancelling, NOTHING but clean audio.

Every time I disable it in MaxxAudioPro, it re-enables at some point in the future.  It also defaults to being enabled every time I connect a new device.  I want it to be disabled PERMANENTLY.

I have tried uninstalling Waves MaxxAudioPro and only having the RealTek Audio installed, which results in the audio being effected but having no way to turn it off.

This doesn't just affect the built in speakers/mic, but every device that is connected to the laptop, including USB audio devices.

This is completely unacceptable.  I play audio through studio-grade speakers and headphones.  I do not want ANY effects whatsoever to be added to my sound outputs ***NEVER EVER EVER***

Please help.

Thank you.

Replies (4)
2 Bronze
2 Bronze

Just in case this helps someone else out there...  This is what ended up working:

Add or Remove programs:

  • Uninstall Waves MaxxAudioPro and RealTek Audio Drivers.

Device Manager:

  • In the "Sound, video and game controllers" section, right-click "RealTek(R) Audio" and select "Update Driver".
  • Click "Browse my computer..."
  • Click "Let me pick..."
  • Uncheck "Show compatible hardware" and select "Microsoft" in the list on the left.
  • On the right you should see "High Definition Audio Device".  I had two, each followed by a version number and a date.  I selected the newer one - Version 10.0.22000.1 [6/5/2021].
  • Click Next button.
  • A warning will come up telling you that the driver isn't compatible with the hardware.  Click Yes.

After doing this, everything now works as I wanted/expected it to.  Audio going out the jack is just what I played.  No garbage effects applied to it.

Community Accepted Solution
2 Bronze
2 Bronze

I want this switch to **permanently** remain in the off position, as it is in this screenshot, for all devices:

liflo_0-1653745159153.png

 

I appreciate you trying to help but that post is for a different generation of XPS laptops. 

As far as I can tell, disabling the services (or even uninstalling MaxxAudioPro) causes a default effect to be applied to the audio.  The only way I can disable it is to keep MaxxAudioPro installed and disable it via the MaxxAudioPro control panel. 

This works okay until the next time I connect a new audio device, install a windows update, or some other action that I can't identify (seemingly random every few weeks). 

I just want it to be permanently disabled. 

When I connect in a new audio device, I want it to default to being disabled.

7 Gold

Have you tried opening Task Manager and disabling it in the Startup tab? Also this forum post may help.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with GIGABYTE B560M DS3H AC budget build with an i3 10100
Real work on a Latitude E5430
Top Contributor
Latest Solutions