XPS

Last reply by 06-28-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1879

XPS 13 9310: touchpad doesn't work after sleep mode

Hello,

I received my XPS 13 9310 on December 16th. I had some of the issues described on this forum (including the screen going black for a few seconds). They all have been fixed by drivers updates since.

Another problem persists though. Every so often, like one out of 4 or 5 times, the cursor don't move anymore when the laptop wakes up from sleep mode. The only solution is to reboot it.

It is a MAJOR problem for a laptop. I've seen people with a similar problem but for another XPS model on this forum. I've tried the solutions suggested by the other members, but they didn't work. The problem still happens.

Does someone have a solution ?

Thank you very much !

Replies (8)
Moderator
Moderator
1876

Thank you! We have received the required details. We will work towards a resolution. In the meantime, you may also receive assistance or suggestions from the community members.


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

2 Bronze
2 Bronze
1852

I have no solution for you, but I have the exact same problem (XPS 13 9310, received Dec 8th 2020).  The symptoms have changed over the past couple of months. Most recently, it happens when coming out of sleep, usually after a long period of sleep (overnight).  As you said, it's very sporadic.  Sometimes it just stops working if I leave the laptop idle for a few minutes or after I plug in the power cable.  Sometimes it comes back to life, but will only operate in short bursts.  I'll start using a bluetooth mouse and after a few minutes, check the touchpad and find that it works again.  Restarting is the only sure way to get it working.

1838

Indeed, it is exactly the same issue. Dell is asking me to do a clean boot and to do some troubleshooting but I haven't had the time. Since the problem is sporadic, it will take time... 

1797

I installed the new BIOS (2.0.0) and the problem still occurs, albeit less often.  Sometimes I can "catch" the touchpad when it's about to fail.  I can slide my finger in circles and the cursor at some point will stop moving.  Then lift my finger off, start swiping in circles again and it resumes, but then stops again, etc.  It's definitely not a Windows-specific issue because it happens in Ubuntu Linux as well.  Clean installs don't solve the problem.  Could be a grounding issue with the touchpad hardware.  I've tried different USB type-C power bricks and a powered dock and the problem still occurs.

1651

Hi,

to throw my hat in the ring, I used have this issue with my 2018 XPS 9360 and it affected both Debian and Windows after my laptop slept.

my early 2020 XPS 2in1 does not have this issue in linux or windows.

and my late 2020 XPS 9310 has this issue in ubuntu but registers some input sporadically. I  don’t remember it happening in windows however I only used windows on it for >day.

1648

Just remembered additional piece of maybe relevant info. I know when it’s about to happen on Ubuntu because my WiFi driver crashes and it goes offline. As with the touchpad issue the only way to resolve this is a reboot (fortunately the touchpad & keeb keep working)
2 Bronze
2 Bronze
363

I also have a similar problem with the touchpad on my XPS 15 7590 laptop - in Windows 11 Pro 21H2.

Something interesting I just noticed about this issue:

The mouse pointer will freeze for what seemed like a fixed period of time and then resume but I don't think it's a timing issue...

What I noticed is that if I touch the pad with on finger, the pointer will not move.  When I touch it with a second finger then lift the first, control of the pointer is resumed.  It appears that the driver is ignoring single-finger movement and processing movement after a second finger touch is detected and the first is removed.

I'm happy to provide more information to Dell - just let me know how.

2 Bronze
2 Bronze
231

Similar issue with 2 different Dell laptops here. 

Rather than restarting I get the touchpad working by going to Device manager and Disabling the "HID-compliant touchpad device" and then re-enabling it. I do this all using my keyboard but you could also do it with an external mouse.

Dell please fix this issue

Latest Solutions
Top Contributor