XPS

Last reply by 10-20-2022 Solved
Start a Discussion
3 Silver
1008

XPS 13 Plus 9320, WD22TB4, wake issue

XPS 13 Plus 9320

I've received my XPS 13 Plus 9320 running Windows 11 Pro 64bit (build 22000) and WD22TB4 Thunderbolt Dock connected via USB to a wired mouse/keyboard. Latest BIOS (1.4.0) and drivers all installed. When the PC sleeps I can't wake it from the Mouse or Keyboard connected through the dock. If I reach over and press the XPS keyboard everything works fine - but it is a pain:-). I have unchecked "Allow this computer to turn off this device" power management options in all USB devices and where it is not greyed out checked the "Allow this device to wake the computer" option.  Still no luck! I have had a response from Dell advising to "Disable “Deep Sleep Control" which also stops you having "Fast Start" and this does work, but this makes the start-up and other options slow/clunky! Any other options to allow wake from keyboard/mouse please?

Thanks, Peter 

Solution (1)

Accepted Solutions
232

Well what did I know?  Support Assist updated the BIOS to version 1.8.1 dated 14-Sep-2022 and with no other changes made to they system/dock wake from my WD22TB4 now works after any amount of time!  I could not see this "bug fixed" it the release notes but it works:-).  Peter 

View solution in original post

Replies (11)
Community Manager
895

To receive assistance from Dell, click the DELL-Cares username. On the resulting page, click "Send this user a private message" and share the private XPS 13 Plus 9320 and WD22TB4 Service Tags with them. Or you may click the "Get help now" on the right to Chat with Dell agents.

I am curious about something. Please do this testing =

* Connect the provided AC power adapter to the XPS 13 Plus 9320 left side TB4/USB-C port
* Connect the WD22TB4 to the XPS 13 Plus 9320 right side TB4/USB-C port
* So now using two AC power adapters. Allow the XPS 13 Plus 9320 to enter sleep. Then try to wake it up. What happens? Same issue?

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag


883

Hi Chris, thanks for the idea, I tried it this today. Sadly so far the same experience, when the PC has locked and turned off the screen I can only wake the screen/login by pressing a key on the XPS 13 Plus keyboard.  Will continue continue to test today.  Regards, Peter

878

I should have been clearer in my first reply, I can't edit that for whatever reason, here is what I meant to say:-).  With the set up requested when the screen locks/blanks of course wake up from my USB desktop keyboard/mouse DOES work, it is only when the PC fully sleeps that they won't wake the PC.  Ap[ologies, Peter

Community Manager
772

"it is only when the PC fully sleeps that they won't wake the PC"
Are you referring to S4 hibernate? The Dell BIOS does not support USB wake from S4 hibernate or S5 power off.

Where did you disable Deep Sleep Control? I do not see it in the XPS 9320 BIOS? In BIOS- Power I see Block Sleep (S3).

How is your XPS 9320 entering sleep mode? Lid close/press the power button/leave the system time out to sleep?

What are your Windows System Settings. See picture below as example =

Capture.JPG

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag


3 Argentum
726

Hi Chris, apologies for not being clearer, when I say "sleep" I am referring to what the PC does when left unattended for a longer period of time as defined in Windows 11 Pro, System, Power & battery, Screen and sleep.  In my case when plugged in turn my screen off after 30 minutes and put my device to sleep after 2 hours.

image.png

I am not using S4 hibernate and not referring to S5 power off.

From my notes (I can check again and take photos if you would like?) I had to "Disable “Deep Sleep Control" and to do this I believe I also had to disable fast boot which makes a super fast PC very clunky!  

I was following troubleshooting advise in what I think was a standard, but not accurate for my XPS13 Plus, article pasted in below.

Thanks, Peter

Please go through the information below and reply.

1. Allow the keyboard and mouse to wake up PC

o allow the keyboard and mouse to wake up your PC:

  1. On your keyboard, press the Windows logo key  and R at the same time, then type devmgmt.msc (Device Manager) into the box and press Enter.
  2. Double-click on Keyboards > your keyboard device.
  3. Click Power Management and check the box before Allow this device to wake the computer and then click OK.
  4. Repeat this fix on your mouse device (usually under the category of mice and other pointing devices).
  5. and if any external peripheral are connected try to initiate a wake up from sleep step for the system
  1. Hard shutdown
  1. Press and hold the power button on the front of the computer for approximately 5 seconds. The computer will shut off. No lights should be near the power button. If lights are still on, you can unplug the power cord to the computer tower.
  2. Wait 30 seconds.
  3. Push the power button to turn the computer on again.
  4. If the system is powering up, try to put the system in sleep mode and then recreate the issue again.
  5. If the issue is coming back then choose the appropiate option to go to the next step
  1. Change Power option Settings in BIOS

Follow below steps to change power options in BIOS.

  1. In “Power Management” setting of BIOS please Enable “USB Wake Support” and Disable “Deep Sleep Control”.
  2. Connect Keyboard or Mouse to Smart Power On Connector port.  
  1. Disable Fast Startup in OS.
    • Search for and open “Power options” in the Start Menu.
  • Click “Choose what the power buttons do” on the left side of the window.
  • Click “Change settings that are currently unavailable.”
  • Under “Shutdown settings” make sure “Turn on fast startup” is disabled.
  1. How To Reset a Single Power Plan to Default Settings
  1. Select Start, then select Settings > System > Power & Sleep > Additional power settings.
  2. Open power plan settings
  3. Click on “Change advanced power settings
  4. Switch selected power plan if required.
  5. Click “Restore plan defaults
  1. Update Video driver
  1. Go to http://www.dell.com/drivers
  2. Enter Service Tag/Express Service Code
  3. Select drivers and downloads
  4. Click Service Tag or System Analysis to view list of applicable drivers, firmware, & updates
  5. Select the Video driver from the categories and download/install.
  6. Follow the on-screen instructions to complete the installation

6. Refresh hiberfil.sys file by toggling the switch ( Disabling and Enabling ) this will reset the file if corrupted.
 
Open elevated command prompt ( Type CMD in start menu and hit Ctrl + Shift + Enter )
Copy and paste the command " powercfg -h off " and press enter to disable.
Restart computer and go to elevated command prompt ( Type CMD in start menu and hit Ctrl + Shift + Enter )
Copy and paste the command " powercfg -h on " and press enter to enable.
 
7. Windows Power Troubleshooter.
 
In Windows, search for and open the Control Panel.
In the Control Panel Search field, type troubleshooting.
Click Troubleshooting.
Under System and Security, click Improve power usage.
Click Next to run the troubleshooting tool.
A Detecting Issues window displays while Windows detects and attempts to fix any issues.
After troubleshooting is complete, close the troubleshooter
 
8. Disable Connected Standby on the device
To disable connected standby and to use basic sleep  disable the feature as follows:
 
Start the registry editor (regedit.exe).
Move to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power.
Double-click CsEnabled and set to 0, then click OK.
 
9.Clean boot with MS Config
To perform a clean boot using MS config on the system:
 
From the search box or run command, type msconfig and press <Enter>.
NOTE: You can also use Diagnostic startup on the General tab.
Click the Startup tab. Click Disable all and click Apply.
Click the Services tab. Check the box that says Hide all Microsoft services and then click Disable all.
Restart the system and check if the issue is resolved.
 
To return the Boot Process to a Normal Startup In MSCONFIG
 
Click Start, click Run, type msconfig in the Open box, and then click OK.
Click the General tab.
Click Normal startup.
Click OK.
Click Yes when you are prompted to restart your computer.
 
10. Attempt System Restore
 
Right-click (or press and hold) the Start button, and then select Control Panel.
Search Control Panel for Recovery.
Select Recovery > Open System Restore > Next.
Choose the restore point related to the problematic app, driver, or update, and then select Next > Finish.
 
11. Create New profile and test
 
Swipe in from the right edge of the screen, tap Settings, and then tap Change PC settings.
Click Accounts, and then Click Other accounts.
Click Add an account, and then click Sign in without a Microsoft account (not recommended).
Click Local account.
Enter a user name for the new account.
If you want this person to sign in with a password, enter and verify the password, add a password hint, and then tap or click Next.
Click Finish.
 
12. Try System File Checker option
 
Use the Windows key + X keyboard shortcut to open the Power User menu and select Command Prompt / Windows Powershell (Admin).
Type the following command into the Command Prompt window and press Enter to run a full system scan:  sfc /scannow
Wait for the process to complete. Once done, type exit and press Enter. Restart the machine.
 
13. Attempt DISM Command
 
Use the Windows key + X keyboard shortcut to open the Power User menu and select Command Prompt / Windows Powershell (Admin).
Type the following command and press Enter:
DISM /Online /Cleanup-Image /RestoreHealth
The process takes time to start and complete.
Once done, type exit and press Enter.
Restart the machine.


3 Argentum
726

Adding screen shot of power buttons:

image.png

Community Manager
487

The issue is still "verified no problem" on our platform and dock side in our testing. We need to know how to reproduce the issue. There should be some other BIOS settings the user needs to check, like “USB wake support”, “Wake on Dell USB-C Dock Dependency”, etc. Please list all BIOS settings you see for wake.

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag


3 Silver
468

Thanks Chris, see below.  Please note problem was first reported with BIOS 1.6 and I have now upgraded to 1.8.1.

Attached three BIOS setting screen shots, let me know if I am missing anything you need. 

20220928_210705.jpg20220928_210133.jpg20220928_210412.jpg  

I went through device manager properties for all USB devices shown here

USB Devices.jpg

As before I have unchecked "Allow this computer to turn off this device" power management options in all USB devices and where it is not greyed out checked the "Allow this device to wake the computer" option.  Some of these had changed from when I first posted this problem which I assume happened when I had to load BIOS defaults to get round my XPS13Plus not shutting down on BIOS 1.7 (different post).

Power Management.jpg

Hope that helps, Peter

2 Bronze
2 Bronze
313

This looks a lot like a WD22TB4 related firmware or driver bug.

I also have the WD19TB3 docking station. I am always able to quickly wake up my laptop via keyboard or mouse when using WD19TB3.

My laptop is a Dell XPS 9310 2-in-1 with Windows 11. All Dell Update drivers are current, as well as all Windows updates.

Latest Solutions
Top Contributor