XPS

Last reply by 10-04-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1127

XPS 13 Plus ubuntu 22.04 does not support deep sleep

Under the balanced energy scheme, the laptop is draining battery at a rate of about 1% per minute or two. If I change this to power saving, it takes a bit more. Still, even with minimal usage, the battery does not last for more than 2 hours.

Even during sleep, the laptop is draining battery. After examining the /sys/power/mem_sleep I get only the [s2sleep] option. I cannot find how to activate deep sleep. I tried adding the `mem_sleep_default=deep` boot option but without any success.

Any help would be appreciated.

Replies (14)
3 Zinc
817

What BIOS revision are you on, have you ran diagnostics in the BIOS and how did you install Ubuntu?

2 Bronze
2 Bronze
811

My bios version is 1.8.1

I downloaded the 22.04.1 LTS desktop image from canonical's web site and installed it via a usb drive. The kernel version is  5.15.0-48-generic.

809

Please run the diagnostics in the BIOS and report back the results. You mentioned the "balanced" energy scheme. Are you referring to the optimized performance mode which you can toggle to in the BIOS? (there are three other modes [ultra performance cool and quiet]). The laptop getting proper sleep might be a tricky one because Dell no longer supports S3 sleep only S0. So please follow up and then maybe I could research more about how they were supposed to implement it in Ubuntu.

2 Bronze
2 Bronze
805

All pre-boot diagnositics test pass. In the bios setting I picked the "Cool" option as I was getting extreme temperatures on the bottom part of the laptop - it was quite inconvenient having it in my lap...

The "balanced" goes to the ubuntu scheme.

I also read that S3 is no longer supported, so I am wondering if there is a way to reduce power drain during suspend... any help would be great!

3 Zinc
803

Allegedly if you install Ubuntu 22.04LTS fresh it will pick up that it is a Dell XPS 13 Plus and make the relevant adjustments. Try running all updates through Ubuntu as well as seeing if there is some sort of driver manager (I know Linux Mint has something like that so I'm sure Ubuntu does as well). Report back with what happens, the last resort would be PMing Dell and maybe they can send you their Ubuntu image that they ship out with.

2 Bronze
2 Bronze
798

I have done all the updates through apt making sure that nothing was held back.

On the software update, under the additional drivers it reports that the laptop is using 2 alternative drivers, one for the camera and a second one from oem-somerville-tentacool-meta that is commented as "hardware support for Dell XPS 9320" without any further information.

Maybe at this point I should PM dell support.

3 Zinc
797

Sounds like the second one is the package that Ubuntu says would help for specific XPS 13 Plus hardware support. Please do keep us updated on Dell and their response to your ask for their image.

3 Zinc
785

Also ran across this forum post that is a good read for your situation Solved: Pros/Cons: AHCI vs. Raid On (XPS13 9300 NVMe) - Dell Community

2 Bronze
2 Bronze
769

I did switch from RAID to AHCI however I still get [s2idle] as the only option.

Latest Solutions
Top Contributor