XPS

Last reply by 05-31-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9520 stuck in boot loop once joined to domain

We have recently purchased an XPS 15 9520 for one of our users. I have an issue where once this machine is joined to our domain and restarted it goes into a boot repair loop. The only way to fix this is to re-install Windows again. Then, when off the domain the laptop can be restarted without issue.

So, the only thing I can think of is that once joined to the domain the laptop is picking up the default domain group policies. I work in a fairly high security industry so there are various group policies in place. The odd thing is that we have a vast amount of laptops that are 'domain joined' without issue. The only difference is that this machine is relatively new. 

I was wondering if anyone else has experienced this?

Thanks very much for any assistance.

Replies (3)
2 Bronze
2 Bronze

Just an update on this as I have found the solution and it might help someone else. As mentioned the laptop fails to boot once the machine inherits the domain GPOs. 

The GPO setting responsible adds in the following registry setting:

Name: FeatureSettingsOverride
Value Name: FeatureSettingsOverride
KeyPath: SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
Value Type: REG_DWORD
Value Data: 00002048
 
This particular setting was a Cyber Essentials issue and addressed execution issues as described here: https://support.microsoft.com/en-us/topic/windows-server-guidance-to-protect-against-speculative-exe...
 
The fix was to reduce the FeatureSettingsOverride decimal value to 72. The 2048 value is the setting for maximum protection with hyperthreading disabled.
 
For the type of laptop we had 'XPS' this was the root cause. There are other ways around it by setting up GPO filtering based on CPU type.
 
Hope this is of some help to someone.
 
 
 
Community Accepted Solution

Hi Mary, thanks for your reply. Unfortunately, as you can see from my original post, the machine was already on a version of Windows that could join a domain 'Windows 10 Pro' as the issues started after I joined our domain.

This morning I have filtered out the computer name from picking up any of the domain GPOs. This has worked and allowed me to restart and log back into the domain. It also proves one of the GPOs is causing the issue. I plan to re-introduce the GPOs back into the domain one by one until it breaks. From there, I just need to work out what specific setting is causing the issue.

Many thanks. 

7 Thorium

Maybe the version of Windows is the Home version which cannot join a Domain. Upgrade to the Pro or Enterprise version.

Top Contributor
Latest Solutions