XPS

2 Bronze

XPS 15-9560, weird keyboard issue

I just noticed a strange keyboard behavior. I don't know it it is just a hardware keyboard problem or it's a common issue.

- When I hold toghether "r" and "t" keys and press "w" key holding "r" and "t" pressed, caps lock turn on or of

- When I hold toghether "r" and "t" keys and press "u" key holding "r" and "t" pressed, the letter typed is one time "y", one time "u"

- When I hold toghether "r" and "t" keys and press "e" key holding "r" and "t" pressed, the sound volume is increasing

- When I hold toghether "f" and "g" keys and press "j" key holding "f" and "g" pressed, the letter typed is one time "h", one time "j"

-The same strage behavior is for "v" and "b" keys holded toghether

 

So strange behavior for "r" + "t", "f" + "g" and "v" + "b" holded toghether + a next to them key pressed (in the left or right of the group) is just for me or anyone else does have it?

Replies (11)
7 Thorium

Remove the base cover and check the battery -- are there any signs it's swelling up?

I checked, everything is OK. The laptop is a couple of months old. Looks to me like a BIOS problem or keyboard problem. BIOS version in 1.8.1.

So, this is a bug in 1.8.1 BIOS. Rolling back to 1.7.1 version, everything went back to normal. I was observed this problem when typing quickly in WORD, words the have "tre" sequence letters (the sound volume was increasing). Where can I report the problem to Dell, so they can take care of this issue in the next BIOS versions?

Thank you for the message. We will be glad to assist you on this.

Have you tried using an external keyboard or the on-screen keyboard while you were on Bios version 1.8.1 did the issue persist with this?

When did you upgrade to version 1.8.1? Did you upgrade from our Support site or did you get any notifications on Dell Support Assist asking you to upgrade?

For my reference, please click on the message tab next to your avatar– click “New Message” & search for my Dell username (Dell-Sreejith R) & send a private message with the service tag, registered name & email address.


Dell-SreejithR
Social Media Support
#IWork4Dell

Hello,

I update bios o 20.03.2018, first day the update came out, I wwas watching your page http://www.dell.com/support/article/ro/ro/robsdt1/sln308587/microprocessor-side-channel-vulnerabilit... for fixing intel vulneabilities and as soon as I saw the update, i did it.

Two days ago I was typing in Microsoft Word a project and I observed that sometimes volume was increasing without pressing F3 key, not once but many times. Then, I tried to realize what could cause these thing and I found that when I was typing (very quick) the word ("trebuie" - in Romanian  = have to) the volume was increasing. Thirst thing that came out of my mind was: keyboard problems. So I tried in a separate document to see exactly what is happening. So I realize that holding toghether "4" + "5" keys or "r" + "t" keys or "f" and "g" keys or "v' and "b" keys and while holding one of these combination I press another key from the same line of letters, the typed letter is not the letter that should be typed. One of the combinations "t" + "r" + "w" made capslock to turn on. I thought that maybe it is the cable from the keyboard or maybe the keyboard. Next step it was to reproduce the bug with Windows screen keyboard and after that with Kaspersky virtual keyboard, but without succes. So, for the moment I conclude it is a hardware problem. Next step was to go to Bios setup and try the "tr" +"w" combination because was the single found combination that could have visual effect in bios (capslock light turn on) and the issue was present. After that I decided to open (for the first time on this laptop) the case and see if it is something wrong inside (by the way, I'm working in IT field and I know what I am doing). I did not see anything wrong but I take advantage of opening the case I repasted the cpu and gpu. After a break I was trying to figure out what could had happened as these sequence of keys "tre" I was typing and few days ago. I remembered that I updated the Bios, so I went back to Bios, check "downgrade bios" and I decided today to put back 1.7.1. After reverting back the issue was gone. So dind't try with another  physical external keyboard.

Hola guys,

Same exact issue on a Dell Latitude 5580, BIOS Version/Date: Dell Inc. 1.9.3, 08.03.2018.

In addition to sequences listed above, these also show up:

* N+J+Space = "nj\"
* N+M+Space = "nm<Enter>"

Plus some more.

Cheers,
Alex

 

Hi I'm having the same issue. Anyone found a solution for this?

BIOS update fixed the problem.

i updated the bios to 1.11.0 yesterday and the same issues persist, the key strokes get jumbled up when you type in word at a natural speed, you find the cursor moves to random positions. 

Top Contributor
Latest Solutions