XPS

Last reply by 01-31-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze
372

XPS 15 9560, won't charge

XPS 15 9560

My XPS 15 does nog charge

Symptoms

- Only boots with charger connected.

- Cannot remove the charger. The laptop shuts down immediately 

- Battery keeps stuck at 19%

- "Time of day not set error", when starting up

- "Chargelight" under the mousepad flickers orange continuously

- Battery charge indicator (with 5 lights) lights the first (1), third (3) en fifth (5) light when pressed

 

What I did so far

- Replaced battery (original Dell)

- Replaced CMOS (ML1220)

- BIOS and other update

 

Do you guys have suggestions? Replace powerjack?

Thank you in advance!!!

 

Rozema

Replies (11)
2 Bronze
2 Bronze
317

<Duplicate post. Merged to 1st post. DELL-Admin>

307

1.  Run diagnostics via F12

2.  Try charging thru USB-C (thunderbolt) port.

8 Platinum
308

I wonder what model XPS-15 laptop it is?

The RTC errors (even after replacing CMOS coin-like battery) is troubling. Did you default/reset BIOS afterwards? If not, do so. Did you check it's voltage before installing?

Maybe try a different AC-Adapter. I thought most XPS-15 models have a place inside BIOS that shows if proper AC-Adapter is connected (I think it has to be working to show it). Also, there should be a place that shows run-battery health.

@Rozema ,

I just edited and added another tip. 


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
298

Thanks for helping!! Update

 

I restored the BIOS settings. Now the "time and date not set" error is gone. 

I did not check the voltage of the CMOS. It should be 3V

 

This week I will visit a friend with a AC adaptor which I will try. 

If that does not work, I will first replace the AC jack.

 

I ran the diagnostic mode and got these screens:

image_50386433.JPGimage_50388737.JPG

296

The system is not recognizing the main battery.  You may want to see if your battery supplier will replace it under whatever warranty they provided.

If a replacement battery is also not recognized (and particularly if that's what happened to the original battery as well), it likely means you have a problem with the mainboard.

 

287

The new battery you got may not be genuine Dell batt for that model, therefore not recognized.

the 130w ac adapter you are using is good, therefore no need to replace it. Thus also means the DC jack is good.  Your problem is the battery itself.


292

It does look like your battery failed the diagnostics test.  At diagnostics screen, hit Esc key twice, it would pause the test, click on right arrow at bottom right of screen bring you to advance display.  System health tab will display your battery and AC adapter with voltage info.  Configuration tab will tell you more about battery cycle, mfr date and health. 

For privacy, try to make change to your post but it passed the allowed time, requesting Mods to remove service tag info for you (in picture).

Many error code 2000-0131 issues can be resolved by reset, reseat, replace the battery.  Worse case could be mobo issue as indicated by other member.

I would hold off on the AC jack replacement as it's a low possibility of the cause.

290

Thank you kindly for your help! Really appreciated!! 

I started with replacing the battery. I bought a original one. Replacing did not help. After that I replaced the CMOS, now the “time and date” error is gone. 

Tomorow I will replace the original battery back again and see what happens. 

All the help really appreciated!

218

You certainly are welcome.  Post back the progress, it may help others with same issue.

Latest Solutions
Top Contributor