XPS

Last reply by 07-04-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1920

XPS 15 9575 - creating a recovery USB - unhelpful Dell software

I'm trying to create a recovery USB and when I run Dell's Direct Key Creator I'm faced with the screen below.

What the hell is going on here?

This screen is VERY unhelpful.  What is IDS_TITLE, IDS_DISK_TO_USE, IDS_DISK_DESC?

I have a single USB memory stick (16GB) plugged into my computer.

Which drive can I tell it's about to write to?  Doesn't state clearly that's my USB memory stick.

I'm a little hesitant to continue from here.

IDS_TITLE.png

This screen is the least useful and explanatory I've ever come across.  I pity users of lesser experience faced with this screen.  I lead software development efforts, and this program would definitely not make it past development, let alone QA. 

Come on Dell, what kind of product QA do you guys run on your software products?

Labels (2)
Replies (2)
2 Bronze
2 Bronze
673

I had this problem to with my laptop.  Basically, the software is looking up your computer language and then tried to display the appropriate text for your language but could not find it - hence those weird labels.  For me, because I live in UK, I set it up as english but unfortunately, its the wrong english!  The software only seems to work with one type of english and thats US english!

So, the solution is to change your language in windows to US English, say the magic word "pants", and then try the software again - hopefully it would work this time.

For any other languages, there is an "xml" file in the directory of the program, and inside that file, there contains various languages it supports - so may be worth looking to see if it supports your language and help you choose your next common language you know.

To be honest, I don't think you missing out - its just a standard windows 10 media disk, but I could be wrong.  And that software should have asked for language the first place!

49

Thanks, this solved the problem. I had my computer set to English - Australia and had exactly the same issue. Changed to English - USA and it worked. So stupid - who would have known to do that? I agree, it's a very unhelpful process.

Latest Solutions
Top Contributor